Link errors in building l4t-multimedia-samples(v4l2cuda)

I’m having some trouble building and running the l4t-multimedia-samples(v4l2cuda) that come with the SDK.
I’m following the steps on this page → [L4T Multimedia API Reference: Building and Running]

Skipped step 2 of the ‘Building and Running’ section because CUDA,Opencv4tegra,cuDNN, and TensorRT were already installed (through the NVIDIA SDK Manager, during setup and OS flashing). I’m not using a host Linux system either, so skipped step 4 too.

The sample was located in /usr/src/jetson_multimedia_api/samples.When I run ‘sudo make’, I’m getting this error:
(base) XXXXXXX@ubuntu:/usr/src/jetson_multimedia_api/samples/v4l2cuda$ sudo make
Linking: capture-cuda
/usr/bin/ld: cannot find -lEGL
/usr/bin/ld: cannot find -lGLESv2
collect2: error: ld returned 1 exit status
make: *** [Makefile:51: capture-cuda] Error 1

What is causing the problem, and how can it be resolved?
Thanks in advance!

My Jetpack version is jetpack5.0.1-developer-preview-with-jetson-linux-34-1-1

R34 (release), REVISION: 1.1, GCID: 30414990, BOARD: t186ref, EABI: aarch64, DATE: Tue May 17 04:20:55 UTC 2022

Thanks for reporting it. We will check this.

I solved this issue by replacing the following cmd
$ sudo ln -sf tegra-egl/
$ sudo ln -sf tegra-egl/


$ sudo ln -sf tegra-egl/
$ sudo ln -sf tegra-egl/

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.