Link Errors with release 1.0

Since I upgraded my 0.8 beta to the 1.0 release I now have link errors like the following:

Error 1 fatal error LNK1181: cannot open input file ‘.\debug\cppIntegration.obj’ cppIntegration

The first time I installed 1.0 I let the installers uninstall my old version of 0.8. I have since uninstalled and reistalled all of the CUDA software, each time deleting the C:\CUDA folder as well as the Nvidia Corporation folder under Program Files. I’ve even removed all CUDA references in the registry. These link errors are occuring with the new SDK examples so its not a backwards compatability issue and it happens with every project in debug, release, emudebug mode etc. I tried running the command line script to creates the cppIntegration.obj file. I copied the string from my friends PC that when run in the command line makes the nvcc.exe create the file and it generated output in the command prompt as well. When I copied the exact string to my PC I recieved no errors, but also no additional output and no file. Any ideas? Thanks

I’ve since uninstalled all the Cuda stuff as well as Visual Studio 8 then reinstalled VS8 and Cuda and still get the same error.

Don’t know if this helps, but here is my cppIntegration.cu custom build step:

$(CUDA_BIN_PATH)\nvcc.exe -ccbin "$(VCInstallDir)bin" -deviceemu -c -D_DEBUG -DWIN32 -D_CONSOLE -D_MBCS -Xcompiler /EHsc,/W3,/nologo,/Wp64,/Od,/Zi,/RTC1,/MTd -I"$(CUDA_INC_PATH)" -I./ -I../../common/inc -o $(ConfigurationName)\cppIntegration.obj cppIntegration.cu

The “outputs” item contains: $(ConfigurationName)\cppIntegration.obj

This is a wild guess, but have you checked if your environment variables are correclty pointing to the 1.0 version?

Thanks for the reply, my custom build step is identical to yours. My environment variables seem to be correct as well and are:

CUDA_BIN_PATH C:\CUDA\bin

CUDA_INC_PATH C:\CUDA\include

CUDA_LIB_PATH C:\CUDA\lib

I’ve successfully installed Cuda 1.0 on my home pc as well as a co-workers, but neither of those PC’s had a previous version of Cuda. The only thing I can think of is a path or file thats not being removed when I unistall cuda, delete the folders, edit the registry and remove listings with Cuda, and unistall visual studio 2005 and delete its folder as well. Any more ideas?

I can’t offer much help, but I have also gotten linking errors after upgrading to CUDA 1.0 from CUDA 0.8. Are there lots of other people with this problem? I still have not gotten the new SDK examples to work. I’ll post if I figure anything out.

I have just downloaded the 1.0 SDK and some examples get compilation errors. It seems that they don’t find “glu.h” and “gl.h” in the “common\inc\GL” directory.

I have replaced this files with some of my own, don’t ask me where I have got them. But it still show compilation errors.

LINK : fatal error LNK1104: cannot open file ‘winmm.lib’

There is a winmm.dll library in the windows sys directory, but cuda is looking for the static one.

:thumbsdown:

Nevertheless the problems seems that come from the examples that includes integration with opengl.

I have just upgraded to Cuda 1.1 and have the exact same problem. I unistalled all of the previous 1.0 stuff and made sure to delete the orignal folders. I then installed 1.1 i the order specified, but I still get the same error. Has anyone since come across this? Thanks

Is the file (cppIntegration.obj) being generated? Is it in the correct folder?

Investigating the build output html file often helps (ctrl-click on the link).

You correct that the file is not being physically generated. I can even switch the output folder to be something known like c:\ and it never appears there.