Linker errors after upgrading to VS 2010

I had been working with VS 2005 and had integrated CUDA into my project. Everything worked fine, except support for 2005 started to drop off as 2008 has been out for a while and 2010 just released. So I have been upgraded to 2010. I’ve read numerous posts about how 2010 isn’t yet supported and all the tricks and work arounds about pointing nvcc.exe to an earlier version so that it will compile CUDA code. I even checked the “unofficial patch” from the nexus post, which by the way seems to only work for CUDA 3.0 and bugged out since I have 3.1 installed. I seem to have successfully gotten the code to compile by pointing nvcc.exe to cl.exe from VS 2008 Express. My problem comes up when it tries to link, apparently it does not know where to find the function definitions that are in my .cu files. So everything compiled and linked ok in 2005, but now I’m in 2010 and it’s stuck on linking. I have not been able to find any posts related to this so I figure it must not be such a common problem. I’ve tried upgrading the old solution, creating it from scratch and both with the same results. I have cudart.lib listed as a dependency and I assume it knows where it is otherwise it would throw an error saying it can’t open that file. Any ideas on how I might solve this problem?