Linux | Cannot run vulkaninfo

Hi, I’ve installed the 64-bit Linux driver, 355.00.26, and the Vulkan SDK. I’ve got X configured to work with a K4200 and K2200. When I try to run any of the examples or vulkaninfo, I get this error:

INFO: [loader] Code 0 : Found manifest file /etc/vulkan/icd.d/nvidia_icd.json, version “1.0.0”
ERROR: [loader] Code 0 : ICD ignored: failed to CreateInstance and find entrypoints with ICD
/home/jeremy/Development/LunarG/Vulkan/LinuxSDK/LoaderAndValidationLayers/demos/vulkaninfo.c:693: failed with VK_ERROR_INITIALIZATION_FAILED

strace indicates that the various nvidia .so files can be opened. Is there anything else I should be checking?


i had the same problem when trying with two GTX660Ti, but when i removed one of it, it worked.
Sounds like a bug in the driver to me.
Greets, Dewayne

Thanks Dewayne, removing one of the cards worked.

I had the same problem using ubuntu, one GTX Titan Black and one GTX 980, i just updated the driver to version 355.00.29, now it is working.


ubuntu studio 16.04 with …17 kernel and last nvidia driver Vulkan SDK ver 1.08 works