NVIDIA Linux 370.28 / Vulkan 1.0.26 Failures with Vulkan tutorial samples

Hello,

I am using current drivers (370.28) and Vulkan SDK 1.0.26 with a computer that has a Quadro 2000 (GF106GL) - which should not support, and I am in fact not using it to drive any monitors and have removed it as well with the same effect. My other card is a Quadro K2000 (GK107GL) which your site says is supported, but I can’t run the cube sample and vulkaninfo returns /home/dayd/Downloads/VulkanSDK/1.0.26.0/examples/vulkaninfo.c:675: failed with VK_ERROR_INCOMPATIBLE_DRIVER. Can someone tell me what I am missing? Do I need to downgrade my drivers?

Thanks!

I in fact tried downgrading - no luck there. Other suggestions- sort of frustrating…

I had kind of issue like you but on Windows:

I normally use GTX1060 as my GPU but while solving some Vulkan driver issues, I tried to remove the card from my PC and use integrated graphics of my i7-6700K. So I also uninstalled everything Nvidia related stuff, installed Intel beta driver to run Vulkan but it didn’t work.

The Vulkan app always found some nvidia related dlls as far as I could see in my IDE output.

Then, Vulkan error out of host memory appeared which indicates I don’t have proper Vulkan GPU…
Maybe clean OS install would solve this multiple GPUs problems. I put back my GTX and didn’t try anything else…

Appreciate the suggestion, but a complete reinstall is not possible, plus I don’t have any integrated graphics to contend with - only one driver. Either way, based on my understanding, it should detect devices and let you select which ones to use, so something isn’t working right or I missed some steps. Thanks!

I figured it out. My package manager wasn’t copying the “nvidia_icd.json” file. I extracted the driver archive and just changed the api version in it to match and copied it to the icd.d directory I have the loader searching and everything seems to work - I can run the examples any way. I am sure that after correcting the environment where it needs, everything else will work as well - just have not had time to verify it.

If you are on Gentoo out there - use the latest nvidia-drivers, emerge it as normal. Then , after setting up the Vulkan SDK, grab the runfile for the nvidia-drivers from your distfiles directory, extarct it by running the .run file with --extract-only. Grab “nvidia_icd.json” and put it where you configured the loader to search for icd.json files. The you should be able to run the examples - at least that is what worked for me - even with both my cards (1 unsupported) installed.

Thanks!

That’s good news! I’m actually on windows so I will have to figure it out by myself. I have only virtual Ubuntu so it’s not for Vulkan…

But thanks

I looked up this document: https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers/blob/master/loader/LoaderAndLayerInterface.md

There is a chapter “Properly-Installed ICDs” for different OS.

I had a problem that 32bit Vulkan apps were crashing, 64bit were OK.
So I checked Windows registry according to this doc and there were two 32bit json files, one of them was from Intel, so I deleted it (I don’t use integrated GPU) and now everything works!!

Vulkan apps were apparently trying to load Intel driver instead of Nvidia, which is not present anymore…

You did the same thing, just by yourself and on Linux ;-)