Vulkan driver installation cannot find compatible graphics hardware

I’m trying to install the Vulkan driver on my laptop, but keep getting an error saying:

NVIDIA Installer cannot continue
This graphics driver could not find compatible graphics hardware

The laptop is an Optimus-based system with a GTX 970M running Windows 10, 64 bit.

I’ve made sure that I downloaded the correct version of the driver (it’s filename is 356.39-vkonly_geforce_win10_64bit_international.exe). I’ve also tried forcing the driver to use the NVIDIA gpu by right-clicking on the executable & choosing “Run with graphics processor” -> “High performance NVIDIA processor”. Neither of these works.

I currently have version 361.75 of the GeForce Game Ready driver installed.

Help…?

Bump.

Does the Vulkan driver support the GTX 970M? None of the ‘M’ models are listed as being supported on the driver’s web page, but other responses here have indicated that at least some of them are.

I’ve found this thread, which suggests modifying the .inf files that ship with the driver:

https://forums.geforce.com/default/topic/513621/installer-cannot-continue-the-graphics-driver-could-not-find-compatible-graphics-hardware-installer-/

…but I’d like to know whether my GPU is actually supposed to work with this driver before I head down that route.

Can anyone help?

Thanks for reporting this.

GTX 970M is not officially supported by our Vulkan beta driver, but will be by the time we have Vulkan support in our regular release drivers.

Regards,

Mathias

That’s a shame, but thanks for letting me know.

Out of curiosity, did you over-install an existing driver before installing the Vulkan beta driver?

If you uninstalled a previous driver, Windows might have installed another driver from its driver store or from Windows update while you were attempting to install the Vulkan beta drivers.

I was installing over an existing driver, version 361.75 of the Game Ready driver (which was installed via GeForce Experience rather than Windows Update, in case that matters).

I’ve since upgraded to 361.91 of the Game Ready driver. I tried installing the Vulkan driver again after upgrading, but with the same result.

I’ve just seen this list of Vulkan-compliant graphics cards on the Khronos website:

which lists the GTX 970M as being Vulkan compliant for Windows 10 64 bit.

So does that mean it is supported after all? I’m not sure how it could be considered compliant without driver support…?

I’ve managed to get the Vulkan driver installed!

I had to do two things to get it to install:

  1. Add an entry to the relevant .inf file - nvaci.inf in my case - with the PCI device & subsystem ID for my laptop.
  2. Reboot and disable driver signing.

For #1 I followed this guide.

http://null-bin.blogspot.co.uk/2015/08/how-to-modify-nvidia-notebook-driver.html

It mentions that you need to boot with driver signing disabled (step 8) but doesn’t say how to do it. Fortunately this comment explains how:

https://forums.geforce.com/default/topic/513621/geforce-mobile-gpus/installer-cannot-continue-the-graphics-driver-could-not-find-compatible-graphics-hardware-installer-/post/3727581/#3727581

Having done those two things - and making sure to run the installer as an administrator - the install succeeded & I’ve been able to run the vulkan choppers demo.

Now I have to figure out why the vulkaninfo utility from the LunarG SDK is just giving me a black window…

Hi Vilya,

Sorry for the trouble you had to go through and thank you for your persistance!

Our Vulkan beta driver comes from a different/earlier driver branch than the branch from which our regular driver releases are created from. As such it’s very much possible that your specific GPU device id was not known when we created that branch. This won’t be an issue though in the future once Vulkan is part of our regular driver releases that can be downloaded e.g. via the GeForce Experience application.

Vulkaninfo is not expected to render anything, it’s printing out information about your Vulkan implementation to stderr I think, which you could redirect to a file from the command prompt with “>”.

However tri.exe and cube.exe from the LunarG Vulkan SDK should render a triangle and cube respectively.

Mathias

P.S. Could you share (possibly as a private message) the line with the device id that you added to the .inf file so I can double check?

Hi Mathias.

As far as i’m concern, i had the exact same problem but with my 960M.

I add “%NVIDIA_DEV.139B.1090.1043% = Section060, PCI\VEN_10DE&DEV_139B&SUBSYS_10901043” in nvami.inf in order to force the driver to accept my ID.

I now run and compile Vulkan with no problem.

Hope that helps :)

Hi, sorry for the slow reply - I’ve been travelling for work. The lines I added to nvaci.inf were:

%NVIDIA_DEV.13D8.2456.1458% = Section027, PCI\VEN_10DE&DEV_13D8&SUBSYS_24561458

(in the [NVIDIA_SetA_Devices.NTamd64.10.0] section), and

NVIDIA_DEV.13D8.2456.1458 = "NVIDIA GeForce GTX 970M  "

in the [Strings] section.