MBF2H332A, can not save ovs configuation

FW ver is 24.39. BFB is 2.5.1 Ubuntu Prod version.

Today, I try to config firefly service in this DPU.

First, I use ‘mlxconfig -d reset’ command and
mlxconfig -d set REAL_TIME_CLOCK_ENABLE=1.
I confirm DPU is Embedded mode.
Then reboot server.

ovs hw-offload is true.
firefly yaml version is 1.3.1
I run this scripts:
sudo ./doca_container_configs_2.6.0v3/scripts/doca_firefly/1.3.0/prepare_for_embedded_mode.sh 4
sudo ./doca_container_configs_2.6.0v3/scripts/doca_firefly/1.3.0/set_new_sf.sh 0000:03:00.0 5
sudo ./doca_container_configs_2.6.0v3/scripts/doca_firefly/1.3.0/set_new_sf.sh 0000:03:00.1 4

and confirm by

sudo ovs-vsctl show

Then
sudo ethtool --set-priv-flags enp3s0f0s4 tx_port_ts on
sudo ifconfig enp3s0f0s4 192.168.1.100 netmask 255.255.255.0 up
sudo route add default gw 192.168.1.1
sudo ovs-vsctl set Bridge uplink mcast_snooping_enable=true
sudo ovs-vsctl set Bridge uplink other_config:mcast-snooping-disable-flood-unregistered=true
sudo ovs-vsctl set Port p0 other_config:mcast-snooping-flood=true
sudo ovs-vsctl set Port p0 other_config:mcast-snooping-flood-reports=true
sudo ovs-ofctl add-flow uplink in_port=en3f0pf0sf4,udp,tp_src=319,actions=output:p0
sudo ovs-ofctl add-flow uplink in_port=p0,udp,tp_src=319,actions=output:en3f0pf0sf4
sudo ovs-ofctl add-flow uplink in_port=en3f0pf0sf4,udp,tp_src=320,actions=output:p0
sudo ovs-ofctl add-flow uplink in_port=p0,udp,tp_src=320,actions=output:en3f0pf0sf4

firefily service is running by ‘sudo crictl ps’ command to confirmed.

This command out put is right.
sudo ovs-ofctl dump-flows uplink

But, no out put when I use this command to check status.
sudo tc -s -d filter show dev en3f0pf0sf4 egress

The document said. This problem is ovs problem. Please make sure hw-offload is true.
I confirm the ovs hw-offload is true.
But, when I reboot DPU. The ovs configuation is gone.

How can I fix this problem?

hi empire4th

You should store the config in OVS config file.
For example:

Thank you
Meng, Shi

Thanks!

I’ll try it