MBP Core2Duo GeForce 8600M GT Query Device Fails

My graphics card is GeForce 8600M GT with the capability shown below and when I run deviceQuery the GPU is not available.
The environment variables added to my .profile are also shown below.
Any suggestions welcomed.
This is running OS X 10.5.5 with the latest CUDA SDK and toolkit downloads.


Chipset Model: GeForce 8600M GT
Type: Display
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0407
Revision ID: 0x00a1
ROM Revision: 3212
Color LCD:
Display Type: LCD
Resolution: 1440 x 900
Depth: 32-bit Color
Built-In: Yes
Core Image: Hardware Accelerated
Main Display: Yes
Mirror: Off
Online: Yes
Quartz Extreme: Supported
Display Connector:
Status: No display connected

I get this result when running device query

Developer/CUDA/bin/darwin/release/deviceQuery ; exit;
There is no device supporting CUDA.

Device 0: “Device Emulation (CPU)”
Major revision number: 9999
Minor revision number: 9999
Total amount of global memory: 4294967295 bytes
Number of multiprocessors: 16
Number of cores: 128
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 16384 bytes
Total number of registers available per block: 8192
Warp size: 1
Maximum number of threads per block: 512
Maximum sizes of each dimension of a block: 512 x 512 x 64
Maximum sizes of each dimension of a grid: 65535 x 65535 x 1
Maximum memory pitch: 262144 bytes
Texture alignment: 256 bytes
Clock rate: 1.35 GHz
Concurrent copy and execution: No


Press ENTER to exit…


[Process completed]

My .profile includes

export PATH=/usr/local/cuda/bin:$PATH
export DYLD_LIBRARY_PATH=/usr/local/cuda/lib:$DYLD_LIBRARY_PATH

Did you install the CUDA toolkit & reboot?

Short answer yes.
Longer answer:
Not immediately but after installation
some things appeared to work then deep excitment set in.
So then tried to run marcing cubes which hung
then rebooted, then tried mandlebrot
hung and crashed.
Then reinstalled kit and cleaned tree and rebuilt apps.
My post reflects state after all of above.
In addition I turned off spaces and rebuilt.
The only other factor I can think of off hand
is I use the Xshade haxie.
What prompted the Q.

Now checked previous posts and spotted that the CUDA.kext was not installed by default so reinstalled.

Then invoked the install options to install CUDA.kext cleaned, rebuilt.

Success CUDA device detected and Mandlebrot works fine.

Can’t wait to get a more capable card in a Mac Pro or Linux box keep up the good work this is fantastic stuff.