memory utilization how to make sure frame buffer is not occupying space

I’m trying to utilize roughly 95% of my cards memory. This seems to be failing due to the fact that it is connected to the screen. Can i simply connect my other GPU to the screen and then this card will be guaranteed to not be allocating any frame buffer memory?

Or do i need to do some sort of “compute mode” setting ?


The answer to that is probably no.

But the exact reasons why, and whether (or if) you can do something else to let you allocate the memory you need, depends on which operating system, card and driver type you are using. Compute mode (as it exists on Linux and the Tesla TCC windows driver) is something different - it lets you control whether a card is available for compute jobs and whether to limit the number of active contexts permitted per card.

hmmm have had similar issue!

263.06 - developer drivers
GT 240 - 1GB - usually for screen
GTX 570


If it can be done on WDDM versions of Windows (and I don’t know whether that is the case or not), it probably involved registry key hackery at a minimum. Even then you should expect to loose 50-100Mb of memory to the CUDA context itself. Also WDDM imposes a limitation on how much GPU memory can be reserved in a single allocation. If you have less than 3Gb of memory, the OS won’t let you allocate almost 1Gb of GPU memory in a single call.

Thanks. I restarted my computer and switched the cable around. Seems to work, unclear exactly why though.