Minimizing Storage Usage on Jetson

Originally published at: https://developer.nvidia.com/blog/minimizing-storage-usage-on-jetson/

Some NVIDIA Jetson modules have limited storage space, which imposes a challenge in packing applications and libraries. Here are ways to cut down on disk usage.

This breaks everything. Tried to install python3.8 packages, got this:

$ sudo apt install python3-pip python3.8-dev python3.8-venv -y

Reading package lists... 4%
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 cuda-command-line-tools-10-2 : Depends: cuda-cupti-dev-10-2 (>= 10.2.89) but it is not going to be installed
 cuda-cupti-10-2 : Depends: cuda-cudart-dev-10-2 (>= 10.2.89) but it is not going to be installed
 cuda-toolkit-10-2 : Depends: cuda-samples-10-2 (>= 10.2.89) but it is not going to be installed
                     Depends: cuda-documentation-10-2 (>= 10.2.89) but it is not going to be installed
                     Depends: cuda-libraries-dev-10-2 (>= 10.2.89) but it is not going to be installed
                     Depends: cuda-nvml-dev-10-2 (>= 10.2.89) but it is not going to be installed
 libcudnn8-doc : Depends: libcudnn8-dev but it is not going to be installed or
                          libcudnn8-dev-cross-aarch64 but it is not installable
 libvisionworks-sfm-dev : Depends: libvisionworks-samples (>= 1.6.0) but it is not going to be installed
 libvisionworks-tracking-dev : Depends: libvisionworks-samples (>= 1.6.0) but it is not going to be installed
 nvidia-l4t-jetson-multimedia-api : Depends: cuda-cudart-dev-10-2 but it is not going to be installed
 python3-pip : Depends: python-pip-whl (= 9.0.1-2.3~ubuntu1.18.04.5) but it is not going to be installed
               Recommends: python3-dev (>= 3.2) but it is not going to be installed
               Recommends: python3-setuptools but it is not going to be installed
               Recommends: python3-wheel but it is not going to be installed
 python3.8-dev : Depends: python3.8 (= 3.8.0-3ubuntu1~18.04.2) but it is not going to be installed
                 Depends: libpython3.8-dev (= 3.8.0-3ubuntu1~18.04.2) but it is not going to be installed
                 Depends: libpython3.8 (= 3.8.0-3ubuntu1~18.04.2) but it is not going to be installed
 python3.8-venv : Depends: python3.8 (= 3.8.0-3ubuntu1~18.04.2) but it is not going to be installed
                  Depends: python-pip-whl (>= 8.1.0-2) but it is not going to be installed
 tensorrt : Depends: libnvinfer-dev (= 7.1.3-1+cuda10.2) but it is not going to be installed
            Depends: libnvinfer-plugin-dev (= 7.1.3-1+cuda10.2) but it is not going to be installed
            Depends: libnvparsers-dev (= 7.1.3-1+cuda10.2) but it is not going to be installed
            Depends: libnvonnxparsers-dev (= 7.1.3-1+cuda10.2) but it is not going to be installed
            Depends: libnvinfer-samples (= 7.1.3-1+cuda10.2) but it is not going to be installed
            Depends: libnvinfer-doc (= 7.1.3-1+cuda10.2) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Impossible to deploy our applications here (currently using internal limited emmc memory as stated in your example).

1 Like