JetPack 4.3 - L4T R32.3.1 released

We are pleased to announce JetPack 4.3 supporting Jetson AGX Xavier series, Jetson TX2 series, Jetson TX1, and Jetson Nano.

JetPack 4.3 key features include new versions of TensorRT and cuDNN, Docker support for CSI cameras, Xavier DLA, and Video Encoder from within containers, and a new Debian package server put in place to host all NVIDIA JetPack-L4T components for installation and future JetPack OTA updates.

Please refer to the JetPack Release Notes and L4T Release Notes for additional info.

JetPack 4.3 Highlights:

  • Support for TensorRT 6.0.1 and cuDNN 7.6.3
  • Full support for DLA INT8 on Jetson AGX Xavier
  • Support for installation of JetPack components via Debian package archives
    • JetPack components are provided as Debian packages via a public APT server hosted by NVIDIA, enabling easier upgrades of JetPack components to future versions. Previous versions of JetPack need to be re-flashed to JetPack 4.3, after which the APT server can be used.
  • Support for CSI, DLA, and Video Encoder from within containers
    • On all Jetson products: Camera Serial Interface (CSI) and NVENC are now supported from within containers.
    • On Jetson AGX Xavier series only: NVIDIA Deep Learning Accelerator (DLA) engines are now supported from within containers.
  • Support for DeepStream 4.0.2
  • Support for ISAAC SDK version 2019.3
  • New easy to use Jetson-IO tool to configure 40-pin header on Jetson developer kits
  • Developer preview of VPI (Vision Programing Interface), a software library that provides Computer Vision and Image Processing algorithms implemented on Xavier Vision Accelerator, GPU and CPU.
    • GPU and CPU implementations are not optimized for performance in this preview release of VPI. A future release will bring performance optimized GPU and CPU implementations

JetPack 4.3 components:

  • L4T R32.3.1 (K4.9)
  • Ubuntu 18.04 LTS aarch64
  • CUDA 10.0
  • cuDNN 7.6.3
  • TensorRT 6.0.1
  • VisionWorks 1.6
  • OpenCV 4.1
  • Nsight Systems 2019.6
  • Nsight Graphics 2019.5
  • Nsight Compute 2019.3
  • SDK Manager 1.0.0

Download JetPack…https://developer.nvidia.com/embedded/jetpack
Nano SD Card Image…https://developer.nvidia.com/jetson-nano-sd-card-image-r3231
JetPack Release Notes…https://docs.nvidia.com/jetson/jetpack/release-notes/index.html
L4T Release Notes…https://developer.nvidia.com/jetson-linux-driver-package-release-notes-r3231-ga

Hello,

Can we please have the cboot source for the nano.

I mean wasn’t it supposed to be released two bsp’s back now.

What is stopping you guys from putting it out?

R32.3.1 ready! Excellent news! So SPI is enabled? If so, I plan on buying another Jetson Nano.

It’s not enabled by default, but the new Jetson-IO pinmux configuration tool makes enabling SPI very easy.

Hi Chris, please see this topic for an update regarding this.

Does this fix the disk resize issue? Really bums me out when my 128GB card gets cut down to 16GB.

Hi odiezapha, if you are referring to when flashing Nano with SDK Manager, it creates the app partition as 16GB. To have the app partition able to use the full capacity of the SD card, use the SD card image or create-jetson-nano-sd-card-image.sh script. For more info, see here: https://devtalk.nvidia.com/default/topic/1068118/jetson-nano/expanding-the-memory-on-jetson-nano/post/5409957/#5409957

Praise Cthulu! Finally! Thank you!

Just tried it straight from the sdk. Figured I have had enough issues, what one more try. Worked great thank you for fixing the bug. Now I have room to really use it for my project. I’ve already applied for the Jarvis sdk. Any idea on how long that takes to get approved for or is my previous approval to the Isaac sdk messing things up? I would gladly give up my Isaac access to be allowed into the Jarvis sdk. It fits my project better.

Hi odiezapha and dusty_nv,

There are spi0.0 and spi1.0 in /dev directory by default in R32.3.1, but spi0.0 can’t be tested by spidev_test tool as you can see in /dev/spi0.0 not work in l4t32.3.1.
Thanks

I ran ‘jetson-io.py’ on jetson nano. but ‘jetson-io.py’ is turned off immediately when run without error code.

Hello!

Can you provide some more details please? When you say is turned-off do you mean that the board powered-down or the tool did nothing?

Can you confirm what command you executed? Did you launch jetson-io from a terminal?

Per the documentation before running jetson-io for the first time you need to open a terminal execute the following command (this will be fixed in future releases).

$ sudo find /opt/nvidia/jetson-io/ -mindepth 1 -maxdepth 1 -type d -exec touch {}/__init__.py \;

Once the above have been executed you just need to execute the following from a terminal …

$ sudo /opt/nvidia/jetson-io/jetson-io.py

You can also try the following command as well as this should display some output …

$ sudo /opt/nvidia/jetson-io/config-by-pin.py

Regards,
Jon

Experiencing the same issue with beargomer.

I got the following error.

$ sudo /opt/nvidia/jetson-io/config-by-pin.py
Traceback (most recent call last):
File “/opt/nvidia/jetson-io/config-by-pin.py”, line 51, in
main()
File “/opt/nvidia/jetson-io/config-by-pin.py”, line 34, in main
jetson = board.Board()
File “/opt/nvidia/jetson-io/Jetson/board.py”, line 149, in init
self.dtb = _board_get_dtb(self.compat, self.model, dtbdir)
File “/opt/nvidia/jetson-io/Jetson/board.py”, line 88, in _board_get_dtb
raise RuntimeError(“No DTB found for %s!” % model)
RuntimeError: No DTB found for NVIDIA Jetson Nano Developer Kit!

In my case, dtb files are under /boot/ , while script expects /boot/dtb/

the following change works for me.

line 135@/opt/nvidia/jetson-io/Jetson/board.py.

    #dtbdir = os.path.join(self.bootdir, 'dtb')
    dtbdir = os.path.join(self.bootdir, '')

Thanks for the feedback. Can you …

$ cat /sys/firmware/devicetree/base/compatible

Regards,
Jon

Hello!

You should have one dtb file under /boot/dtb/ which is the dtb file for the platform and then dtbs for all Jetson platforms under /boot/. Can you tell me what you see from the following comands …

$ cat /sys/firmware/devicetree/base/compatible
$ fdtget /boot/dtb/*.dtb / compatible

Regards,
Jon

Here it is.
$cat /sys/firmware/devicetree/base/compatible
nvidia,p3449-0000-b00+p3448-0000-b00nvidia,jetson-nanonvidia,tegra210

Thanks can you also dump …

$ fdtget /boot/dtb/*.dtb / compatible

Regards,
Jon

dj@dj-desktop:/boot$ fdtget /boot/dtb/.dtb / compatible
Couldn’t open blob from '/boot/dtb/
.dtb’: No such file or directory

dj@dj-desktop:/boot$ fdtget /boot/*.dtb / compatible
Error at ‘/boot/tegra210-jetson-tx1-p2597-2180-a02-devkit-24x7.dtb’: FDT_ERR_NOTFOUND
dj@dj-desktop:/boot$

Thanks. That’s very odd. It appears that you have no dtb file under /boot/dtb. Can you confirm that you have no files there?

ls -l /boot/dtb/

I have flashed the released version of L4T r32.3.1 and I don’t see this issue. I have a slightly older board version (A02), but that shouldn’t matter.

$ fdtget /boot/dtb/*.dtb / compatible                                                                                                                                                                                  
nvidia,p3449-0000-a02+p3448-0000-a02 nvidia,jetson-nano nvidia,tegra210

$ cat /sys/firmware/devicetree/base/compatible
nvidia,p3449-0000-a02+p3448-0000-a02nvidia,jetson-nanonvidia,tegra210

Can you tell me exactly how you flashed the board? Or are you using the SD card image? Ah looking at the SD card image there is no /boot/dtb directory so that will be a problem if you are using this image. Please confirm. We will look into a fix for this.

Regards,
Jon