JetPack 3.2 — L4T R28.2 Production Release for Jetson TX1/TX2

We’re pleased to announce that a developer preview release of JetPack 3.2 is now available for Jetson TX1 and TX2!

Highlights include support for TensorFlow models in TensorRT 3.0 GA, up to 15% perf/W improvement for DL applications, out-of-the-box kernel support for Docker, and support for Ubuntu 16.04 on your host PC (Ubuntu 14.04 on your host PC will also work, except cross-development packages for OpenCV and VisionWorks will be unavailable on that host PC). With JetPack 3.2, NVIDIA has also enabled Jetson TX2i for industrial environments. For more info, please view the full Release Notes.

JetPack 3.2 components:

  • L4T R28.2
  • CUDA 9.0
  • cuDNN 7.0.5
  • TensorRT 3.0 GA
  • OpenCV 3.3.1
  • VisionWorks 1.6

Release Notes…https://developer.nvidia.com/embedded/jetpack-notes
Download JetPack…https://developer.nvidia.com/embedded/jetpack
Software Overview…https://developer.nvidia.com/embedded/develop/software
L4T R28.2 Release…https://developer.nvidia.com/embedded/linux-tegra
L4T Archive Page…https://developer.nvidia.com/embedded/linux-tegra-archive

Is this the same developer preview for TX2 as before ?
Is there just R28.2-DP for TX1, or is there a new version for TX2 as well ?

Hi Honey_Patouceul, this is a new version for both TX1/TX2, updated with further enhancements and fixes since R28.2-DP for TX2.

In the preview release, there was some discussion about OpenCV, CUDA9, and gstreamer:
https://devtalk.nvidia.com/default/topic/1027301/jetson-tx2/jetpack-3-2-mdash-l4t-r28-2-developer-preview-for-jetson-tx2/post/5225602/#5225602

Have the issues with OpenCV and CUDA9 been resolved in this production release? What OpenCV modules are included with this release of Jetpack 3.2? It’d be nice to know before flashing. Thanks.

Hi Mepix, the configuration with OpenCV is still the same as the Developer Preview, as the issues weren’t resolved upstream, however you can re-build from source with GPU enabled if you so desire.

I have installed last R28.2-DP(2), it works fine but I face this issue with apt:

sudo apt-get update
Get:1 file:/var/cuda-repo-9-0-local  InRelease
Ign:1 file:/var/cuda-repo-9-0-local  InRelease
Get:2 file:/var/nv-tensorrt-repo-ga-cuda9.0-trt3.0.4-20180208  InRelease
Ign:2 file:/var/nv-tensorrt-repo-ga-cuda9.0-trt3.0.4-20180208  InRelease
Get:3 file:/var/visionworks-repo  InRelease
Ign:3 file:/var/visionworks-repo  InRelease
Get:4 file:/var/visionworks-sfm-repo  InRelease
Ign:4 file:/var/visionworks-sfm-repo  InRelease
Get:5 file:/var/visionworks-tracking-repo  InRelease
Ign:5 file:/var/visionworks-tracking-repo  InRelease
Get:6 file:/var/cuda-repo-9-0-local  Release [574 B]
Get:7 file:/var/nv-tensorrt-repo-ga-cuda9.0-trt3.0.4-20180208  Release [574 B]
Get:8 file:/var/visionworks-repo  Release [1,999 B]
Get:9 file:/var/visionworks-sfm-repo  Release [2,003 B]
Get:6 file:/var/cuda-repo-9-0-local  Release [574 B]
Get:10 file:/var/visionworks-tracking-repo  Release [2,008 B]
Get:7 file:/var/nv-tensorrt-repo-ga-cuda9.0-trt3.0.4-20180208  Release [574 B]
Get:11 file:/var/cuda-repo-9-0-local  Release.gpg [819 B]
Get:8 file:/var/visionworks-repo  Release [1,999 B]          
Get:12 file:/var/nv-tensorrt-repo-ga-cuda9.0-trt3.0.4-20180208  Release.gpg [819 B]
Get:9 file:/var/visionworks-sfm-repo  Release [2,003 B]          
Get:10 file:/var/visionworks-tracking-repo  Release [2,008 B]       
Get:11 file:/var/cuda-repo-9-0-local  Release.gpg [819 B]                      
Get:12 file:/var/nv-tensorrt-repo-ga-cuda9.0-trt3.0.4-20180208  Release.gpg [819 B]
Hit:14 http://ports.ubuntu.com/ubuntu-ports xenial InRelease                   
Hit:15 http://ports.ubuntu.com/ubuntu-ports xenial-updates InRelease
Hit:16 http://ports.ubuntu.com/ubuntu-ports xenial-security InRelease
Ign:11 file:/var/cuda-repo-9-0-local  Release.gpg
Ign:12 file:/var/nv-tensorrt-repo-ga-cuda9.0-trt3.0.4-20180208  Release.gpg
Hit:19 file:/var/nv-tensorrt-repo-ga-cuda9.0-trt3.0.4-20180208  Packages
Reading package lists... Done                            
W: GPG error: file:/var/cuda-repo-9-0-local  Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F60F4B3D7FA2AF80
W: The repository 'file:/var/cuda-repo-9-0-local  Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: file:/var/nv-tensorrt-repo-ga-cuda9.0-trt3.0.4-20180208  Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F60F4B3D7FA2AF80
W: The repository 'file:/var/nv-tensorrt-repo-ga-cuda9.0-trt3.0.4-20180208  Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I had had this on a previous boot, launched an apt-get upgrade where it asked me about cudnn not be being signed, I accepted anyway… Was that wrong ?

Hi Honey_Patouceul, it looks like the log was from apt-get update, in this case it’s doubtful the packages have been tampered with or are otherwise unsecure, is the error able to be ignored and the update completed ok?

Seems apt-get upgrade works after apt-get update gives this error.

I can confirm I have the same issue when I do apt_get update after doing a fresh install of JetPack 3.2. I believe apt-get upgrade still works for the other repositories.

I wouldn’t expect much upgrade from a local repository, but it would be nice to get it signed so that we won’t see this error any longer. Is there a way to fix it ?

Great news. Can someone confirm that the Docker support (“• L4T: Out-of-the-box kernel support for Docker”) includes GPU support. Like Nvidia-docker (https://github.com/NVIDIA/nvidia-docker).

Thanks.

We confirmed that the packages are signed, however it appears that you haven’t added a public key. Without a public key added to your system, you will encounter the warnings/errors. Can you try adding a public key and verify that the behavior is corrected?

As per the JetPack 3.2 Release Notes, the L4T kernel has been configured with the proper flags such that you can install docker.io, however we haven’t officially tested nvidia-docker yet. One of my colleagues has a bash script for enabling GPU sharing within docker containers located here:

https://gist.github.com/JasonAtNvidia/e03e6675849d1d4049b85ea41efb2171

Yes, it has been fixed after:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys F60F4B3D7FA2AF80

I did nothing special, I installed the same way than previous versions, with JetPack unselecting CUDA on host.

When I tried to install 3.2 b196 (the new package), it seems to want to install multimedia api 28.1 instead of 28.2 (which gets installed with b157). is this a regression?

Hi wdouglass,

The JetPack-3.2 is download “Tegra_Multimedia_API_R28.2.0_aarch64.tbz2” package.
Please delete your “jetpack_download” folder and download again.

Thanks!

Hi carolyuu

i followed the document lonk to download jetpack3.2.

http://docs.nvidia.com/jetpack-l4t/#developertools/mobile/jetpack/l4t/3.2/introduction.htm%3FTocPath%3D_____1

when i run the JetPack-L4T-3.2-linux-x64_b157.run
i only see the tx2 development environment item.
i can’t see tx2i and tx1.

how could i download the correct jetpack3.2 ?

Hi etta,

Please download the latest JetPack3.2 from here:
https://developer.nvidia.com/embedded/dlc/jetpack-l4t-3_2-ga

Thanks!

Hi everyone,

can I UPDATE Jetpack version on my TX2 platform, without loosing data on previous version ?

or it always flashes an OS from scratch ?

Hi Wahaj, the officially supported method is to re-flash with JetPack so it automatically updates the kernel and L4T BSP with the updated NVIDIA drivers, CUDA toolkit, ect. It is recommended that you backup your modified files before doing this so you can copy them back over after flashing, as the partition will be reformatted.

Unofficially, if your Jetson TX2 currently has the JetPack 3.2 Developer Preview on it, which is pretty similar, there is a small chance that if you manually update to the new kernel and the L4T drivers, it may work for you. However you would still want to backup your files first and it will probably take you more time to achieve than just reflashing and restoring your files.