JetPack 3.1 — L4T R28.1 released for Jetson TX1/TX2

Hello everyone, we’re pleased to announce that JetPack 3.1 with L4T R28.1 has been released.

JetPack 3.1 is a production software release for both Jetson TX1 and TX2, with Linux kernel 4.4 shared between both devices. In addition to bug fixes and improvements in the camera stack, JetPack 3.1 also includes updates to TensorRT 2.1 and cuDNN 6.0, delivering twice the inferencing performance for latency-sensitive applications. See our Parallel ForAll article, JetPack 3.1 Doubles Jetson’s Low-Latency Inference Performance.

View the full JetPack 3.1 Release Notes here, and the Release Notes for L4T here.

Package Contents

  • L4T BSP 28.1 64-bit with Linux kernel 4.4
  • Ubuntu 16.04 LTS aarch64 sample root filesystem
  • CUDA 8.0.84
  • cuDNN v6.0
  • TensorRT 2.1
  • OpenCV 2.4.13
  • VisionWorks 1.6

Release Notes…https://developer.nvidia.com/embedded/jetpack-notes
Download JetPack…https://developer.nvidia.com/embedded/jetpack
Software Overview…https://developer.nvidia.com/embedded/develop/software
28.1 Release Page…https://developer.nvidia.com/embedded/linux-tegra
Archive Page…https://developer.nvidia.com/embedded/linux-tegra-archive
Embedded DLC…https://developer.nvidia.com/embedded/downloads

Attempting to get going with 3.1 …

First, the launcher and menu bars were absent. (I posted about this, but looks that was in another group).
Minor fix.

But now, it seems the config_swap is not enabled on this.
I get error : swapon failed: Function not implemented.

Did something go wrong with my installation or others face this as well?

Probably it would be good if the next release made CONFIG_SWAP=y by default, but this is not an error. It simply needs the option enabled in a kernel compile.

@linuxdev Thanks.

Does this mean I need to rebuild the kernel from source? Or is there a simpler config option?

The kernel must be rebuilt…swap can only be added as a direct integrated feature, not as a module. Adding swap to the Image will not invalidate other features though, so just keep CONFIG_LOCALVERSION as matching the suffix of the current “uname -r” and replace the existing Image file. I always suggest backing up the original image, or better yet, adding a second boot entry to extlinux.conf to test first.

@linuxdev Thank you for all your help.

I tried using JetPack 3.1 on TX1 and facing issues.
I have posted separately but I think I will consolidate here in one post.

For now, I am going back to earlier JetPack, have wasted alot of time in this one.

  1. The default CSI camera doesn’t work with the base install of JetPack 3.1.
    I noted it herehttps://devtalk.nvidia.com/default/topic/1019986/jetson-tx1/getting-errors-in-using-onboard-camera-jetpack-3-1-/
    Going by @linuxdev’s comment on the thread, I am not alone in facing this issue.

  2. Unlike previous versions, there is a user nvidia in JetPack 3.1 . The samples etc. which were earlier in the home directory, are in ‘nvidia’ user directory this time. Though, the online install guide seems to indicate otherwise.
    Is it possible the Tx1 and TX2 installations are working any differently?
    FWIW I repeated steps on both users just to make sure if one of them works. No luck.

  3. The config_swap on the kernel is disabled. This will make compiling many modules difficult on this build. Please consider releasing an update to overcome this, this is troublesome. Though, it appears it’s a small issue for linux users, it is still another hurdle.

  4. Has anyone been successful in using the CSI camera on Tx1 with JetPack 3.1? Will be helpful if you can share any tips that helped… Given this is the LTS edition, I am keen on using this as a base to move forward, but losing more time is also hurting my project.

./JetPack-L4T-3.1-linux-x64.run

Error: Please run JetPack as a non-elevated user: when root access is needed, the installer will prompt you

I use
$sudo ./JetPack-L4T-3.1-linux-x64.run

show same question

Are you logged in as root?

yes log in ubuntu as root automatic

By default, it should log in as user ‘ubuntu’, not root.

Just a heads-up…the issue of apt-get update overwriting libglx.so is back. Anyone wanting to fix this can copy (from the driver package) “nv_tegra/nvidia_drivers.tbz2” over to “/” of the Jetson, and upack it to fix this (verify good/bad with “sha1sum -c /etc/nv_tegra_release”):

# On the Jetson, after copy of nvidia_drivers.tbz2 to "/"...
cd /
sudo tar xvfj nvidia_drivers.tbz2
# Verify fixed:
sha1sum -c /etc/nv_tegra_release

To find out for sure which user you are logged in as run command “whoami”.

I run Jetpack 3.1 like this:
./JetPack-L4T-3.1-linux-x64.run

and it runs,however,an error occurs when installing the OS to my TX1 board.

The dialog box information is:
Error occurs during querying next page: Page chmod not found .
Please check Launcher.log

What’s more,initrd is not in rootfs/boot and I can not find it.

thanks for help!

@lianghu

Start with a clean folder on the host. I had mistakenly downloaded 3.1 in the same folder as 3.0 and faced this issue. My earlier files from 3.0 installation were there and that messed up.

When I tried again, in a clean folder, it proceeded fine.

@lianghu

I have the same issue. Was it resolved ?

@shaktiD
Thanks for your kindly help!
@nish_p
I use Jetpackunistaller to uninstall the whole jetpack files(64_TX1) and all the jetpack download files(jetpack_dowanloads,jetpack_doc …).Then I move JetPack-L4T-3.1-linux-x64.run to a clean folder and run it ,follow shaktiD’s suggestion.It’s a pitty,the issue also exists.I think that my host PC has run Jetpack3.0 before and has not restarted since the last running of Jetpack3.0.so,I restart my PC and run again,It works normally and the problem is resolved.

I’m unable to connect to wifi or ethernet after flashing my jetson with jetpack 3.1
The ethernet LEDs aren’t glowing either.

kindly help.

@ShaktiD @linuxdev

Could I only update the cuDNN version on TX1 (Jetpack L4T 24.2.1)directly?

If I want to update the version v6, I would reflash the TX1 by Jetpack3.1?

Thanks for help !

@Shuyu0815
Updating to 3.1 is the better route.

@ShaktiD

OK,Thank you !