JetPack 3.0 - L4T R27.1 released for Jetson TX2

Hello everyone, JetPack 3.0 is live.

JetPack 3.0 adds support for the new Jetson TX2 Developer Kit with a preview release of L4T with kernel 4.4, and continues to support the Jetson TX1 Developer Kit and the Jetson TK1 Developer Kit. Components for Jetson TX1 and Jetson TK1 Developer Kits remain unchanged from the previous version of JetPack. (A future release of JetPack will support both Jetson TX2 and Jetson TX1 with aligned API and Linux kernel versions.)

View the full JetPack 3.0 Release Notes here, and the Release Notes for L4T here.

Package Contents

  • L4T BSP 27.1 64-bit
  • Ubuntu 16.04 LTS aarch64 sample root filesystem
  • CUDA 8.0.64
  • cuDNN v5.1
  • TensorRT 1.0
  • OpenCV 2.4.13
  • VisionWorks 1.6

Software Overview: https://developer.nvidia.com/embedded/develop/software
27.1 Release Page: https://developer.nvidia.com/embedded/linux-tegra
Archive Page: https://developer.nvidia.com/embedded/linux-tegra-archive
Embedded DLC: https://developer.nvidia.com/embedded/downloads
JetPack: https://developer.nvidia.com/embedded/jetpack

When I install the jetpack, is there any option I can uncheck the contents.
for example I am not going user the opencv then can I dissect it while installing it?

Yes, click in the Action column and select not to install the package in the context menu.

My Jetson TX2 Architecture: aarch64 when i try to install jetpack3.0
Error shown “Error : Jetson must be run on x86_64 Host platform.”
Advise me please.

You run the Jetpack installer on a “host” x64 Linux system, and connect that to the “target” Jetson TX2 module.

@snarky thank you very much… I review in https://www.youtube.com/watch?v=D7lkth34rgM

I have the Jetson TX2 development kit and I have installed JetPack 3.0 already. I noticed in the description of JetPack 3.0 it says “…JetPack 3.0 adds support for the new Jetson TX2 Developer Kit with a preview release of L4T”. Does that mean I have to install the L4T Jetson TX2 driver package from the embedded downloads page as well? Thank you.

JetPack is a front end for other software. When you choose to flash via JetPack the driver package is downloaded by JetPack…you could flash on command line without JetPack via command line. Flashing from JetPack is for convenience. Currently, flashing via JetPack 3.0 implies driver package and sample rootfs from L4T R27.1.

Where is the download for CUDA 8 from armhf ?

Hi cxmzlxb, only aarch64 package is supported/available on TX2.

thank you!

I am beyond frustrated with the TX2, the flashing process and everything. It would’ve been great to have received this dev kit out of the box ready to go although I understand that’s more difficult than it may seem coming from a manufacturer or already made stock when updates come out after the fact. If this post needs to be added or moved to another section please do so or suggest it. I try not to post anything until I’m absolutely tearing my hair out.

First: Directions are so unclear and disorganized. I read people saying to use Ubuntu 14.04(Nvidia’s instructions which I ultimately went with) and others saying use 16.04 and then that 16.04 works for flashing from VM where as 14.04 won’t work. I setup a boot-able USB 128GB sandisk 3.0 thumb drive with an available space of 116GB with Ubuntu 14.04. I set it up with Universal USB installer with a persistence space of about 40GB. I figured that would be more than sufficient and it has indeed seemed to suffice.

Second: During the Jetpack 3.0 install it hung up on one part(Installing OpenCV for Tegra 2.4.13-17 failed. Return code 1. Error:OpenCV4Tegra cannot be installed on host) where, on the host, in terminal, I had to enable universe and multiverse and after that it flashed everything successfully.

Third: When I went to boot up the Jetson TX2 it kept flashing the Nvidia screen during boot-up and then ultimately gave me the message of “running in low graphics mode”. I researched this problem on the forums and google and only found answers more specifically to ubuntu but not necessarily for the TX2 itself. I can’t seem to find the same information again but part of the advice given was to press Control + Alt and F1 to get into terminal. After doing so and running a command under sudo, NONE of the default logins would be accepted. I tried nvidia for both username and password. I tried ubuntu for both. Neither would take therefor I wasn’t able to get any further. I don’t currently have the usb serial cable although I’ll be ordering one soon. Someone advised editing the xorg.conf file and deleting or editing some of the information and I assume reflashing it with that newly edited file. Can anyone please point me in the right direction as Nvidia’s support seems absolutely horrible?

I’m unable to copy and save the text directly but have taken photos on my phone and uploaded them to photo bucket. Hopefully linking to them is allowed but the following are the photo links(sorry if they’re hard to read):

http://i1149.photobucket.com/albums/o594/cpsatmega/Mobile%20Uploads/IMG_20170622_104354_zpshenyg2c0.jpg

http://i1149.photobucket.com/albums/o594/cpsatmega/Mobile%20Uploads/IMG_20170622_104416_zpsksmync8w.jpg

http://i1149.photobucket.com/albums/o594/cpsatmega/Mobile%20Uploads/IMG_20170622_104433_zpsxwkozery.jpg

http://i1149.photobucket.com/albums/o594/cpsatmega/Mobile%20Uploads/IMG_20170622_104444_zpsvrfkvjui.jpg

http://i1149.photobucket.com/albums/o594/cpsatmega/Mobile%20Uploads/IMG_20170622_104455_zpsqzlbtazw.jpg

http://i1149.photobucket.com/albums/o594/cpsatmega/Mobile%20Uploads/IMG_20170622_104505_zpsvpnnh8xt.jpg

http://i1149.photobucket.com/albums/o594/cpsatmega/Mobile%20Uploads/IMG_20170622_104522_zpshsumjat4.jpg

http://i1149.photobucket.com/albums/o594/cpsatmega/Mobile%20Uploads/IMG_20170622_104533_zpsji12aaux.jpg

http://i1149.photobucket.com/albums/o594/cpsatmega/Mobile%20Uploads/IMG_20170622_104544_zpsdq2g7fxt.jpg

http://i1149.photobucket.com/albums/o594/cpsatmega/Mobile%20Uploads/IMG_20170622_104552_zpsxyl33bur.jpg

http://i1149.photobucket.com/albums/o594/cpsatmega/Mobile%20Uploads/IMG_20170622_104601_zpsxp9f7s0t.jpg

http://i1149.photobucket.com/albums/o594/cpsatmega/Mobile%20Uploads/IMG_20170622_104609_zpslvyicrxz.jpg

http://i1149.photobucket.com/albums/o594/cpsatmega/Mobile%20Uploads/IMG_20170622_104619_zpsp06jizuz.jpg

http://i1149.photobucket.com/albums/o594/cpsatmega/Mobile%20Uploads/IMG_20170622_104626_zpsrriur1iz.jpg

Hi cpsatmega, please repost your 3rd issue as a new topic, thanks.

Note that flashing from VM isn’t formally supported regardless of the host. Linuxdev has some tips that may get it to work, increase USB buffer sizes.

Was this on 16.04 or 14.04? On 14.04 it should work fine, but 16.04 users may need to disable Host-side OpenCV4Tegra (it can still be installed to the Jetson fine).

If you simplify and just flash you may get more information. Using JetPack requires not only the micro-B USB cable, but also ethernet (wired only, don’t use WiFi for JetPack). Command line cuts out many requirements and may offer more clues as to basic issues. Here is some info for flashing on command line:
https://devtalk.nvidia.com/default/topic/1001583/jetson-tx2/jetson-tx2-not-recognized-installation-inside-docker-error-8-error-return-value-8-command-tegrarcm_v2-chip-0x18-rcm-rcm_list_signed-xml-skipuid-reading-board-information-failed-/post/5116716/#5116716

Hey Guys,

Sorry for taking so long to respond. I’ve been working 12 hour shifts in a food factory and I’ve been so tired I’ve only had limited time to dedicate to sitting down and working on this and the suggestions given(sad excuse, I know, but I’d rather not mess things up further working tired).

I ultimately decided that since most of the problems people were having kept referring to using a VM as the host, etc, or in the one case, somebody with the dvi to hdmi adapter which didn’t apply to me, that I should actually install 14.04 on my host hdd.

I was attempting to use a large live thumb drive(116GB(sandisk 128GB 3.0 but in 2.0 usb ports(all ports on my hosts have only been 2.0 oldees)) in my previous flash attempts due to not wanting to change my OS(had things set up ideally on my last OS but after having some config issues arise anyway decided to flush and fresh install) and that finally worked and everything flashed as simply as it should have.

Sometimes it’s the simplest things that you just don’t think would make a difference. I tried from live usb with a persistence of 60GB on both an older dell inspiron laptop and a slim tower gateway with no luck. All times had both host and TX2 connected to my router via Ethernet cord(not wireless). It never went much further than acquiring the IP after reboot and often didn’t acquire it although it did the first time. But with fresh full hard drive install, it worked perfectly. I watched the terminal carefully and when it said reboot/reset the TX2 I pressed the reset button…after about 20-30 seconds terminal showed it acquired IP and it actually went through installing everything without a hitch.

I’m typing this on the TX2 right now.

Hope this helps if the majority of these problems are arising from using live usb, usb 3.0 ports,DVI/HDMI adaptor ,WiFi or VM. I know sometimes, after going through 10 different versions of linux etc, finding what’s right for you, that when you get things set just right and may be utilizing all your hdd and in my case unable to resize, repartition it, that live or VM seems the way but just wipe your host system and install. It’ll save the headaches down the road. It also seems somewhat easier to setup dual boot from ubuntu as your primary install rather than the other way around IMO.

I did a standard Jetpack 3.0 install on my Jetson TX2 from Ubuntu 16.04. Everything looks great, except the SD Card reader isn’t there. Not in /dev (no mmcblk1*), not in the device list, or running Disks. How do I get it installed? Thanks.

Does this show any error:

sha1sum -c /etc/nv_tegra_release

When an SD card is inserted or removed, does anything show in “dmesg --follow”?

Not sure, but you might also check if your SD card is UHS-I https://devtalk.nvidia.com/default/topic/1017109/jetson-tx2/tx2-sd-card-slot/post/5180808/#5180808

No errors. I thought the reader should show up in /dev, even if no card installed?

The “/dev” files for file systems are block device driver point of access. The reader itself is not a block device…the memory inserted into the SD slot is the block device. No SD, no block device, no driver making it visible in “/dev”.