Flashing Tx2 with Jetpack 3.3.2 hangs

When I try to use SDK Manager 1.4.0.7363 on an Ubuntu 16.04 physical (not virtual) machine to flash a Tx2, the process hangs at this line:

...
12:18:17 INFO: Flash Jetson TX2: [ 4.3160 ] tegradevflash_v2 --iscpubl
12:20:17 INFO: Flash Jetson TX2: [ 4.3174 ] C

Attached are the complete logs from the SDK Manager Export Logs buttonSDKM_logs_2021-01-06_12-35-16.zip (2.9 MB) .

Before you ask if I can use Jetpack 3.3.3 instead, I can and it flashes successfully, but it uses L4T 28.4 and I need L4T 28.3

I also tried Jetpack 3.3.1, but it has a separate error (it cannot find USB). I can post about that separately if that would be helpful.

What is the issue and how is it fixed?

hello connortzx1a,

may I know what’s your actual use-case for using JetPack-3.3.1?
the latest production release of JetPack SDK is JetPack-4.4.1, which supporting all Jetson modules.

it seems JetPack release image has already download to your local machine.
could you please duplicate the image flashing process with the flash script file.
you may found the image as following, for example, ~/nvidia/nvidia_sdk/JetPack_3.3.1_Linux_P2888/Linux_for_Tegra/

please refer to developer guide, Basic Flash Script Usage to enable flash script to flash the board.
thanks

I need to use L4T 28 for compatibility with my application, this is why I can’t use 4.4.1. As for why I can’t use 3.3.3, I need L4T 28.3 in order to get a device to flash with balenaOS.

I don’t have a directory named JetPack_3.3.1_Linux_P2888/, I do have JetPack_3.3.1_Linux_GA_JETSON_TX2 which contains the Linux_for_Tegra directory.

Is this what I should be expecting? Or is it an error that I don’t have the JetPack_3.3.1_Linux_P2888 directory?

Running the command:
sudo ./flash.sh jetson-tx2-devkit.conf mmcblk0p1

produces the error:
Error: Invalid target board - jetson-tx2-devkit.

Even though jetson-tx2-devkit is definitely listed for Jetson TX2 P3310-1000 in the Jetson Modules and Configurations table.

These are the exact steps I followed and a complete log of the flashing process:

  1. Download and unpack the L4T 28.3 TX2 BSP archive from https://developer.nvidia.com/embedded/dlc/l4t-jetson-driver-package-28-3-tx2
  2. Connect micro USB cable to Orbitty and PC. Put board in recovery mode. Ensure the board entered recovery mode with lsusb.
  3. Unpack the Nvidia BSP archive to create a Linux_for_Tegra folder. Enter it and issue: sudo ./flash.sh jetson-tx2 mmcblk0p1

This inevitably completes with:

tegradevflash_v2 --iscpubl
Cannot Open USB

cti-orbitty-tx2-L4T28.3-Ubuntu16.04.log (22.9 KB) (This one ends with just C not Cannot Open USB. It seems to be the same error though.)

hello connortzx1a,

since I’m not working with rel-28 for a long time. I should mentioned it’s my assumption of the path name.
yes, please goes with Linux_for_Tegra directory for the JetPack release image.

there’s param for target board naming, please exclude conf from the command line for a try.
you should execute flash script as following, $ sudo ./flash.sh jetson-tx2 mmcblk0p1

FYI, we had also test this locally. we’re able to flash JP-3.3.1 on TX2 via SDKManager without failures.
thanks

Jerry, please see my most recent post where I said:

I have posted the complete logs of multiple different flashing attempts. Both the specific logs for ./flash.sh and general logs for the SDKmanager flash.

The information that

does not help me if I don’t know why my flashes are failing.

Have you seen this error before?
Am I perhaps missing a step in the flashing process?
Is there anything I need to do to prepare a Tx2 for being flashed again after it has been flashed improperly before?
Is Ubuntu 16.04 + SDKManager1.4.0.7363 the right version combinations to use?
Should I be using the Tx2 devboard or something different?

hello connortzx1a,

SDKManager works with Jetson TX2 DevKits for image flashing.
are you working with your own customize board?
thanks

Hi Connortzx1a -

If I’m reading correctly, you are trying to flash your TX2 for use with the Orbitty Carrier Board, correct? If that’s the case, our Tech Support Team would be happy to point you in the direction of the correct BSP for JetPack 3.3.2, and help you flash your module. If you fill out our support form, the tech team will get you up and running; you can find the form here: https://connecttech.com/support/cscr-form/.

Let me know if you have any more questions!
Jacki

Hi Jerry,

I have tried flashing the TX2 DevKit with SDK Manager 1.4.0 and JetPack 3.3.1. This is something I have attempted about 3 - 4 times. With this approach I get the error:

tegradevflash_vn --iscpubl 
Cannot Open USB

I also tried flashing directly onto the CTI Orbitty, which is the series of steps followed in this post:

Hi Jacki,

I am trying to flash my TX2 for use with balenaOS. The particular version of balenaOS I require is compatible only with L4T 28.3 (found in Jetpack 3.3.1 and 3.3.2).

I don’t think I need your help, the flashing step with balenaOS media should take care of the CTI Orbitty carrier board requirements. Does that sound right?

Jerry, no it does not work for me.

I’m not sure what is going wrong, but here is another attempt to flash a tx2 on theDevKit with SDK Manager, this time on Ubuntu 18.04 (just in case that was the issue) SDKM_logs_2021-01-08_09-13-23.zip (112.9 KB) .

Same Cannot Open USB error. Are you not seeing this issue on your devices? Have you seen this issue before? I’ve seen some mention in the forums, but never really a diagnosis of it.

If you want a dignosis, then few things to try

  1. Use only TX2 devkit and ubutnu 16.04./18.04 Please note that VMs are not permitted. And we don’t know of CTI board would work or not, so do not use that board at this moment.

  2. Try different usb cable/ tx2 modules, if you have multiple of them. This is to prevent hardware defect.

  3. Try different host machines if possible.

  4. Dump the serial console log from both host and device. As this page indicates

Please note that I need both host and device flash log. All the log you have pasted are host side log.
The device log requires the ttl usb cable to dump from uart.

Thank you WayneWWW.

  1. I have done many tests with ubuntu 16.04 and 18.04 on a physical host machine connected to the DevKit.
  2. I have tested 5 usb cables and I have tested different tx2 modules. More on that below
  3. I have tried multiple host machines. 3 different ones.
  4. I haven’t yet dumped the serial console logs from the device. I may do that, however I have an update.

These TX2s I’m trying to flash are brand new, and almost all of them give me problems. Only 3 of the 8 devices I’ve tested have flashed successfully. However, when I try to flash older TX2s from previous orders they work just fine.

I believe there may be a problem with the hardware I have received. It could either be that something changed on the hardware and wasn’t tested with Jetpack 3.3.1/3.3.2, or perhaps this is just a bad batch.

That would explain why, with the exact same setup, some devices work and others don’t. It would also explain why JetPack 3.3.1 is working for you but not for me.

How could I test the hardware to get a more definitive answer as to whether I have received a bad batch?

  1. Please still dump the log from uart console.

  2. However, when I try to flash older TX2s from previous orders they work just fine.

I don’t quite understand this comment. Could you elaborate what are “older TX2” and “previous orders”?
Did you mean some tx2 that was bought before that can be flashed without error?

If these new modules failed to get flashed on jetpack3.x release, then please use jetpack4.4.1 and see if you can see the problem on jetpack4.4.1. This is just for debug and not asking you to use jetpack4.4.1 forever. We should at least find a version that can flash your modules to confirm modules are not broken.

If jetpack4.4.1 can flash your boards, I would guess this maybe some issue related to the TX2 PCN. Since you said “new TX2” would be affected. The latest PCN of TX2 indicates that only rel-28.4 and jetpack4.4 support specific modules.

  1. You could just use sdkmanager to download Linux_for_Tegra. After that, directly use flash.sh to do the flash work to save your time.

I’m still waiting for my serial to usb stick to arrive. Once I get it I’ll send the logs.

Yes, exactly. Tx2s I bought in November have no problem.

Ok, I do know that these newer devices can be flashed with 3.3.3, so I’d guess 4.4.1 will work. I’ll check on it.

Great, thank you.

What does this mean? What do I do with this information?

Search “PCN” in the download center.
Read the latest PCN document for TX2. And you will understand what is PCN doing.