Jet Pack installation jetson TX2

I am trying to install jetpack 4.2.2 in jetson TX2.but during flashing it is showing error.
“Could not detect hardware”
it flashes for about 1.4% and throws this error.
The bard is set to recovery mode.and i using ubuntu 18.04 in host pc.
The jetson is already flashed with jetpack 3.3.

Please help in solving the issue

Hi varunqd,

Before flash and put device into recovery mode, please check your host machine can detect it via ‘lsusb’ command:

Bus Device : ID 0955: 7c18 Nvidia Corp.

If you see the message, you can start flash.

Hi Carolyuu
Thanks for the reply
I have put the device into recovery mode. and was also able to list in the device using the lsusb command

Hi Carolyuu
I have also noted that the flash window is popping up before the entire manager is being Downloaded.It pops up when the download is around 60%.
Will that be a problem?
I have attached the log from sdk manager terminal

(Attachment log_sdkmanager.txt is missing)

Log file

log_sdkmanager.log (38.7 KB)

Hi varunqd,

Check sdkmanager log:
09:54:31 INFO : Flash Jetson TX2 : Error: probing the target board failed.
09:54:31 INFO : Flash Jetson TX2 : Make sure the target board is connected through
09:54:31 INFO : Flash Jetson TX2 : USB port and is in recovery mode.
09:54:31 INFO : Flash Jetson TX2 : exit status 1

Looks your device doesn’t into recovery mode.
Please connect micro-USB cable from TX2 to host machine.

Hi carolyuu

I believe my board is in recover mode. cauz when i use " lsusb | grep 0955:7c18 " it is showing the following " Bus 001 Device 033: ID 0955:7c18 NVidia Corp."

if it is not in recovery mode it should the previous OS na?
i can also see in sdk manger that the flashing percentage increases from zero and it almost reaches 1.4% and then shows the error

During flash the USB disconnects and reconnects multiple times. If you are using a VM this will happen if the VM does not have complete ownership of the device (sometimes upon reconnect the VM is no longer owner of the USB device). Are you using a VM?

Note: Many common micro-B USB cables are just charger cables. If you are using the cable which comes from the developer kit this is good, but if using another cable, then this too can be an issue.

I am not using a vm
The cable i am using is not the one from the box.but it’s working fine I have test it on the same board and was also able to get the console output on my terminal

Beware that many lower quality cables have this issue, it is a common event. When these cables are used for shorter periods of time or at lower speeds they work. However, when running at the full USB2 speeds for long duration errors will cause a disconnect. It is very difficult to get a third party micro-B USB cable (usually labeled OTG) which actually works well. This may be nothing more than a cable issue.

Hi varunqd,

Suggest you can remove below path and try download again:

$ sudo rm -r ~/.nvsdkm

Also you can try other micro-usb cables.

I have tried with more than 3 usable cable but still showing the same error.
I also removed the path using the given command


Please use the flash script directly instead of sdkmanager.

Let’s see if would find your deivce or not.

I tried with the flash script .but no use same error.


What same error? USB cannot find your device in recovery mode?

It showing “cannot probe to the device”.

I got the same error while using tbe SDK manager.


I would suggest to change another host machine to try or find another TX2 devkit(if you have one) to test.


case 1. Your current host is able to flash another TX2 devkit, then maybe this problematic tx2 has some defect.

case 2. Another host machine is able to flash this tx2.
Then maybe there are some reasons in old host. I would say not to use it at this moment.

Hi Wayane…

I have followed these two suggestions

By the following above i was able to run the flash script. but as noted in the above posts the script hangs at this point ‘tegrarcm_v2 --isapplet’

[ 0.8208 ]
[ 0.8209 ] Boot Rom communication
[ 0.8237 ] tegrarcm_v2 --chip 0x18 0 --rcm rcm_list_signed.xml
[ 0.8263 ] BootRom is not running
[ 5.9764 ]
[ 6.9792 ] tegrarcm_v2 --isapplet
[ 1011.8007 ]
[ 1011.8042 ] tegradevflash_v2 --iscpubl
[ 1011.8087 ] CPU Bootloader is not running on device.
[ 2027.6092 ]
[ 2028.6136 ] tegrarcm_v2 --isapplet
[ 3043.4166 ]
[ 3043.4207 ] tegradevflash_v2 --iscpubl
[ 3043.4251 ] CPU Bootloader is not running on device.
[ 4059.2247 ]
[ 4060.2288 ] tegrarcm_v2 --isapplet
[ 5075.0320 ]
[ 5075.0352 ] tegradevflash_v2 --iscpubl

Could you tell us what you’ve done to make it able to flash?
If you could start the flash process, please also dump the UART log so that we could see what get stuck.

Hi waynee…
As discussed in the above forms.

I first put the board to recovery mode,then connect the usb cable at the same time run the flash script.

(Have to try the above setup for 2 or 3 times until it showed the flash script running)

I was not getting any log on UART console.