Jetson TX2 Jetpack Failed to flash device.

Good morning.

I have a problem.

The problem is that when I connect my laptop to Jetson TX2 to install the Jetpack on the Jetson TX2 and then press enter, the connected USB connection is disconnected and the following message appears.
(Error: Return value 8
Command tegradevflash_v2 --oem platformdetails storage storage_info.bin
Failed flashing t186ref.
0

Failed to flash device. Check /home/mrlee/JetPack3.1/_installer/logs/64_TX2/flash_os_tx2.log for more details. Please close this terminal window, fix the issue mentioned in log, and run JetPack again to reinstall.

How can I solve it?
I need help.
Please.

What does “/home/mrlee/JetPack3.1/_installer/logs/64_TX2/flash_os_tx2.log” say? Also, is there any kind of USB HUB between the Jetson and the host?

Hi aks0309,

Please provide your “flash_os_tx2.log”.
What is your laptop system? ubuntu 14.04?

Thanks

I have the same problem!!
While I flash the Jetson tx2 with “JetPack-L4T-3.1-linux-x64.run” , I get the same problem.
There is something different from the install guide. My host platform os is Ubuntu16.04 in the VirtualBox virtual machine,
and the target is Jetson Tx2. In addition, I didn’t choise the full packets, but I select the all packets except the opencv2.4.13, because
I will delevop my applications with opencv3.4.0. Is it the point of the problem?

Here is the part of the flash_os_tx2.log:

[ 3.9221 ] tegrahost_v2 --generateblob blob.xml blob.bin
[ 3.9230 ] number of images in blob are 9
[ 3.9311 ] blobsize is 3725048
[ 3.9326 ] Added binary blob_nvtboot_recovery_cpu_sigheader.bin.encrypt of size 184576
[ 3.9432 ] Added binary blob_nvtboot_recovery_sigheader.bin.encrypt of size 78080
[ 3.9479 ] Added binary blob_preboot_d15_prod_cr_sigheader.bin.encrypt of size 61472
[ 3.9527 ] Added binary blob_mce_mts_d15_prod_cr_sigheader.bin.encrypt of size 2077088
[ 3.9606 ] Added binary blob_bpmp_sigheader.bin.encrypt of size 528800
[ 3.9673 ] Added binary blob_tegra186-a02-bpmp-quill-p3310-1000-c04-00-te770d-ucm2_sigheader.dtb.encrypt of size 466160
[ 3.9810 ] Added binary blob_tos_sigheader.img.encrypt of size 58880
[ 3.9829 ] Added binary blob_eks_sigheader.img.encrypt of size 1488
[ 3.9829 ] Added binary blob_tegra186-quill-p3310-1000-c03-00-base_sigheader.dtb.encrypt of size 268352
[ 3.9829 ]
[ 3.9830 ] Sending bootloader and pre-requisite binaries
[ 3.9841 ] tegrarcm_v2 --download blob blob.bin
[ 3.9853 ] Applet version 01.00.0000
[ 4.1911 ] Sending blob
[ 4.1948 ] [… ] 028%
[ 4.1948 ] [… ] 056%
[ 4.1948 ] [… ] 084%
[ 4.1948 ] […] 100%

[ 5.7933 ]
[ 5.8019 ] tegrarcm_v2 --boot recovery
[ 5.8135 ] Applet version 01.00.0000
[ 6.0815 ]
[ 6.0857 ] tegrarcm_v2 --isapplet
[ 6.7341 ]
[ 6.7424 ] tegradevflash_v2 --iscpubl
[ 6.7475 ] CPU Bootloader is not running on device.
[ 7.4752 ]
[ 38.5997 ] Retrieving storage infomation
[ 38.6047 ] tegrarcm_v2 --oem platformdetails storage storage_info.bin
[ 38.6101 ] Applet is not running on device. Continue with Bootloader
[ 38.6536 ]
[ 38.6611 ] tegradevflash_v2 --oem platformdetails storage storage_info.bin
[ 38.6665 ] CPU Bootloader is not running on device.
[ 38.6931 ]
Error: Return value 4
Command tegradevflash_v2 --oem platformdetails storage storage_info.bin
Failed flashing t186ref.

USB normally fails on a VM. You’d have to go through extra steps. See:
https://devtalk.nvidia.com/default/topic/1002081/jetson-tx2/jetpack-3-0-install-with-a-vm/

@linuxdev, thank you for your answer. I know why this have happaned.
But When I follow the suggests, I can not make it work as before. Maybe my VM is running on the Windows 10 system, but Mac OS.In the setting of the virtualbox, the usb controler of USB2.0 or USB3.0 ,I have tried both.
It seems that I have to flash the Jetson tx2 with the Ubuntu16.04 as the host, not the VM.

VMs seem to have many fatal issues with how they pass through USB. No doubt configuration differs between VMs under Windows versus Mac, but I have avoided VMs so I have no way to offer advice (and I also don’t have a Mac). A native install would be a good idea.

Thank you, linuxdev! I have solve the problem by using the native ubuntu.

Hi heyan3502,
I saw you said you solved the problem by using the native ubuntu, can you share the procedure that using native ubuntu to flash JetPack to TX2, please share with me! I had try VirtualBox to build a VM, but it always failed when flashing JetPack to TX2… so I am now trying to use native ubuntu, but when I try to run “./JetPack-L4T-3.1-lonux-x64.run”, and it can only Uncompress JetPack and do nothing else… how should I do for next step to flash JetPack to Tx2? Thanks!!

The following are the results on my command line:
edward@ECS500G4-DD3B:/mnt/d$ ./JetPack-L4T-3.1-linux-x64.run
Creating directory _installer
Verifying archive integrity… All good.
Uncompressing JetPack 100%

Does your Ubuntu have internet access? For example, can you browse nvidia.com from that system?

@a0975003518, you can follow the tutorial at http://docs.nvidia.com/jetpack-l4t/index.html#developertools/mobile/jetpack/l4t/3.2/jetpack_l4t_install.htm. If you have use JetPack-L4T-3.1-linux-x64.run, you should better install ubuntu16.04_x64 on your host computer. You neet to read the “System Requirements” and make sure you have meet the condition. I think you will get success.

In addition, the tutorial said you need 10GB of disk space, but I think that is too small, if you will install the full packets, the whole process need 40GB more or less, but 50GB is certainly no problem.