Jetson TX2 4GB Flashing Issue

I just received my Jetson TX2 4GB with JetPack 3.3 - L4T 28.2.1.
But I have a problem with flashing:
[ 5.1612 ] Added binary blob_bpmp_sigheader.bin.encrypt of size 529440
[ 5.1634 ] Added binary blob_tegra186-a02-bpmp-p3310-1000-c04-as-0888-ucm2_sigheader.dtb.encrypt of size 327584
[ 5.1665 ] Added binary blob_tos_sigheader.img.encrypt of size 62976
[ 5.1677 ] Added binary blob_eks_sigheader.img.encrypt of size 1488
[ 5.1709 ] Added binary blob_tegra186-quill-p3310-1000-as-0888_sigheader.dtb.encrypt of size 279056
[ 5.1812 ]
[ 5.1813 ] Sending bootloader and pre-requisite binaries
[ 5.1821 ] tegrarcm_v2 --download blob blob.bin
[ 5.1832 ] Applet version 01.00.0000
[ 5.3554 ] Sending blob
[ 5.5058 ]
Error: Return value 1
Command tegrarcm_v2 --download blob blob.bin
Failed flashing t186ref.

Why? I would really appreciate your help.
flash_os_tx2.log (183 KB)

Is the host PC a VM? Is the cable being used the provided cable?

Hi linuxdev,
I tried on both a VM(Ubuntu 14.04) and a native Ubuntu(16.04), they do not work and show the same error report with value 1. Yes, the cable used is provided. Also, I was wondering if it is USB issue, and I tried to use a USB hub and to directly connect keyboard to the tx2, none of them worked. Another issue is that when I connect a display to tx2 via HDMI (monitor is also HDMI type), the display does not show anything but black screen; however, the display does receive the signal from tx2, but it just does not show up. Sorry to be such a pain, thanks for help!
flash_os_tx2.log (183 KB)

There is a significant chance that it is actually booting, but video configuration has failed (that would be if flash had completed, then video isn’t a reasonable way to see if flash worked, but for your case we know flash failed). It sounds like you have the basics in place though. In the case of failing flash from native Ubuntu 16.04 it should have worked.

Someone from NVIDIA may be able to find a more detailed reason why you hit the Error 1. However, a full flash log is probably needed. If you hover the mouse over the quote icon in the upper right of one of your existing posts, then other icons will show up. The paper clip icon would allow you to attach a full log (just give it a “.txt” file name suffix).

Hi linuxdev,
Thanks for your reply. As you said, tx2 could be booting but with no video configuration, but what could I do to the monitor? I mean I need it for display, and I also tried HDMI - VGA type monitor, it did not work either. I followed other threads to try to work this thing out, but all failed. Is the problem with tx2 4gb board? I read through NVIDIA L4T BSP for tx2 4gb version step by step to do configuration, after typing in $ sudo ./ jetson-tx2-as-4GB mmcblk0p1, I found it still failed with the same error report value 1. I just posted the flash log. Again, I really appreciate your help!

VGA is invalid since it cuts (literally) the wire which is used for EDID (which is the automatic configuration data). Pure HDMI, DVI (most, though not pure analog), and DisplayPort support EDID.

After a flash fails the unit is probably not bootable, although you would see an NVIDIA logo for a brief moment. I think you have done the actual flash steps correctly, and I’m hoping someone from NVIDIA can comment on the error. Part of the log shows some flash did occur, but later steps failed…this is the part in need of someone knowing more about reasons for that particular error.

Hi linuxdev,
Is there any chance that improper Internet connection leads to such failure? I connected both host and tx2 4gb to the router via wired cable.

JetPack3.3/L4T R28.2.1 uses only the micro-B USB cable for flash. No networking is involved, so this could not have any direct effect on flash failing. Networking between host PC and TX2 is used for extra package installs after flash completes.

There is one possible exception to network issues causing failure based on the fact that JetPack downloads a manifest and other packages to the host PC before starting the flash. If the host cannot talk to the internet, then parts of the flash software can be missing. However, it is unlikely flash would have started if this were the case. You could delete your JetPack directory and download again as there have been a few rare cases of corrupt download (you’d want to download JetPack itself after deleting the old content). I do not believe this is the case for your situation, but it doesn’t hurt to check (other than time required).

Mostly I’m curious what NVIDIA might say about this failure at the end of the log since there was evidence that some earlier steps succeeded at downloading data to the TX2/4GB:

[   4.6655 ] Added binary blob_tegra186-quill-p3310-1000-a00-00-base_sigheader.dtb.encrypt of size 279440
[   4.6798 ] 
[   4.6798 ] Sending bootloader and pre-requisite binaries
[   4.6825 ] tegrarcm_v2 --download blob blob.bin
[   4.6843 ] Applet version 01.00.0000
[   5.0045 ] Sending blob
[   5.1535 ] 
Error: Return value 1
Command tegrarcm_v2 --download blob blob.bin
Failed flashing t186ref.

Hi linuxdev,
I asked my colleague to help me with the flash, since he successfully flashed tx2 before, so I would keep updating the post once I get tx2 from him. Thanks for your help!

Has there been any more progress with this, I am also experiencing the same issue?