TX2 4GB not booting after successful flashing - Screen turns blank

Hi

I flashed the TX2 4GB more than 10 times with 4.6 & 4.4. I cannot access the TX2 via an HDMI connected monitor - nothing shows up. I can’t ssh to the TX2 although for varying periods after boot it can be pinged. Also tried the 3.3 jetpack.run file but it shows :

Sending blob
Error: Return value 1
Command tegrarcm_v2 --download blob blob.bin
Failed flashing t186ref.

what the is blob ?? i searched a lot
why my screen not turning on after showing nvidia, I tried 42" to 16" 'different displays with HDMI.
I am afraid there is a problem with the board ?

I am attaching the l0g.
SDKM_logs_JetPack_4.5.1_(rev.1)Linux_for_Jetson_TX2[4GB]_2021-12-09_09-46-25.zip|attachment (241.5 KB)

Hi,

Are you talking about you can flash jetpack4.6 on your TX2 module but it cannot give you the screen?

Yes, the flash session showing success, after that the screen not turning to booting option, where we set the username and password.
At that time my host pc is waiting to enter the username and password that we set on nvidia, but I couldn’t complete that process.

Time to use serial console to see what is going on there.

Serial Console shows an error:

Aux Info = 0x0, Reason = 0xd
[0?[0000.048] C > ERROR: Highest Layer Module = 0x40, Lowest Layer Module = 0x40,

Plz find the attached pic also

Please learn to dump the full log from the boot… if the log starts to repeat in the end, then ignore the repeated part…

And attach your log as a text file.

capturefile (15.4 KB)

Plz find the attached log from the boot, the log is on repeating pattern.
capturefile.txt (15.4 KB)

Do you have other TX2 4GB module that can validate your jetpack BSP is fine?

Unfortunately, I don’t have other.

Just want to confirm, currently this board is flashed by jetpack4.6 right?

If this is jetpack4.6, then we have nothing to do. This is probably hardware side problem. Please RMA the device.

BTW, jetpack3.3 does not support TX2-4GB, so flash failure is expected.

I just re-flash it with jetpack4.6 and i got the following line repeatedly:

[ 43.475509] tegradc 15210000.nvdisplay: sanitize_flip_args: WIN 3 invalid size:w=0,h=0,out_w=0,out_h=0
[ 43.775431] tegradc 15210000.nvdisplay: sanitize_flip_args: WIN 3 invalid size:w=0,h=0,out_w=0,out_h=0
[ 43.801669] tegradc 15210000.nvdisplay: sanitize_flip_args: WIN 3 invalid size:w=0,h=0,out_w=0,out_h=0

Check the attached log also
bootCap.txt (41.1 KB)

I think it is time to RMA this board.

Hi Wayne,

I tried with a TX1, I didn’t even get the nvidia boot logo. Please find the attached log.
jetLog1.txt (81.0 KB)

The log says it is waiting for you to configure the user account.

[ 10.074871] Please complete system configuration setup on desktop to proceed…

Nothing to do with your TX2 error.

But the display not turning on or didn’t get any boot window

I replaced the TX2 with a TX1, I got the flash process success and nothing will display on my monitor. The log shows complete the system configuration but how without a display?

I got different log on different flashing trials, please check that too.
JetLog2.txt (22.8 KB)
JetLog3.txt (119.9 KB)

Use this script before running flash.sh and it will bypass user configuration.

And just to clarify , is your carrier board a NV devkit or some custom board?