flash failed Tx2

Hi,
I was trying to use Jetpack-3.0 to flash OS images on TX-2. However, and host is ubuntu 14.04 LTS.
When I flash the OS, I got the following error message:

./tegraflash.py --chip 0x18 --applet "/home/jungle/workspace/jetpack3.0/64_TX2/Linux_for_Tegra_tx2/bootloader/mb1_recovery_dev.bin" --cmd "dump eeprom boardinfo cvm.bin" --skipuid 
Welcome to Tegra Flash
version 1.0.0
Type ? or help for help and q or quit to exit
Use ! to execute system commands
 
[   0.0016 ] Generating RCM messages
[   0.0026 ] tegrarcm_v2 --listrcm rcm_list.xml --chip 0x18 --download rcm /home/jungle/workspace/jetpack3.0/64_TX2/Linux_for_Tegra_tx2/bootloader/mb1_recovery_dev.bin 0 0
[   0.0035 ] File /home/jungle/workspace/jetpack3.0/64_TX2/Linux_for_Tegra_tx2/bootloader/mb1_recovery_dev.bin open failed
[   0.0035 ] Cannot create RCM messages
[   0.0035 ] 
Error: Return value 19
Command tegrarcm_v2 --listrcm rcm_list.xml --chip 0x18 --download rcm /home/jungle/workspace/jetpack3.0/64_TX2/Linux_for_Tegra_tx2/bootloader/mb1_recovery_dev.bin 0 0
Reading board information failed.

I also tried to use jetpack 3.0 and 3.1 with ubuntu 16.04 LTS, but I got the same message.
Does someone have same problem?
And can anyone help me in fixing this problem?

Thanks!

Hi wwjd228,

If you try “JetPack-L4T-3.1-linux-x64.run” in a clean folder, still hit the issue?

Additional question: Is this a VM host?

Hi linuxdev,

It’t not the VM host. My host dell inspiron 15 7570 laptop with ubuntu 14.04.

And I’m trying to use Jetpack 3.1

If this goes through a USB HUB can you try without the HUB? Is the USB cable the one supplied with the kit?

Hi vickyy,
I got the same error message and return value, when I tried the “JetPack-L4T-3.1-linux-x64.run” in a clean folder.

Hi linuxdev,
I don’t use the USB HUB, and the USB is the pure micro USB line…

By the way, I can not boot my Tx2 normally(no internet, and the screen shows “Not support input”). I used the HDMI to VGA converter, but I can boot the tx1 with same way.

Is that related to the flashing problem?

When the Jetson is in recovery mode does it show up with “lsusb”? FYI, “lsusb -d 0955:” shows all NVIDIA USB devices, “lsusb -d 0955:7721” shows all TX1s in recovery mode, and “lsusb -d 0955:7c18” shows all NVIDIA TX2s in recovery mode. If you see recovery mode devices then you know the USB pipe is functioning to at least some minimal extent…if you can’t see it via lsusb, then you know there is a USB issue needing a fix before you can continue.

Using a VGA adapter guarantees video cannot auto configure. This would of course have nothing to do with the flash problem, but if flash does succeed the monitor will only work if you get lucky and the default mode is something the monitor works with (VGA adapters literally cut the cable wire used for monitor query). So far as boot success goes, don’t count video not working as a way to determine if the system is failing.

Hello linuxdev,
Yes it show up with “lsusb”, but it’s error ID of Tx2 in recovery mode:

Bus 001 Device 007: ID 0955:7018 NVidia Corp.

It shows “7018” not “7c18”. I have to fix this problem first, if it were a problem…

And I think Tx2 isn’t booted normally, because the LED of SOC turn off after a few minutes, and network is not available.

PS:Everything works correctly on Tx1 in the same way.

Unless the hardware is non-standard it shouldn’t be possible for this value to differ. I would suspect a corrupt ROM if this is an ordinary TX2 and the ID does not match 0955:7c18. Or perhaps this is the ID of something else from NVIDIA and not the Jetson. Are you absolutely positive that the 0955:7018 shows up only when the TX2 is connected and in recovery mode? If this really is the TX2, what do you see from:

sudo lsusb -d 0955:7018 -vvv

Hello linuxdev,
Yes, the ID “0955:7018” shows up only when the TX2 is connected and in recovery mode.

And I saw the following information from “sudo lsusb -d 0955:7018 -vvv”:

Bus 001 Device 008: ID 0955:7018 NVidia Corp. 
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  idVendor           0x0955 NVidia Corp.
  idProduct          0x7018 
  bcdDevice            0.00
  iManufacturer           1 NVIDIA Corp.
  iProduct                2 APX
  iSerial                 0 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           32
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xc0
      Self Powered
    MaxPower               32mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass    255 Vendor Specific Subclass
      bInterfaceProtocol    255 Vendor Specific Protocol
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
Device Qualifier (for other device speed):
  bLength                10
  bDescriptorType         6
  bcdUSB               2.00
  bDeviceClass          255 Vendor Specific Class
  bDeviceSubClass       255 Vendor Specific Subclass
  bDeviceProtocol       255 Vendor Specific Protocol
  bMaxPacketSize0        64
  bNumConfigurations      1
Device Status:     0x0001
  Self Powered

Thanks for your help.

Is there anything at all custom about this hardware? I don’t know if NVIDIA has a product ID 0x7018…if not, then this is a hardware failure…if there is such a product, and if this really is a Jetson TX2, then you got the wrong chip (I see it listed as “APX”…perhaps this is a real product which is different from a JTX1/JTX2). On the assumption that this really is a JTX2 and is not customized, then you probably should RMA. RMA info is near the top of this:
https://devtalk.nvidia.com/default/topic/793798/embedded-systems/some-jetson-web-links/

Hi wwjd228,

Please make sure you’re using Jetson TX2 Developer Kit (https://developer.nvidia.com/embedded/buy/jetson-tx2-devkit).

Hi linuxdev, vickyy:

Yes, I think it might be a hardware failure. I will check it out!!

Thanks for your help.