Cannot flash TX2

I have both TX2 and TX1 devices and while I can flash the TX1 devices just fine, the TX2 device fails. I am running ubuntu 16.04 natively as recommended.

I can get the TX2 to show up in recovery mode via lsusb :

# craig @ aurxps in ~/Downloads/jetpack/64_TX2/Linux_for_Tegra_tx2 [10:07:25] C:1
$ lsusb | grep NVidia            
Bus 003 Device 016: ID 0955:7c18 NVidia Corp.

However when I attempt to flash the device it fails when trying to read the board information:

# craig @ aurxps in ~/Downloads/jetpack/64_TX2/Linux_for_Tegra_tx2 [10:07:18] C:1
$ sudo ./flash.sh jetson-tx2 sdb1     
./tegraflash.py --chip 0x18 --applet "/home/craig/Downloads/jetpack/64_TX2/Linux_for_Tegra_tx2/bootloader/mb1_recovery_prod.bin" --cmd "dump eeprom boardinfo cvm.bin" --skipuid 
Welcome to Tegra Flash
version 1.0.0
Type ? or help for help and q or quit to exit
Use ! to execute system commands
 
[   0.0023 ] Generating RCM messages
[   0.0034 ] tegrarcm_v2 --listrcm rcm_list.xml --chip 0x18 --download rcm /home/craig/Downloads/jetpack/64_TX2/Linux_for_Tegra_tx2/bootloader/mb1_recovery_prod.bin 0 0
[   0.0044 ] RCM 0 is saved as rcm_0.rcm
[   0.0050 ] RCM 1 is saved as rcm_1.rcm
[   0.0050 ] List of rcm files are saved in rcm_list.xml
[   0.0050 ] 
[   0.0050 ] Signing RCM messages
[   0.0059 ] tegrasign_v2 --key None --list rcm_list.xml --pubkeyhash pub_key.key
[   0.0067 ] Assuming zero filled SBK key
[   0.0108 ] 
[   0.0108 ] Copying signature to RCM mesages
[   0.0117 ] tegrarcm_v2 --chip 0x18 --updatesig rcm_list_signed.xml
[   0.0130 ] 
[   0.0131 ] Boot Rom communication
[   0.0138 ] tegrarcm_v2 --chip 0x18 --rcm rcm_list_signed.xml --skipuid
[   0.0145 ] Boot Rom communication failed
[   3.0441 ] 
Error: Return value 3
Command tegrarcm_v2 --chip 0x18 --rcm rcm_list_signed.xml --skipuid
Reading board information failed.

Not that it doens’t matter what “” I use, mmcblk0p1 doesn’t work either.

I thought that this was a hardware problem so I already sent the device back and got a different one, but I run into the same problem with this one as well.

Please advise.

Are you using a VM?

No, I’m running ubuntu 16.04 natively.

I will suggest trying to simplify and doing a manual command line install. Here is a cheat sheet:
https://devtalk.nvidia.com/default/topic/1001583/jetson-tx2/jetson-tx2-not-recognized-installation-inside-docker-error-8-error-return-value-8-command-tegrarcm_v2-chip-0x18-rcm-rcm_list_signed-xml-skipuid-reading-board-information-failed-/post/5116716/#5116716

NOTE: This is to rule out JetPack issues. JetPack can still be run after this to do other package updates/installs.

People have reported JetPack 3.1 installation issues using Ubuntu 16.04 on the host to install. The NVIDIA recommended version is 14.04.

I think 16.04 was originally to only supported platform, but I see now that 14.04 is recommended. I’ll try 14.04. But for now I’ll just skip the flashing.

Just FYI, command line flash only requires x86_64 Linux PC host, it is JetPack which requires Ubuntu 14.04. Also, I noticed you flashed to “sdb1”:

sudo ./flash.sh jetson-tx2 <b>sdb1</b>

sdb1 is not supported. You can flash to eMMC (mmcblk0p1), SD card (mmcblk1p1), or a USB SATA drive on “/dev/sda1” (so it seems sdb1 might have been a host designation, but the device flash refers to the part of the Jetson being flashed, not the host).

Thanks, but as I noted in the post it doesn’t batter which that I specify. mmcblk0p1 and mmcblk1p1 have the same problem.

mmcblko0p1

Did you spell that with the “o”? It shouldn’t be there.
Also mmcblk1p1 should only exist if you have an external SD card installed.

Are you using the carrier board from the devkit, or some other carrier board?
If you do “lsusb” on the host before you attempt to flash, does it see the NVIDIA device?

@snarky, I appreciate the attempt to help, it was a typo. Also as shown in the original post it shows up in lsusb.

Have you tried flashing from command line, or is this all via JetPack? I see some answers which might mean you tried on command line, but I wanted to verify since command line should work from any x86_64 Linux PC host, but JetPack needs to be run from Ubuntu 14.04.

Hi linuxdev, yes I have tried the command-line and it has the same problem.

Command line should remove any compatibility issues for the Linux host distribution which might exist under JetPack. Considering you have two units which fail in the same way (not on a VM), and fail using both command line and JetPack, the issue must be something to do with host, downloaded driver package corruption, or cables/USB hardware.

I would wonder first about whether the cable and/or any HUB might be getting in the way. Try a different port and different cable. If using a HUB, try direct without a HUB.

Try deleting your PC’s JetPack directory and downloading a fresh copy.

If this still fails, describe your PC’s hardware and setup (including how much spare disk space there is on the relevant flash software partition, e.g, via “df -H”).

I can flash TX1 devices without any problem with the same host and cables and installation of JetPack. So I’m skeptical that the host hardware is the issue. However, I will try it on another machine.

The driver package differs for a TX2 versus TX1, but so far as I know nothing which is part of the USB pipe or executable differs…I could be wrong, but it seems that only data should differ. The way data differs would not normally change the communications pipe, but trying on a different machine would validate that the error follows the host or the error follows the Jetson.