Boot Rom communication failed while flashing a Jetson TX2

Hello everyone,

I’m trying to flash a Jetson TX2 with Jetpack and I have the following error :

./ --chip 0x18 --applet "/home/flashing/Workspaces/JetPack/64_TX2/Linux_for_Tegra_tx2/bootloader/mb1_recovery_prod.bin" --cmd "dump eeprom boardinfo cvm.bin" --skipuid 
Welcome to Tegra Flash
version 1.0.0
Type ? or help for help and q or quit to exit
Use ! to execute system commands
[   0.0015 ] Generating RCM messages
[   0.0022 ] tegrarcm_v2 --listrcm rcm_list.xml --chip 0x18 --download rcm /home/flashing/Workspaces/JetPack/64_TX2/Linux_for_Tegra_tx2/bootloader/mb1_recovery_prod.bin 0 0
[   0.0028 ] RCM 0 is saved as rcm_0.rcm
[   0.0031 ] RCM 1 is saved as rcm_1.rcm
[   0.0031 ] List of rcm files are saved in rcm_list.xml
[   0.0031 ] 
[   0.0031 ] Signing RCM messages
[   0.0039 ] tegrasign_v2 --key None --list rcm_list.xml --pubkeyhash pub_key.key
[   0.0045 ] Assuming zero filled SBK key
[   0.0073 ] 
[   0.0073 ] Copying signature to RCM mesages
[   0.0084 ] tegrarcm_v2 --chip 0x18 --updatesig rcm_list_signed.xml
[   0.0095 ] 
[   0.0095 ] Boot Rom communication
[   0.0102 ] tegrarcm_v2 --chip 0x18 --rcm rcm_list_signed.xml --skipuid
[   0.0109 ] Boot Rom communication failed
[   3.0093 ] 
Error: Return value 3
Command tegrarcm_v2 --chip 0x18 --rcm rcm_list_signed.xml --skipuid
Reading board information failed.

My host is a native 14.04 Ubuntu (not a VM).
I can see “Bus 001 Device 029: ID 0955:7c18 NVidia Corp.” when I run lsusb.
I have enough place on my disk.
I tried to use the command-line like mentioned here :

I still have the same error.

Any idea how to solve this one ?

Thanks a lot !

You may try another USB cable.

I also faced similar error on a native but very old PC(1GB RAM), giving this system message (in dmesg or syslog):

INFO: task tegradevflash:<PID> blocked for more than 120 seconds.

Then I successfully flashed the image prepared by JetPack from the command line and then reused JetPack only later for post-install.

[EDIT: Faced this again, and the solution was to use a small USB hub between my old motherboard and the Jetson. The hub was not self powered, so it doubt it was a power issue. I guess this old MB (once it was struck by lightning from an ADSL box that died then, and forever lost integrated Ethernet…) has old USB controllers, and may have levels/timing issues.]

Hi Nicolas, if you are still experiencing the issue after the above suggestion, can you confirm that you are flashing a TX2 board with the TX2 BSP? One of our developers noticed the same error message when they tried to flash the production TX2 image to a TX1 board.

Hi !

I’m flashing the TX2 Board with an Astro Carrier. But it was indeed an hardware problem and I solved it.
Now, everything is working fine.

Thanks for your help !


Hi, how did you solve the hardware issue?