JetPack 2.3.1 - L4T R24.2.1 released for Jetson TX1

Hello everyone, NVIDIA’s released a software update for Jetson TX1. JetPack 2.3.1 and L4T R24.2.1 BSP. Highlights of the release include:

Multimedia API v24.2.1

  • Caffe to TensorRT model conversion tool
  • libargus samples
  • AE, AWB, Bayer Average Map
  • Video decode with TensorRT sample supports arbitrary batch size

Linux for Tegra 24.2.1

  • Multi-Camera support
  • 10 & 12-bit sensor support
  • White Point Correction
  • Camera stability and performance improvements

Links to resources, documentation, and downloads:

L4T 24.2.1 - https://developer.nvidia.com/embedded/linux-tegra
JetPack 2.3 - https://developer.nvidia.com/embedded/jetpack
Release Notes - https://developer.nvidia.com/embedded/dlc/l4t-release-notes-24-2-1

Hi Dusty

do you have an idea when there will be a Jetpack release that is compatible with Ubuntu 16.04 ?

Thanks

Galto

Hi Galto, JetPack supports Ubuntu 16.04 on Jetson TX1 and if you have trouble installing on 16.04 host, try disabling the host-side OpenCV4Tegra package.

Hi, I upgraded my Jetson TX1 using the latest Jetpack (2.3.1), however, on my CPU (Jetson TX1) when I run this command:

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies

the result is:

102000 204000 307200 403200 518400 614400 710400 825600 921600 1036800 1132800 1224000 1326000 1428000 1555500 1632000 1734000

and this command:
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq

shows:

1734000

With the original installation the max frequency available on the CortexA57 was 1.9125Ghz not 1.734Ghz as it shows now, what is wrong ?

Thanks,

Hi,

I can't understand the difference between JetPack 2.3.1 and L4T R24.2.1, can anyone briefly explain the difference? I have installed JetPack 2.3.1 on my TX1, do I have all what I could need during the developing or I have to install also L4T R24.2.1? 

Forgive me for the stupid question but I’m a beginner in this field.

Thanks.

The release notes give some information. See:
https://developer.nvidia.com/embedded/linux-tegra
…look for the “Release Notes” download.

A given L4T release is just a set of drivers on top of an Ubuntu release. Mostly it’s Ubuntu, but drivers designed for this specific hardware. JetPack is a graphical front end which can be used instead of command line to run the same L4T flash as what you would get from a combination of the driver package and sample rootfs. JetPack has additional package installation capabilities beyond just L4T flash.

it’s a good news!

Hi,

I tied to compile EGLStreams_CUDA_Interop sample, but egl.h and eglext.h was not found. Actually /usr/include/EGL is completely missing. As I remember it worked on 2.3.0.
Should I additionally install mesa EGL?

Thanks.

Hello world!

Couple of questions…

I’m running 16.10 (Mate not vanilla, but I shouldn’t think (hope) that would affect things?)… and I’m not feeling like switching back to 16.04 vanilla, so before I start to flash my new TX1 via Jetpack from my host, does anyone know if it will work?
i.e. has Jetpack been tested with 16.10 successfully or will I have to use the older LTS version of Ubuntu and incur that headache? (If so, a question for the devs… why, in terms of dependencies etc.?)

If 16.04 and not 16.10, has anyone managed to install from a live 16.04 usb, or is that just plaid crazy? (as it ain’t even plain crazy, 'cos I’m guessing there’s a few host side packages to reside there…)

Follow up question… my entire network runs SL5 or 6 (essentially RHEL) depending on age of machine and how our sysadmin feels about poking things… we’re looking at getting a few more dev kits for our students, so I’m guessing the most painless way is to throw 14.04 or 16.04 onto a laptop… hopefully not mine and install them all from there?

Thanks for any advice you can throw my way…

You can flash with any x86_64 Linux. You can only use JetPack (which is a front end to many packages plus flash) on Ubuntu. I think currently Ubuntu 14.04 is the only host, but I’m uncertain about that.

If the underlying file system is large and native Linux, then perhaps a USB or DVD live distribution would work. Permissions and file types must be preserved, so running on top of something like NTFS will not work. Issues might occur if USB stalls and interrupts download of packages to the Jetson. During flash only USB is used; once flash has finished only wired ethernet is used.

JetPack does not have to install extra packages on a host, but it provides a more convenient interface to many packages on the Jetson itself.

Hey LD, thanks for getting back to me…

So Jetpack works fine on 16.04… not even a bit on 16.10… so I ended up going back to the LTS, which is probably for the best anyway.
Re installing via USB… I think given more patience I could have gotten it to work, but sadly I’m not as patient as I used to be!
I tried to hunt around for details on using any old x86 system to flash but I’m not as patient as I used to be…

RE installations on the host, the only thing that hung was CUDA 8, as I’m guessing that my lack of cuda compliant gpu threw it off? Not to worry.

Did a headless install and update via ssh -t session in the end. I’m not too worried about the gui, but managed to update the TX1 via apt-get so all seems OK.

Hopefully I can find time to play with it in the afternoon after the students have gone home!

Thanks for the encouragement, sorry I couldn’t give your more positive news on the USB drive based install and flash.

APG

Any machine running CUDA does need the nVidia GPU…it is hardware-dependent.

Yeah, I was hoping there would be a cpu only variant (like Caffe) that I could use on A.N.Other machine to make interacting with the TX1 easier from our workstations in the UG lab… I’m sure something will be found to ease the students in…
Thanks again for the support!

-APG

Hi APG, in JetPack you can choose not to install CUDA8 on the host if you want. The CUDA Toolkit included with JetPack is the cross-compiling variant for ARM (predominantly used to cross-compile the numerous CUDA toolkit samples for Jetson on the host during post-flash install) or if you have a project which uses NVCC cross-compilation. You can choose to disable CUDA Toolkit install on host if desired and compile the samples onboard the Jetson after installation (which takes a bit more time but is otherwise the same).

Hey Dusty,
Thanks for the response. Yeah going through the GUI for Jetpack I turned off a lot of the client side stuff. I’m happily running the TX1 on it’s own for now and will see how it plays with the rest of the network after the holidays.

-APG

Did you guys managed to get OpenCV installed from 16.04?
It is the only component not installing