Host ubuntu16.04 install JetPack 2.3 error

Hello everyone!

My Host with ubuntu16.04, and also installed Nvidia Graphics Driver.

1、When I want to install JetPack 2.3, Pop-up warning box:
warning : We noticed you are running OS with non-EN locale. NVIDIA does not test nor support such configurations.

How do I deal with this ?

2、JetPack L4T 2.3 provides opencv 2.4.13,but faied.

Installing OpenCV for Tegra on Ubuntu 14.04 2.4.13-17 failed.
Return code:1
Error:OpenCV4Tegra cannot be installed on host. Please use following command on device to install packages before continuing:
sudo apt-get install libopencv4tegra libopencv4tegra-dev

When I run the command I get unmet dependencies message.

sudo apt-get install libopencv4tegra libopencv4tegra-dev

Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libopencv4tegra : Depends: libavcodec54 (>= 6:9.1-1) but it is not installable or
libavcodec-extra-54 (>= 6:9.18) but it is not installable
Depends: libavformat54 (>= 6:9.1-1) but it is not installable
Depends: libavutil52 (>= 6:9.1-1) but it is not installable
Depends: libswscale2 (>= 6:9.1-1) but it is not installable
E: Unable to correct problems, you have held broken packages.

Hi amylee_wang,

The host PC needs to be running Ubuntu 14.04, however, yours is Ubuntu 16.04 machine to cause this issue.

We have mentioned it at JetPack 2.3 portal - https://developer.nvidia.com/embedded/jetpack, also on system requirements section.

Thanks

1、I tried ubuntu 14.04, but failed.
Everytime I input “sudo apt-get update”, terminal shows that were not support!

2、Does the Host need to install Nvidia graphics driver before?

thank you!

Hi amylee_wang,

Did this happen right after flashing with JetPack? Did you attempt to flash again?
Also, did you check the time setting on the system? If the time is wrong something like that could happen.
Sometimes “sudo apt clean all” might help if it is a cache issue.

Thanks

Be careful to distinguish if the install is going to the desktop host versus the Jetson. JetPack can install to both…recent JetPack makes Ubuntu 16 available to the Jetson, but host would still run Ubuntu 14.

Can not run sudo apt-get?

Is your TX1’s network turned on?

Can you ‘ping google.com’ at the terminal?

Marc

When is Jetpack 2.3 going to be supported for Ubuntu 16.04 host? I recently moved my host to 16.04 because of other drivers no longer being supported for 14.04 unless I downgrade something else, which then causes something else to fail… you get the picture :)

I am running Jetpack2.3.1 on ubuntu16.04 . The same problem happened:
Jetpack output an error:

Installing OpenCV for Tegra on Ubunutu 14.04 2.4.13-17 failed.

Return Code: 1
Error: OpenCV4Tegra cannot be installed on host. Please use following command on device to install packages before continuing:
    sudo apt-get install libopencv4tegra libopencv4tegra-dev

I run the command “sudo apt-get install libopencv4tegra libopencv4tegra-dev”,then an error outputed:

"Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libopencv4tegra : Depends: libavcodec54 (>= 6:9.1-1) but it is not going to be installed or
                            libavcodec-extra-54 (>= 6:9.18) but it is not going to be installed
                   Depends: libavformat54 (>= 6:9.1-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
"

so why “Installing OpenCV for Tegra on Ubunutu 14.04 2.4.13-17” on ubuntu 16.04?

Can you give a try with the following command before the installation?

sudo add-apt-repository universe
sudo add-apt-repository multiverse
sudo apt-get update

I’d like to chime in here as well. Having the same issue

First started with 16.10. with the same issue OpenCV error Return Code 1. When I tried to run the sudo apt-get install libopencv4tegra libopencv4tegra-dev I received dependency errors for libopencv4tegra.

I then started fresh, and installed 14.10. Only to find out the installer for JetPackL42.3.1 will only run on 14.4 and 16.4 Well… Installed 16.4

Now i’ve got the same issue, but I’m running 16.4 I’ve also tried the suggestion above
sudo add-apt-repository universe
sudo add-apt-repository multiverse
sudo apt-get update

With errors aroudn invalid ‘Date’ entry for a number of files (_var_libopencv4tegra-repo_Release, _var_visionworks-repo_releases, etc…)

And yes the date and time are correct.

Any suggestions?
Thanks

The host needs to be running 14.04 regardless of what you’re flashing to the TX1. I would use a completely fresh install of 14.04 and start the whole process over again.

[/quote]

1、I tried ubuntu 14.04, but failed.
Everytime I input “sudo apt-get update”, terminal shows that were not support!

2、Does the Host need to install Nvidia graphics driver before?

[/quote]

Have you used this install to flash a TX1 before? I’ve found that the Jetpack will not work if you try to flash an older L4T after flashing a newer one.

The host needs to be running 14.04 regardless of what you’re flashing to the TX1. I would use a completely fresh install of 14.04 and start the whole process over again.

Have you used this install to flash a TX1 before? I’ve found that the Jetpack will not work if you try to flash an older L4T after flashing a newer one.

The pop-up while trying to run the JetPack under 14.10 stated specifically that 14.04 and 16.04 were supported. I went with 16.04 for the very reason that it’s near impossible to run “sudo apt-get update” on 14.10, and i figure it will be just as difficult as running under 14.04.

At this point i’m very disappointed with this entire process.

16 has never been supported as a host. 14.04 is the only release that is supported by the Jetpack.

As another user has stated: if you try to install JetPack on a 16.10 host, a box will be shown stating that only Ubuntu versions 14.04 and 16.04 on the host can be used to install JetPack.

Thus, I downloaded a 16.04 VM to do this. And now it looks like I am going to have to delete it and start all over again with a 14.04 VM. This really should be resolved.

I think I got it ,this install must be in the user of ROOT .that’s all, My PC is ubuntu 16.04