Error installing opencv in Jetpack 3.2 on host(ubuntu 16.04) PC.

While attempting to install Jetpack 3.2 on Jetson TX2 using host pc with ubuntu 16.04, following message pop up and cannot proceed.

Return Code: 1
Error: libopencv-python libopencv-samples  cannot be installed on host. Please manually run following command in terminal to install packages before continuing:
    sudo apt install /home/ladar/jetson/jetpack_download/libopencv_3.3.1_amd64.deb /home/ladar/jetson/jetpack_download/libopencv-dev_3.3.1_amd64.deb /home/ladar/jetson/jetpack_download/libopencv-python_3.3.1_amd64.deb /home/ladar/jetson/jetpack_download/libopencv-samples_3.3.1_amd64.deb

Seems like it fails to install opencv package however I already build installed opencv 3.3.1 on my PC.
I checked it by

$ dpkg -l | grep libopencv
ii  libopencv                                    3.3.1                                                 amd64        Open Computer Vision Library
ii  libopencv-calib3d2.4v5:amd64                                      amd64        computer vision Camera Calibration library
ii  libopencv-contrib2.4v5:amd64                                      amd64        computer vision contrib library
ii  libopencv-core2.4v5:amd64                                         amd64        computer vision core library
ii  libopencv-dev                                                     amd64        development files for opencv
ii  libopencv-features2d2.4v5:amd64                                   amd64        computer vision Feature Detection and Descriptor Extraction library
ii  libopencv-flann2.4v5:amd64                                        amd64        computer vision Clustering and Search in Multi-Dimensional spaces library
ii  libopencv-gpu2.4v5:amd64                                          amd64        computer vision GPU library
ii  libopencv-highgui2.4v5:amd64                                      amd64        computer vision High-level GUI and Media I/O library
ii  libopencv-imgproc2.4v5:amd64                                      amd64        computer vision Image Processing library
ii  libopencv-legacy2.4v5:amd64                                       amd64        computer vision legacy library
ii  libopencv-ml2.4v5:amd64                                           amd64        computer vision Machine Learning library
ii  libopencv-objdetect2.4v5:amd64                                    amd64        computer vision Object Detection library
ii  libopencv-ocl2.4v5:amd64                                          amd64        computer vision OpenCL support library
ii  libopencv-photo2.4v5:amd64                                        amd64        computer vision computational photography library
ii  libopencv-stitching2.4v5:amd64                                    amd64        computer vision image stitching library
ii  libopencv-superres2.4v5:amd64                                     amd64        computer vision Super Resolution library
ii  libopencv-ts2.4v5:amd64                                           amd64        computer vision ts library
ii  libopencv-video2.4v5:amd64                                        amd64        computer vision Video analysis library
ii  libopencv-videostab2.4v5:amd64                                    amd64        computer vision video stabilization library
ii  libopencv2.4-java                                                 all          Java bindings for the computer vision library
ii  libopencv2.4-jni                                                  amd64        Java jni library for the computer vision library


$ pkg-config --modversion opencv

Should I just ignore this and press NEXT button?

1 Like


Does this happen when you already installed opencv3.3.1 by yourself? I mean if you remove opencv3.3.1 first, could jetpack hits this issue?

Just want to clarify the cause of it. It looks like jetpack does not detect the package you’ve installed.

Hi, I uninstalled the opencv 3.3.1 built myself and also removed packages by
$ sudo apt-get -f install

And to check the current opencv version, I get
$ pkg-config --modversion opencv

But the same message still on and cannot proceed. Should I clean install ubuntu 16.04 ?

Following method seems to work

  1. Uninstall pre built opencv3.3.1

  2. try
    $ sudo apt-get -f install

  3. $ apt-get purge libhighgui-dev

Now the opencv in jetpack installed and I can proceed.

We have team to investigate this now.
These thread looks also the same issue. Please refer if any comment can help first.


was same for me, I have done what Kyubot said and everything went ok :-)


Same problem with OpenCV here, and Kyubot’s solution workek for me too!


i had the same issue and solved it thanks to @Kyubot

Used this .sh to uninstall opencv, run it more than one times as it uninstalls one library per execution.

sudo apt-get -f install
apt-get purge libhighgui-dev



this solve my problem,thanks

Another confirmation, this solved the problem.

1 Like