jetpack 3.3 install opencv error on host

Hi Experts

I began to flash my tx2 with jetpack 3.3. During the install process of opencv 3.3 on host I got this message:

Return Code: 1
Error: libopencv-python libopencv-samples cannot be installed on host. Please manually run following command in terminal to install packages before continuing:
sudo apt install /home/ubuntu/Jetpack33/jetpack_download/libopencv_3.3.1_amd64.deb /home/ubuntu/Jetpack33/jetpack_download/libopencv-dev_3.3.1_amd64.deb /home/ubuntu/Jetpack33/jetpack_download/libopencv-python_3.3.1_amd64.deb /home/ubuntu/Jetpack33/jetpack_download/libopencv-samples_3.3.1_amd64.deb

I then did the sudo apt and got the following error message:

Preparing to unpack …/libopencv-dev_3.3.1_amd64.deb …
Unpacking libopencv-dev (3.3.1) over (2.4.9.1+dfsg-1.5ubuntu1) …
dpkg: error processing archive /home/ubuntu/Jetpack33/jetpack_download/libopencv-dev_3.3.1_amd64.deb (–unpack):
trying to overwrite ‘/usr/include/opencv/cvaux.hpp’, which is also in package libcvaux-dev:amd64 2.4.9.1+dfsg-1.5ubuntu1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/home/ubuntu/Jetpack33/jetpack_download/libopencv-dev_3.3.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any hints?

Thanks,
sojohan

trying to overwrite '/usr/include/opencv/cvaux.hpp', which is also in package libcvaux-dev:amd64 2.4.9.1+dfsg-1.5ubuntu1

Looks like you have old 2.4.9 installed on your host. Could you purge it first?

Hi Wayne

Thanks. So I should use:

sudo apt-get purge libcvaux-dev ?

sojohans

Hello,

Sojohans, were you able to get this resolved. I’m also having the same issue. was wondering if you were able to make it work. Wayne’s suggestion to overwrite doesn’t make sense to me. When I purge libcvaux-dev I get the following.

Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libhighgui-dev : Depends: libopencv-highgui-dev but it is not going to be installed
 libopencv-dev : Depends: libopencv-core-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-ml-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-imgproc-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-video-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-objdetect-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-highgui-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-calib3d-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-flann-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-features2d-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-legacy-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-contrib-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-ts-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-photo-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-videostab-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-stitching-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-gpu-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-superres-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libopencv-ocl-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libcv-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
                 Depends: libcvaux-dev (= 2.4.9.1+dfsg-1.5ubuntu1.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Hi mascenzi

I used this script instead:

That worked for me…

sojohans

Perhaps you can check this link, it works well for me.

Run this command prior running JetPack installer.

sudo apt-get purge libhighgui-dev

https://devtalk.nvidia.com/default/topic/1029270/