JetPack 3.3 — L4T R28.2.1 Release for Jetson TX1/TX2

We’re pleased to announce that JetPack 3.3 is now available for Jetson TX2/TX2i and Jetson TX1!

The highlight of this release is TensorRT 4.0, enabling support for TensorFlow’s TensorRT integration feature. Also, cuDNN has a small update to support the new TensorRT version, and all other JetPack components remain unchanged from JetPack 3.2.1. Please view the Release Notes.

JetPack 3.3 components:

  • L4T R28.2.1 (TX2/TX2i)
  • L4T R28.2    (TX1)
  • CUDA 9.0
  • cuDNN 7.1.5
  • TensorRT 4.0
  • VisionWorks 1.6

Download JetPack…https://developer.nvidia.com/embedded/jetpack
Release Notes…https://developer.nvidia.com/embedded/jetpack-notes
L4T Release Notes…https://developer.nvidia.com/embedded/dlc/release-notes-r2821
L4T R28.2.1 Page…https://developer.nvidia.com/embedded/linux-tegra
L4T Archive Page…https://developer.nvidia.com/embedded/linux-tegra-archive

Hello sir, I am trying to install Jetpack 3.3 on Jetson Tx1. I downloaded Jetpack 3.3 to my host machine. My host pc is using Ubuntu 16.04 and is a customized system having GeForce GTX 1080 Gpu with CUDA 9 and CUDnn 7. I already installed some Deep Learning Libraries like Caffe and Tensorflow on host system along with OpenCV 3.4.1. So when i am trying to extract Jetpack using given guide i am getting an error like:

root     11081  0.1  0.0 199828  2816 ?        Ssl  16:30   0:01 /home/rohit/_installer/sudo_daemon -installer=10935 -d=/home/rohit/_installer/tmp
0
/home/rohit//_installer/run_command  -c="apt install -y /home/rohit/jetpack_download/libopencv_3.3.1_amd64.deb" -d=/home/rohit//_installer/tmp -l=/home/rohit/_installer/logs//opencv_host.log

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  linux-headers-4.13.0-43 linux-headers-4.13.0-43-generic
  linux-headers-4.13.0-45 linux-headers-4.13.0-45-generic
  linux-image-4.13.0-43-generic linux-image-4.13.0-45-generic
  linux-image-extra-4.13.0-43-generic linux-image-extra-4.13.0-45-generic
  linux-modules-extra-4.15.0-24-generic
Use 'apt autoremove' to remove them.
The following NEW packages will be installed:
  libopencv
0 upgraded, 1 newly installed, 0 to remove and 260 not upgraded.
Need to get 0 B/27.7 MB of archives.
After this operation, 149 MB of additional disk space will be used.
Get:1 /home/rohit/jetpack_download/libopencv_3.3.1_amd64.deb libopencv amd64 3.3.1 [27.7 MB]
dpkg-preconfigure: unable to re-open stdin: No such file or directory
Selecting previously unselected package libopencv.
(Reading database ... 508304 files and directories currently installed.)
Preparing to unpack .../libopencv_3.3.1_amd64.deb ...
Unpacking libopencv (3.3.1) ...
Setting up libopencv (3.3.1) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
root     11081  0.1  0.0 199828  3024 ?        Ssl  16:30   0:01 /home/rohit/_installer/sudo_daemon -installer=10935 -d=/home/rohit/_installer/tmp
0
/home/rohit//_installer/run_command  -c="apt install -y /home/rohit/jetpack_download/libopencv-dev_3.3.1_amd64.deb" -d=/home/rohit//_installer/tmp -l=/home/rohit/_installer/logs//opencv_host_dev.log

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  libhighgui-dev libilmbase-dev libopencv-calib3d2.4v5 libopencv-contrib2.4v5
  libopencv-gpu2.4v5 libopencv-legacy2.4v5 libopencv-ml2.4v5
  libopencv-ocl2.4v5 libopencv-photo2.4v5 libopencv-stitching2.4v5
  libopencv-superres2.4v5 libopencv-ts2.4v5 libopencv-videostab2.4v5
  libopencv2.4-java libopencv2.4-jni libopenexr-dev linux-headers-4.13.0-43
  linux-headers-4.13.0-43-generic linux-headers-4.13.0-45
  linux-headers-4.13.0-45-generic linux-image-4.13.0-43-generic
  linux-image-4.13.0-45-generic linux-image-extra-4.13.0-43-generic
  linux-image-extra-4.13.0-45-generic linux-modules-extra-4.15.0-24-generic
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  libcv-dev libcvaux-dev libopencv-calib3d-dev libopencv-contrib-dev
  libopencv-core-dev libopencv-features2d-dev libopencv-flann-dev
  libopencv-gpu-dev libopencv-highgui-dev libopencv-imgproc-dev
  libopencv-legacy-dev libopencv-ml-dev libopencv-objdetect-dev
  libopencv-ocl-dev libopencv-photo-dev libopencv-stitching-dev
  libopencv-superres-dev libopencv-ts-dev libopencv-video-dev
  libopencv-videostab-dev
The following packages will be upgraded:
  libopencv-dev
1 upgraded, 0 newly installed, 20 to remove and 260 not upgraded.
Need to get 0 B/1,120 kB of archives.
After this operation, 27.6 MB disk space will be freed.
Get:1 /home/rohit/jetpack_download/libopencv-dev_3.3.1_amd64.deb libopencv-dev amd64 3.3.1 [1,120 kB]
dpkg-preconfigure: unable to re-open stdin: No such file or directory
dpkg: libopencv-ts-dev:amd64: dependency problems, but removing anyway as you requested:
 libopencv-dev depends on libopencv-ts-dev (= 2.4.9.1+dfsg-1.5ubuntu1).

(Reading database ... 508362 files and directories currently installed.)
Removing libopencv-ts-dev:amd64 (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: libopencv-core-dev:amd64: dependency problems, but removing anyway as you requested:
 libopencv-imgproc-dev:amd64 depends on libopencv-core-dev (= 2.4.9.1+dfsg-1.5ubuntu1).
 libopencv-gpu-dev:amd64 depends on libopencv-core-dev (= 2.4.9.1+dfsg-1.5ubuntu1).
 libopencv-ml-dev:amd64 depends on libopencv-core-dev (= 2.4.9.1+dfsg-1.5ubuntu1).
 libcv-dev:amd64 depends on libopencv-core-dev.
 libopencv-dev depends on libopencv-core-dev (= 2.4.9.1+dfsg-1.5ubuntu1).
 libopencv-flann-dev:amd64 depends on libopencv-core-dev (= 2.4.9.1+dfsg-1.5ubuntu1).
 libcvaux-dev:amd64 depends on libopencv-core-dev.

Removing libopencv-core-dev:amd64 (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: libopencv-videostab-dev:amd64: dependency problems, but removing anyway as you requested:
 libopencv-dev depends on libopencv-videostab-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libopencv-videostab-dev:amd64 is to be removed.

Removing libopencv-videostab-dev:amd64 (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: libopencv-features2d-dev:amd64: dependency problems, but removing anyway as you requested:
 libcv-dev:amd64 depends on libopencv-features2d-dev; however:
  Package libopencv-features2d-dev:amd64 is to be removed.
 libopencv-dev depends on libopencv-features2d-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libopencv-features2d-dev:amd64 is to be removed.
 libopencv-calib3d-dev:amd64 depends on libopencv-features2d-dev (= 2.4.9.1+dfsg-1.5ubuntu1).
 libcvaux-dev:amd64 depends on libopencv-features2d-dev; however:
  Package libopencv-features2d-dev:amd64 is to be removed.

Removing libopencv-features2d-dev:amd64 (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: libopencv-stitching-dev:amd64: dependency problems, but removing anyway as you requested:
 libopencv-dev depends on libopencv-stitching-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libopencv-stitching-dev:amd64 is to be removed.

Removing libopencv-stitching-dev:amd64 (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: libopencv-flann-dev:amd64: dependency problems, but removing anyway as you requested:
 libcv-dev:amd64 depends on libopencv-flann-dev; however:
  Package libopencv-flann-dev:amd64 is to be removed.
 libopencv-dev depends on libopencv-flann-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libopencv-flann-dev:amd64 is to be removed.

Removing libopencv-flann-dev:amd64 (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: libopencv-superres-dev:amd64: dependency problems, but removing anyway as you requested:
 libopencv-dev depends on libopencv-superres-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libopencv-superres-dev:amd64 is to be removed.

Removing libopencv-superres-dev:amd64 (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: libopencv-highgui-dev:amd64: dependency problems, but removing anyway as you requested:
 libopencv-contrib-dev:amd64 depends on libopencv-highgui-dev (= 2.4.9.1+dfsg-1
5ubuntu1).
 libopencv-dev depends on libopencv-highgui-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libopencv-highgui-dev:amd64 is to be removed.
 libopencv-ocl-dev:amd64 depends on libopencv-highgui-dev (= 2.4.9.1+dfsg-1.5ubuntu1).
 libhighgui-dev:amd64 depends on libopencv-highgui-dev.
 libopencv-objdetect-dev:amd64 depends on libopencv-highgui-dev (= 2.4.9.1+dfsg-1.5ubuntu1).
 libopencv-legacy-dev:amd64 depends on libopencv-highgui-dev (= 2.4.9.1+dfsg-1.5ubuntu1).

Removing libopencv-highgui-dev:amd64 (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: libopencv-ocl-dev:amd64: dependency problems, but removing anyway as you requested:
 libopencv-dev depends on libopencv-ocl-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libopencv-ocl-dev:amd64 is to be removed.

Removing libopencv-ocl-dev:amd64 (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: libopencv-video-dev:amd64: dependency problems, but removing anyway as you requested:
 libopencv-contrib-dev:amd64 depends on libopencv-video-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libopencv-video-dev:amd64 is to be removed.
 libcv-dev:amd64 depends on libopencv-video-dev; however:
  Package libopencv-video-dev:amd64 is to be removed.
 libopencv-dev depends on libopencv-video-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libopencv-video-dev:amd64 is to be removed.
 libopencv-legacy-dev:amd64 depends on libopencv-video-dev (= 2.4.9.1+dfsg-1.5ubuntu1).
 libcvaux-dev:amd64 depends on libopencv-video-dev; however:
  Package libopencv-video-dev:amd64 is to be removed.

Removing libopencv-video-dev:amd64 (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: libopencv-imgproc-dev:amd64: dependency problems, but removing anyway as you requested:
 libcv-dev:amd64 depends on libopencv-imgproc-dev; however:
  Package libopencv-imgproc-dev:amd64 is to be removed.
 libopencv-dev depends on libopencv-imgproc-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libopencv-imgproc-dev:amd64 is to be removed.
 libcvaux-dev:amd64 depends on libopencv-imgproc-dev; however:
  Package libopencv-imgproc-dev:amd64 is to be removed.
 libopencv-photo-dev:amd64 depends on libopencv-imgproc-dev (= 2.4.9.1+dfsg-1.5ubuntu1).

Removing libopencv-imgproc-dev:amd64 (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: libcv-dev:amd64: dependency problems, but removing anyway as you requested:
 libopencv-dev depends on libcv-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libcv-dev:amd64 is to be removed.

Removing libcv-dev:amd64 (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: libopencv-legacy-dev:amd64: dependency problems, but removing anyway as you requested:
 libopencv-dev depends on libopencv-legacy-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libopencv-legacy-dev:amd64 is to be removed.
 libcvaux-dev:amd64 depends on libopencv-legacy-dev; however:
  Package libopencv-legacy-dev:amd64 is to be removed.

Removing libopencv-legacy-dev:amd64 (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: libopencv-ml-dev:amd64: dependency problems, but removing anyway as you requested:
 libopencv-contrib-dev:amd64 depends on libopencv-ml-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libopencv-ml-dev:amd64 is to be removed.
 libopencv-dev depends on libopencv-ml-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libopencv-ml-dev:amd64 is to be removed.

Removing libopencv-ml-dev:amd64 (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: libopencv-objdetect-dev:amd64: dependency problems, but removing anyway as you requested:
 libopencv-contrib-dev:amd64 depends on libopencv-objdetect-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libopencv-objdetect-dev:amd64 is to be removed.
 libopencv-dev depends on libopencv-objdetect-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libopencv-objdetect-dev:amd64 is to be removed.
 libcvaux-dev:amd64 depends on libopencv-objdetect-dev; however:
  Package libopencv-objdetect-dev:amd64 is to be removed.

Removing libopencv-objdetect-dev:amd64 (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: libopencv-photo-dev:amd64: dependency problems, but removing anyway as you requested:
 libopencv-dev depends on libopencv-photo-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libopencv-photo-dev:amd64 is to be removed.

Removing libopencv-photo-dev:amd64 (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: libopencv-gpu-dev:amd64: dependency problems, but removing anyway as you requested:
 libopencv-dev depends on libopencv-gpu-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libopencv-gpu-dev:amd64 is to be removed.

Removing libopencv-gpu-dev:amd64 (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: libopencv-contrib-dev:amd64: dependency problems, but removing anyway as you requested:
 libopencv-dev depends on libopencv-contrib-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libopencv-contrib-dev:amd64 is to be removed.
 libcvaux-dev:amd64 depends on libopencv-contrib-dev; however:
  Package libopencv-contrib-dev:amd64 is to be removed.

Removing libopencv-contrib-dev:amd64 (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: libopencv-calib3d-dev:amd64: dependency problems, but removing anyway as you requested:
 libopencv-dev depends on libopencv-calib3d-dev (= 2.4.9.1+dfsg-1.5ubuntu1); however:
  Package libopencv-calib3d-dev:amd64 is to be removed.
 libcvaux-dev:amd64 depends on libopencv-calib3d-dev; however:
  Package libopencv-calib3d-dev:amd64 is to be removed.

Removing libopencv-calib3d-dev:amd64 (2.4.9.1+dfsg-1.5ubuntu1) ...
(Reading database ... 508074 files and directories currently installed.)
Preparing to unpack .../libopencv-dev_3.3.1_amd64.deb ...
Unpacking libopencv-dev (3.3.1) over (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: error processing archive /home/rohit/jetpack_download/libopencv-dev_3.3.1_amd64.deb (--unpack):
 trying to overwrite '/usr/include/opencv/cvaux.hpp', which is also in package libcvaux-dev:amd64 2.4.9.1+dfsg-1.5ubuntu1
dpkg-deb (subprocess): decompressing archive member: internal gzip write error: Broken pipe
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg-deb (subprocess): cannot copy archive member from '/home/rohit/jetpack_download/libopencv-dev_3.3.1_amd64.deb' to decompressor pipe: failed to write (Broken pipe)
Errors were encountered while processing:
 /home/rohit/jetpack_download/libopencv-dev_3.3.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root     11081  0.1  0.0 199828  3252 ?        Ssl  16:30   0:01 /home/rohit/_installer/sudo_daemon -installer=10935 -d=/home/rohit/_installer/tmp
0
/home/rohit//_installer/run_command  -c="apt install -y /home/rohit/jetpack_download/libopencv-python_3.3.1_amd64.deb" -d=/home/rohit//_installer/tmp -l=/home/rohit/_installer/logs//opencv_host_python.log

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libcvaux-dev : Depends: libopencv-core-dev but it is not installed
                Depends: libopencv-imgproc-dev but it is not installed
                Depends: libopencv-features2d-dev but it is not installed
                Depends: libopencv-calib3d-dev but it is not installed
                Depends: libopencv-objdetect-dev but it is not installed
                Depends: libopencv-legacy-dev but it is not installed
                Depends: libopencv-video-dev but it is not installed
                Depends: libopencv-contrib-dev but it is not installed
 libhighgui-dev : Depends: libopencv-highgui-dev but it is not installed
 libopencv-dev : Depends: libopencv-core-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-ml-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-imgproc-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-video-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-objdetect-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-highgui-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-calib3d-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-flann-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-features2d-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-legacy-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-contrib-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-ts-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-photo-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-videostab-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-stitching-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-gpu-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-superres-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-ocl-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libcv-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
E: Unmet dependencies. Try using -f.
root     11081  0.1  0.0 199828  3264 ?        Ssl  16:30   0:01 /home/rohit/_installer/sudo_daemon -installer=10935 -d=/home/rohit/_installer/tmp
0
/home/rohit//_installer/run_command  -c="apt install -y /home/rohit/jetpack_download/libopencv-samples_3.3.1_amd64.deb" -d=/home/rohit//_installer/tmp -l=/home/rohit/_installer/logs//opencv_host_sample.log

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libcvaux-dev : Depends: libopencv-core-dev but it is not installed
                Depends: libopencv-imgproc-dev but it is not installed
                Depends: libopencv-features2d-dev but it is not installed
                Depends: libopencv-calib3d-dev but it is not installed
                Depends: libopencv-objdetect-dev but it is not installed
                Depends: libopencv-legacy-dev but it is not installed
                Depends: libopencv-video-dev but it is not installed
                Depends: libopencv-contrib-dev but it is not installed
 libhighgui-dev : Depends: libopencv-highgui-dev but it is not installed
 libopencv-dev : Depends: libopencv-core-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-ml-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-imgproc-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-video-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-objdetect-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-highgui-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-calib3d-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-flann-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-features2d-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-legacy-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-contrib-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-ts-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-photo-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-videostab-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-stitching-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-gpu-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-superres-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-ocl-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libcv-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
E: Unmet dependencies. Try using -f.

root     11081  0.1  0.0 273560  3276 ?        Ssl  16:30   0:02 /home/rohit/_installer/sudo_daemon -installer=10935 -d=/home/rohit/_installer/tmp
0
/home/rohit//_installer/run_command  -c="apt install -y /home/rohit/jetpack_download/libopencv_3.3.1_amd64.deb" -d=/home/rohit//_installer/tmp -l=/home/rohit/_installer/logs//opencv_host.log

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libcvaux-dev : Depends: libopencv-core-dev but it is not installed
                Depends: libopencv-imgproc-dev but it is not installed
                Depends: libopencv-features2d-dev but it is not installed
                Depends: libopencv-calib3d-dev but it is not installed
                Depends: libopencv-objdetect-dev but it is not installed
                Depends: libopencv-legacy-dev but it is not installed
                Depends: libopencv-video-dev but it is not installed
                Depends: libopencv-contrib-dev but it is not installed
 libhighgui-dev : Depends: libopencv-highgui-dev but it is not installed
 libopencv-dev : Depends: libopencv-core-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-ml-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-imgproc-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-video-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-objdetect-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-highgui-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-calib3d-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-flann-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-features2d-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-legacy-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-contrib-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-ts-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-photo-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-videostab-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-stitching-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-gpu-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-superres-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-ocl-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libcv-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
E: Unmet dependencies. Try using -f.
root     11081  0.1  0.0 273560  3336 ?        Ssl  16:30   0:02 /home/rohit/_installer/sudo_daemon -installer=10935 -d=/home/rohit/_installer/tmp
0
/home/rohit//_installer/run_command  -c="apt install -y /home/rohit/jetpack_download/libopencv-dev_3.3.1_amd64.deb" -d=/home/rohit//_installer/tmp -l=/home/rohit/_installer/logs//opencv_host_dev.log

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libcvaux-dev : Depends: libopencv-core-dev
                Depends: libopencv-imgproc-dev
                Depends: libopencv-features2d-dev
                Depends: libopencv-calib3d-dev
                Depends: libopencv-objdetect-dev
                Depends: libopencv-legacy-dev but it is not installed
                Depends: libopencv-video-dev
                Depends: libopencv-contrib-dev but it is not installed
 libhighgui-dev : Depends: libopencv-highgui-dev
 libopencv-dev : Depends: libopencv-core-dev (= 2.4.9.1+dfsg-1.5ubuntu1)
                 Depends: libopencv-ml-dev (= 2.4.9.1+dfsg-1.5ubuntu1)
                 Depends: libopencv-imgproc-dev (= 2.4.9.1+dfsg-1.5ubuntu1)
                 Depends: libopencv-video-dev (= 2.4.9.1+dfsg-1.5ubuntu1)
                 Depends: libopencv-objdetect-dev (= 2.4.9.1+dfsg-1.5ubuntu1)
                 Depends: libopencv-highgui-dev (= 2.4.9.1+dfsg-1.5ubuntu1)
                 Depends: libopencv-calib3d-dev (= 2.4.9.1+dfsg-1.5ubuntu1)
                 Depends: libopencv-flann-dev (= 2.4.9.1+dfsg-1.5ubuntu1)
                 Depends: libopencv-features2d-dev (= 2.4.9.1+dfsg-1.5ubuntu1)
                 Depends: libopencv-legacy-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-contrib-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-ts-dev (= 2.4.9.1+dfsg-1.5ubuntu1)
                 Depends: libopencv-photo-dev (= 2.4.9.1+dfsg-1.5ubuntu1)
                 Depends: libopencv-videostab-dev (= 2.4.9.1+dfsg-1.5ubuntu1)
                 Depends: libopencv-stitching-dev (= 2.4.9.1+dfsg-1.5ubuntu1)
                 Depends: libopencv-gpu-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-superres-dev (= 2.4.9.1+dfsg-1.5ubuntu1)
                 Depends: libopencv-ocl-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libcv-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
E: Unmet dependencies. Try using -f.
root     11081  0.1  0.0 273560  3380 ?        Ssl  16:30   0:02 /home/rohit/_installer/sudo_daemon -installer=10935 -d=/home/rohit/_installer/tmp
0
/home/rohit//_installer/run_command  -c="apt install -y /home/rohit/jetpack_download/libopencv-python_3.3.1_amd64.deb" -d=/home/rohit//_installer/tmp -l=/home/rohit/_installer/logs//opencv_host_python.log

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libcvaux-dev : Depends: libopencv-core-dev but it is not installed
                Depends: libopencv-imgproc-dev but it is not installed
                Depends: libopencv-features2d-dev but it is not installed
                Depends: libopencv-calib3d-dev but it is not installed
                Depends: libopencv-objdetect-dev but it is not installed
                Depends: libopencv-legacy-dev but it is not installed
                Depends: libopencv-video-dev but it is not installed
                Depends: libopencv-contrib-dev but it is not installed
 libhighgui-dev : Depends: libopencv-highgui-dev but it is not installed
 libopencv-dev : Depends: libopencv-core-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-ml-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-imgproc-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-video-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-objdetect-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-highgui-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-calib3d-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-flann-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-features2d-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-legacy-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-contrib-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-ts-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-photo-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-videostab-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-stitching-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-gpu-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-superres-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-ocl-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libcv-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
E: Unmet dependencies. Try using -f.
root     11081  0.1  0.0 273560  3392 ?        Ssl  16:30   0:02 /home/rohit/_installer/sudo_daemon -installer=10935 -d=/home/rohit/_installer/tmp
0
/home/rohit//_installer/run_command  -c="apt install -y /home/rohit/jetpack_download/libopencv-samples_3.3.1_amd64.deb" -d=/home/rohit//_installer/tmp -l=/home/rohit/_installer/logs//opencv_host_sample.log

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libcvaux-dev : Depends: libopencv-core-dev but it is not installed
                Depends: libopencv-imgproc-dev but it is not installed
                Depends: libopencv-features2d-dev but it is not installed
                Depends: libopencv-calib3d-dev but it is not installed
                Depends: libopencv-objdetect-dev but it is not installed
                Depends: libopencv-legacy-dev but it is not installed
                Depends: libopencv-video-dev but it is not installed
                Depends: libopencv-contrib-dev but it is not installed
 libhighgui-dev : Depends: libopencv-highgui-dev but it is not installed
 libopencv-dev : Depends: libopencv-core-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-ml-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-imgproc-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-video-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-objdetect-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-highgui-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-calib3d-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-flann-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-features2d-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-legacy-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-contrib-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-ts-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-photo-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-videostab-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-stitching-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-gpu-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-superres-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libopencv-ocl-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
                 Depends: libcv-dev (= 2.4.9.1+dfsg-1.5ubuntu1) but it is not installed
E: Unmet dependencies. Try using -f.

Also i tried to remove the error by manually installing the required packages through terminal but got this error:

sudo apt -f install /home/rohit/jetpack_download/libopencv_3.3.1_amd64.deb /home/rohit/jetpack_download/libopencv-dev_3.3.1_amd64.deb /home/rohit/jetpack_download/libopencv-python_3.3.1_amd64.deb /home/rohit/jetpack_download/libopencv-samples_3.3.1_amd64.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
Note, selecting 'libopencv' instead of '/home/rohit/jetpack_download/libopencv_3.3.1_amd64.deb'
Note, selecting 'libopencv-dev' instead of '/home/rohit/jetpack_download/libopencv-dev_3.3.1_amd64.deb'
Note, selecting 'libopencv-python' instead of '/home/rohit/jetpack_download/libopencv-python_3.3.1_amd64.deb'
Note, selecting 'libopencv-samples' instead of '/home/rohit/jetpack_download/libopencv-samples_3.3.1_amd64.deb'
libopencv is already the newest version (3.3.1).
The following packages were automatically installed and are no longer required:
  libhighgui-dev libilmbase-dev libopencv-calib3d2.4v5 libopencv-contrib2.4v5
  libopencv-gpu2.4v5 libopencv-legacy2.4v5 libopencv-ml2.4v5
  libopencv-ocl2.4v5 libopencv-photo2.4v5 libopencv-stitching2.4v5
  libopencv-superres2.4v5 libopencv-ts2.4v5 libopencv-videostab2.4v5
  libopencv2.4-java libopencv2.4-jni libopenexr-dev linux-headers-4.13.0-43
  linux-headers-4.13.0-43-generic linux-headers-4.13.0-45
  linux-headers-4.13.0-45-generic linux-image-4.13.0-43-generic
  linux-image-4.13.0-45-generic linux-image-extra-4.13.0-43-generic
  linux-image-extra-4.13.0-45-generic linux-modules-extra-4.15.0-24-generic
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  libcvaux-dev
The following NEW packages will be installed:
  libopencv-python libopencv-samples
The following packages will be upgraded:
  libopencv-dev
1 upgraded, 2 newly installed, 1 to remove and 260 not upgraded.
Need to get 0 B/2,210 kB of archives.
After this operation, 7,948 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 /home/rohit/jetpack_download/libopencv-dev_3.3.1_amd64.deb libopencv-dev amd64 3.3.1 [1,120 kB]
Get:2 /home/rohit/jetpack_download/libopencv-python_3.3.1_amd64.deb libopencv-python amd64 3.3.1 [906 kB]
Get:3 /home/rohit/jetpack_download/libopencv-samples_3.3.1_amd64.deb libopencv-samples amd64 3.3.1 [184 kB]
(Reading database ... 508074 files and directories currently installed.)
Preparing to unpack .../libopencv-dev_3.3.1_amd64.deb ...
Unpacking libopencv-dev (3.3.1) over (2.4.9.1+dfsg-1.5ubuntu1) ...
dpkg: error processing archive /home/rohit/jetpack_download/libopencv-dev_3.3.1_amd64.deb (--unpack):
 trying to overwrite '/usr/include/opencv/cvaux.hpp', which is also in package libcvaux-dev:amd64 2.4.9.1+dfsg-1.5ubuntu1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /home/rohit/jetpack_download/libopencv-dev_3.3.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Can you please suggest me how can i overcome this error ?

Since you have previously installed CUDA packages on your host PC that you presumably wish to keep, have you tried deselecting the host-side packages from the JetPack GUI so that it doesn’t try to install them on the host?

The host packages are listed at the top of the JetPack Component Manager, and the ones that are install to the Target (Jetson) are listed towards the bottom.

Hello Sir, Thanks for your response. I tried to deselect Opencv for host system through JetPack GUI Manager and as a result the VisionWorks package is also getting deselected. Now i am not sure whether it will help or not. Waiting for your guidance.

I would like to use ethernet or IP camera for surround view for an industrial application. Has anybody done this? The latency should be within 2~3 frames.

That should just pertain to VisionWorks for the host - you should still be able to install VisionWorks on your target Jetson.

Hi, please refer to this other thread:

https://devtalk.nvidia.com/default/topic/1037990/jetson-tx2/surround-or-area-view-using-ethernet-or-ip-camera/

Until now, the host still has to be ubuntu 16.04? I just installed a 18.04 version and configured all other deep learning environment
, is there will be a way to keep using ubuntu 18.04 to fresh JetPack? Or in the future can support for newer ubuntu version officially.

Hello, @dusty_nv I followed your advice and after 6 hours of installation i am stuck here:

82% [Waiting of headers]: Broken pipe

dpkg-query: package .cuda-toolkit-9-0. is not installed and no information is available
dpkg-query: package .libfreeimage-dev. is not installed and no information is available
dpkg-query: package .libopenmpi-dev. is not installed and no information is available
dpkg-query: package .openmpi-bin. is not installed and no information is available
Use dpkg --info (= dpkg deb info) to examine archive files, and dpkg --contents (= dpkg-deb --contents) to list their contents. 1

Error: CUDA cannot be installed on device. This may be caused by other apt-get command running on device when installing CUDA. Please use apt-get command in at terminal to make sure following packages are installed correctly on device before continuing: cuda-toolkit-9-0 libgompl libfreeimage-dev libopenmpi-dev openmpi-bin after these packages are installed on device, press Enter key to continue

Please advice on this. I also followed this link https://devtalk.nvidia.com/default/topic/1036338/jetson-tx1/unable-to-complete-post-installation-of-jetpack-3-2-on-tx1-cuda-9-0-installation-fails/ but didn’t download the cuda manually. Waiting for your reply. Shall i start installing Jetpack from the beginning ?

Ubuntu 16.04 is the recommended host version for JetPack 3.3, official support for 18.04 will be coming in a future release.

Can you boot up your Jetson and try running the following commands on your Jetson?

$ sudo apt-get update
$ sudo apt-get install cuda-toolkit-9-0 libgompl libfreeimage-dev libopenmpi-dev openmpi-bin

You could also try running the Post-Install steps of JetPack again, you don’t need to start from the beginning. Deselect everything from the JetPack Component Manager except for the software packages installed to the target Jetson after the entries for L4T (scroll down towards the bottom).

When you run the apt steps above, it should verify that your Jetson can access the internet. Also make sure your host and Jetson can ping each other.

Hello, I followed your step and installed CUDA and other packages. After that i tried to run https://github.com/dusty-nv/jetson-inference on Jetson Tx1 and failed. Below is the error i am getting when i type make. I already remove the error related to std::vector undefined and error related to conversion of string to a ghar. But now i am stuck here.

nvidia@tegra-ubuntu:~/jetson-inference/build$ make 
-- system arch:  aarch64
-- output path:  /home/nvidia/jetson-inference/build/aarch64
-- Copying /home/nvidia/jetson-inference/segNet.h
-- Copying /home/nvidia/jetson-inference/detectNet.h
-- Copying /home/nvidia/jetson-inference/tensorNet.h
-- Copying /home/nvidia/jetson-inference/imageNet.h
-- Copying /home/nvidia/jetson-inference/util/loadImage.h
-- Copying /home/nvidia/jetson-inference/util/commandLine.h
-- Copying /home/nvidia/jetson-inference/util/camera/gstCamera.h
-- Copying /home/nvidia/jetson-inference/util/camera/gstUtility.h
-- Copying /home/nvidia/jetson-inference/util/camera/v4l2Camera.h<a target='_blank' rel='noopener noreferrer' href=''></a>
-- Copying /home/nvidia/jetson-inference/util/cuda/cudaMappedMemory.h
-- Copying /home/nvidia/jetson-inference/util/cuda/cudaOverlay.h
-- Copying /home/nvidia/jetson-inference/util/cuda/cudaFont.h
-- Copying /home/nvidia/jetson-inference/util/cuda/cudaYUV.h
-- Copying /home/nvidia/jetson-inference/util/cuda/cudaResize.h
-- Copying /home/nvidia/jetson-inference/util/cuda/cudaRGB.h
-- Copying /home/nvidia/jetson-inference/util/cuda/cudaUtility.h
-- Copying /home/nvidia/jetson-inference/util/cuda/cudaNormalize.h
-- Copying /home/nvidia/jetson-inference/util/display/glUtility.h
-- Copying /home/nvidia/jetson-inference/util/display/glTexture.h
-- Copying /home/nvidia/jetson-inference/util/display/glDisplay.h
-- Copying /home/nvidia/jetson-inference/data/images/bird_0.jpg
-- Copying /home/nvidia/jetson-inference/data/images/granny_smith_1.jpg
-- Copying /home/nvidia/jetson-inference/data/images/dog_2.jpg
-- Copying /home/nvidia/jetson-inference/data/images/drone_0436.png
-- Copying /home/nvidia/jetson-inference/data/images/granny_smith_0.jpg
-- Copying /home/nvidia/jetson-inference/data/images/airplane_0.jpg
-- Copying /home/nvidia/jetson-inference/data/images/bottle_0.jpg
-- Copying /home/nvidia/jetson-inference/data/images/red_apple_0.jpg
-- Copying /home/nvidia/jetson-inference/data/images/peds-001.jpg
-- Copying /home/nvidia/jetson-inference/data/images/dog_0.jpg
-- Copying /home/nvidia/jetson-inference/data/images/banana_0.jpg
-- Copying /home/nvidia/jetson-inference/data/images/fontmapA.png
-- Copying /home/nvidia/jetson-inference/data/images/drone_0255.png
-- Copying /home/nvidia/jetson-inference/data/images/dog_1.jpg
-- Copying /home/nvidia/jetson-inference/data/images/fontmapB.png
-- Copying /home/nvidia/jetson-inference/data/images/peds-002.jpg
-- Copying /home/nvidia/jetson-inference/data/images/cat_0.jpg
-- Copying /home/nvidia/jetson-inference/data/images/peds-004.jpg
-- Copying /home/nvidia/jetson-inference/data/images/orange_1.jpg
-- Copying /home/nvidia/jetson-inference/data/images/drone_0435.png
-- Copying /home/nvidia/jetson-inference/data/images/orange_0.jpg
-- Copying /home/nvidia/jetson-inference/data/images/drone_0427.png
-- Copying /home/nvidia/jetson-inference/data/images/peds-003.jpg
-- Copying /home/nvidia/jetson-inference/data/images/drone_0428.png
-- Doxygen detected, to build API reference, run `make docs`
-- Configuring done
-- Generating done
-- Build files have been written to: /home/nvidia/jetson-inference/build
[ 51%] Building NVCC (Device) object CMakeFiles/jetson-inference.dir/util/cuda/jetson-inference_generated_cudaNormalize.cu.o
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
[ 51%] Building NVCC (Device) object CMakeFiles/jetson-inference.dir/jetson-inference_generated_imageNet.cu.o
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
[ 51%] Building NVCC (Device) object CMakeFiles/jetson-inference.dir/util/cuda/jetson-inference_generated_cudaRGB.cu.o
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
[ 51%] Building NVCC (Device) object CMakeFiles/jetson-inference.dir/util/cuda/jetson-inference_generated_cudaFont.cu.o
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
[ 51%] Building NVCC (Device) object CMakeFiles/jetson-inference.dir/util/cuda/jetson-inference_generated_cudaResize.cu.o
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
[ 51%] Building NVCC (Device) object CMakeFiles/jetson-inference.dir/util/cuda/jetson-inference_generated_cudaYUV-YUYV.cu.o
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
[ 51%] Building NVCC (Device) object CMakeFiles/jetson-inference.dir/util/cuda/jetson-inference_generated_cudaOverlay.cu.o
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
/home/nvidia/jetson-inference/util/cuda/cudaOverlay.cu(47): warning: variable "thick" was declared but never referenced

/home/nvidia/jetson-inference/util/cuda/cudaOverlay.cu(26): warning: function "eq_less" was declared but never referenced

<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
/home/nvidia/jetson-inference/util/cuda/cudaOverlay.cu(47): warning: variable "thick" was declared but never referenced

/home/nvidia/jetson-inference/util/cuda/cudaOverlay.cu(26): warning: function "eq_less" was declared but never referenced

[ 51%] Building NVCC (Device) object CMakeFiles/jetson-inference.dir/util/cuda/jetson-inference_generated_cudaYUV-NV12.cu.o
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
[ 51%] Building NVCC (Device) object CMakeFiles/jetson-inference.dir/util/cuda/jetson-inference_generated_cudaYUV-YV12.cu.o
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:2: warning: ISO C++11 requires whitespace after the macro name
<command-line>:0:7: warning: ISO C++11 requires whitespace after the macro name
Scanning dependencies of target jetson-inference
[ 51%] Building CXX object CMakeFiles/jetson-inference.dir/tensorNet.cpp.o
/home/nvidia/jetson-inference/tensorNet.cpp: In member function ‘bool tensorNet::LoadNetwork(const char*, const char*, const char*, const char*, const std::vector<std::__cxx11::basic_string<char> >&, uint32_t)’:
/home/nvidia/jetson-inference/tensorNet.cpp:221:115: error: ‘NV_GIE_VERSION’ was not declared in this scope
 ild %u\n", NV_TENSORRT_MAJOR, NV_TENSORRT_MINOR, NV_TENSORRT_PATCH, NV_GIE_VERS
                                                                     ^
CMakeFiles/jetson-inference.dir/build.make:1345: recipe for target 'CMakeFiles/jetson-inference.dir/tensorNet.cpp.o' failed
make[2]: *** [CMakeFiles/jetson-inference.dir/tensorNet.cpp.o] Error 1
CMakeFiles/Makefile2:67: recipe for target 'CMakeFiles/jetson-inference.dir/all' failed
make[1]: *** [CMakeFiles/jetson-inference.dir/all] Error 2
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2

Please take a look and why is it so difficult to install everything here.
Waiting for your reply.

I have resolved the problem. Thanks.

Hi trohit920, I pushed a change earlier to the repo, so master is updated now.

Hi experts

Just installed jetpack 3.3. I see that opencv3.3 is in the package. Does it contains bindings for python3?

Both python2 and python3 is installed and works fine…

By the way it was also necceasary for me to manually install:

$ sudo apt-get install cuda-toolkit-9-0 libgompl libfreeimage-dev libopenmpi-dev openmpi-bin

After that the Jetpack continued.

Is there a set of commands I can check that my installation is ok?

nvcc --Version works fine!

I was also able to compile Cuda 9 samples…

Thanks,
sojohans

Hi sojohans, you may want to check cv::getBuildInformation() if you are not sure about the configuration. You may wish to rebuild OpenCV from source with the exact config that you desire. This thread may be relevant. If you continue to experience an issue with the package, you can post a new topic for more in-depth feedback.

Hi,

When I try to import cv2 in python3 I get:

Python 3.5.2 (default, Nov 23 2017, 16:37:01)
[GCC 5.4.0 20160609] on linux
Type “help”, “copyright”, “credits” or “license” for more information.

import cv2
Traceback (most recent call last):
File “”, line 1, in
ImportError: No module named ‘cv2’

In python2 I get:

Python 2.7.11+ (default, Apr 17 2016, 14:00:29)
[GCC 5.3.1 20160413] on linux2
Type “help”, “copyright”, “credits” or “license” for more information.

import cv2
ImportError: numpy.core.multiarray failed to import
Traceback (most recent call last):
File “”, line 1, in
ImportError: numpy.core.multiarray failed to import

Any ideas?

Thanks,

Sojohans

Hi Sojahans, from this thread it looks like you are trying to rebuild OCV (presumably with the desired configuration), let us know if it fixes your Python issue.

Hi Dusty_nv

I got it to work! Just installed opencv 3.2 from scratch and used:

Cheers,

sojohans

It seems that JetPack 3.3 doesn’t have python3 binding for opencv.

$ python3 -c "import cv2"
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named 'cv2'

It is expected to have library in proper path when you successfully build and install opencv with python3 binding.
Usually it is located in one of belows
/usr/local/lib/python3.5/site-packages/
~/.local/lib/python3.5/site-packages/

$ ls ~/.local/lib/python3.5/site-packages/cv2*
~/.local/lib/python3.5/site-packages/cv2.cpython-35m-aarch64-linux-gnu.so

For reference, JetPack 4.2 ships python3 binding for opencv.

$ ls /usr/lib/python3.6/dist-packages/cv2*
/usr/lib/python3.6/dist-packages/cv2.cpython-36m-aarch64-linux-gnu.so