JetPack 4.3 - L4T R32.3.1 released

We are pleased to announce JetPack 4.3 supporting Jetson AGX Xavier series, Jetson TX2 series, Jetson TX1, and Jetson Nano.

JetPack 4.3 key features include new versions of TensorRT and cuDNN, Docker support for CSI cameras, Xavier DLA, and Video Encoder from within containers, and a new Debian package server put in place to host all NVIDIA JetPack-L4T components for installation and future JetPack OTA updates.

Please refer to the JetPack Release Notes and L4T Release Notes for additional info.

JetPack 4.3 Highlights:

  • Support for TensorRT 6.0.1 and cuDNN 7.6.3
  • Full support for DLA INT8 on Jetson AGX Xavier
  • Support for installation of JetPack components via Debian package archives
    • JetPack components are provided as Debian packages via a public APT server hosted by NVIDIA, enabling easier upgrades of JetPack components to future versions. Previous versions of JetPack need to be re-flashed to JetPack 4.3, after which the APT server can be used.
  • Support for CSI, DLA, and Video Encoder from within containers
    • On all Jetson products: Camera Serial Interface (CSI) and NVENC are now supported from within containers.
    • On Jetson AGX Xavier series only: NVIDIA Deep Learning Accelerator (DLA) engines are now supported from within containers.
  • Support for DeepStream 4.0.2
  • Support for ISAAC SDK version 2019.3
  • New easy to use Jetson-IO tool to configure 40-pin header on Jetson developer kits
  • Developer preview of VPI (Vision Programing Interface), a software library that provides Computer Vision and Image Processing algorithms implemented on Xavier Vision Accelerator, GPU and CPU.
    • GPU and CPU implementations are not optimized for performance in this preview release of VPI. A future release will bring performance optimized GPU and CPU implementations

JetPack 4.3 components:

  • L4T R32.3.1 (K4.9)
  • Ubuntu 18.04 LTS aarch64
  • CUDA 10.0
  • cuDNN 7.6.3
  • TensorRT 6.0.1
  • VisionWorks 1.6
  • OpenCV 4.1
  • Nsight Systems 2019.6
  • Nsight Graphics 2019.5
  • Nsight Compute 2019.3
  • SDK Manager 1.0.0

Download JetPack…https://developer.nvidia.com/embedded/jetpack
JetPack Release Notes…https://docs.nvidia.com/jetson/jetpack/release-notes/index.html
L4T Release Notes…https://developer.nvidia.com/jetson-linux-driver-package-release-notes-r3231-ga

Good news that the JetPack is finally available as Debian package, makes updating a whole lot easier!

Regarding “Camera Serial Interface (CSI) and NVENC are now supported from within containers”, what is ment by containers? Is there a guide on how to use this? Or is it like with the Jetson-IO tool using the overlay functions?

Hi IceBlackz, it means that you can use those hardware devices from within containers like Docker (see here for more info)

Need write up for R32.3.1 to edit and update kernel dtb
Terry

Is it possible to release some up to date inference benchmarks with the TX2 with the latest jetpack?

Hi all, we have a new on-demand webinar about JetPack 4.3, covering what’s new and a deep-dive on key features.

It’s now available to stream here: https://nvda.ws/2T0DNDk

Hi,I want to open the 2th usb3.0 port for the TX2.Is it support to change the power tree in the JetPack 4.3 - L4T R32.3.1 code resource? Thanks.

SDK manager refuses to work telling me that I am not enrolled in the correct developer program.

Keep in mind that although it is difficult to see, that there are actually two logins possible. One is for partners, and the other is for regular developers. If you picked the wrong drop down as to which one to log in to, then it will say you are not enrolled.

I didn’t. I made sure.

I know have the same issue on 2 different computers on the same network.

Are you able to manually (in a web browser) log in to the documentation URL?
https://developer.nvidia.com/embedded/downloads

If this fails or succeeds it would offer some debug information.

It works with no problem on my end.

This would be the same login as the regular developer login via SDK Manager. The other login is for partners. If you can log in to this, then it means the regular developer login should also work from SDKM. Look very closely at which login you are using since it may not be obvious that it is a drop-down menu. Do you see the “partners” option? Choose the opposite, and if this still fails, then there is a true error in the login.

I triple check on both systems i attempted a login on. Both showed the same error.

Fixed the sdk manager issue. Had a problem with the default dns config on my system. You need to change the resolv.conf file in /etc/ with a new name server ip of the default Google one at 8.8.8.8.

Hi Dusty:

I have a Jetson TX2 with the JetPack 4.2 (L4T 32.1.0). Its carrier board is P3310-1000. I want to upgrade the TX2 from JetPack 4.2 to JetPack 4.3 (L4T 32.3.1). I know that the SDK Manager can flash the new JetPack 4.3. However, the TX2 is assembled into an aluminum case. So it is not convenient to unpack the TX2 carrier board from the aluminum case and operate the switch and recovery button. Can I directly upgrade the TX2 from JetPack 4.2 to JetPack4.3 with the command lines of the Package Management Tool as follows.

sudo apt-get update
sudo apt-get install nvidia-jetpack

Please have a look at the following weblink of Package Management Tool.

nvidia: https://docs.nvidia.com/jetson/jetpack/install-jetpack/index.html

Look forward to hearing from you.

Mike

Hi @mikechen6688, the apt-based upgrade mechanism was introduced in JetPack 4.3, so you need to be on JetPack 4.3 or newer to use it to upgrade JetPack. Since you are currently on JetPack 4.2, you will need to access the micro-USB port to flash it. But once you are on JetPack 4.3, you shouldn’t need to do that anymore.

Hi Dusty:

Thanks. I have installed the JetPack 4.4.DP in TX2 with the the sdkmanager. Its version. is sdkmanager_1.1.0-6343_amd64.deb. However, I could not install the TensorFlow by the following command since JetPack 4.4 DP does not support any TensorFlow versions right now.

$ sudo pip3 install --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v44 tensorflow-gpu==1.15.2+nv20.3

or

$ sudo pip3 install tensorflow-gpu

ERROR: Could not find a version that satisfies the requirement tensorflow (from versions: none)
ERROR: No matching distribution found for tensorflow

Since I checked the TensorFlow versions and compatibility between JetPack 4.4 DP and
TensorFlow, I have found out that there is no TensorFlow version supporting JetPack 4.4 DP on Jetson TX2. I am pleased to give the following weblinks for your reference.

tf versions: https://developer.nvidia.com/embedded/downloads#?search=Tensorflow

installing tensorflow: https://docs.nvidia.com/deeplearning/frameworks/install-tf-jetson-platform/index.html

compatibility: https://docs.nvidia.com/deeplearning/frameworks/install-tf-jetson-platform-release-notes/tf-jetson-rel.html#tf-jetson-rel

Since the TensorFlow is not present for JetPack 4.4 DP, I returned to reinstall JetPack 4.3 with the automatic installation. However, VisionWorks on Host under Computer Vision has an error with the prefix exclamation .

It shows Download 100.7 MB but install Size is 233.0 MB. Even though I completely deleted the sdkm_downloads files under Home/Downloads/nvidia directory and restarted the installation again, it still incurred the same error. It is a recursive error. So I have not way to complete the JetPack 4.3 installation. Please see the following errors reported in Terminal.

“”"
19:22:25 ERROR: VisionWorks on Host: E: Version ‘1.6.0.500n*’ for ‘libvisionworks’ was not found.

19:22:25 ERROR: VisionWorks on Host: [Error]: Error when apt install failed; [exec_command]: sudo apt-get update; sleep 0.5; sudo apt-get -y install libvisionworks=1.6.0.500n* libvisionworks-dev=1.6.0.500n* libvisionworks-samples=1.6.0.500n*; [error]: exit status 100; [deb_path]: home/mike/Downloads/nvidia/sdkm_downloads/libvisionworks-repo_1.6.0.500n_amd64.deb

1922:25 ERROR: VisionWorks on Host: command terminated with error

19:22:25 ERROR: VisionWorks on Host: Install ‘VisionWorks on Host’ failure, command <using adapter to install NV_VISIONWORKS_HOST_COMP@host to /home/mike/nvidia/nvidia_sdk/JetPack_4.3_Linux> terminated with error.
“”"

It did not work after repairing and remove the old host installation from the SDK Manager. While I tried to remove the sdkmanager_1.1.0-6343_amd64.deb and install sdkmanager_1.0.1-5538_amd64.deb. The system poped up the following reminding information.

“”"
A newer version of SDK Manager database was detected on your host machine. This database is not supported by the SDK Manager version you are running.

Continue and SDK Manager will backup the database on your hard drive and will create a new one instead.
“”"

I could not delete the database (sdkmanager_1.1.0-6343 created) since I did not find where the database is located. I installed sdkmanager_1.1.0-6343 with Ubuntu Software. So I could not use the old version SDK manager(sdkmanager_1.0.1-5538) to install JetPack 4.3.

It took me about 3 hours for a single installation but fails each time. So it is a quite time-consuming process. How to deal with the JetPack installation problem?

Best regards,

Mike