JetPack 4.3 - L4T R32.3.1 released

We are pleased to announce JetPack 4.3 supporting Jetson AGX Xavier series, Jetson TX2 series, Jetson TX1, and Jetson Nano.

JetPack 4.3 key features include new versions of TensorRT and cuDNN, Docker support for CSI cameras, Xavier DLA, and Video Encoder from within containers, and a new Debian package server put in place to host all NVIDIA JetPack-L4T components for installation and future JetPack OTA updates.

Please refer to the JetPack Release Notes and L4T Release Notes for additional info.

JetPack 4.3 Highlights:

  • Support for TensorRT 6.0.1 and cuDNN 7.6.3
  • Full support for DLA INT8 on Jetson AGX Xavier
  • Support for installation of JetPack components via Debian package archives
    • JetPack components are provided as Debian packages via a public APT server hosted by NVIDIA, enabling easier upgrades of JetPack components to future versions. Previous versions of JetPack need to be re-flashed to JetPack 4.3, after which the APT server can be used.
  • Support for CSI, DLA, and Video Encoder from within containers
    • On all Jetson products: Camera Serial Interface (CSI) and NVENC are now supported from within containers.
    • On Jetson AGX Xavier series only: NVIDIA Deep Learning Accelerator (DLA) engines are now supported from within containers.
  • Support for DeepStream 4.0.2
  • Support for ISAAC SDK version 2019.3
  • New easy to use Jetson-IO tool to configure 40-pin header on Jetson developer kits
  • Developer preview of VPI (Vision Programing Interface), a software library that provides Computer Vision and Image Processing algorithms implemented on Xavier Vision Accelerator, GPU and CPU.
    • GPU and CPU implementations are not optimized for performance in this preview release of VPI. A future release will bring performance optimized GPU and CPU implementations

JetPack 4.3 components:

  • L4T R32.3.1 (K4.9)
  • Ubuntu 18.04 LTS aarch64
  • CUDA 10.0
  • cuDNN 7.6.3
  • TensorRT 6.0.1
  • VisionWorks 1.6
  • OpenCV 4.1
  • Nsight Systems 2019.6
  • Nsight Graphics 2019.5
  • Nsight Compute 2019.3
  • SDK Manager 1.0.0

Download JetPack…
JetPack Release Notes…
L4T Release Notes…

What’s the status of DMA support of “ethernet over PCIe”?

In, vidyas said that “DMA support would be available in next release.”

In, Manikanta said that it will be included in Jetpack 4.3.

So I want to know whether DMA is supported for “ethernet over PCIe” in this release.


I’m completely stoked, because of all of the really cool stuff in this Jetpack, however my installation is being blown out of the water by what appears to be a ridiculously simple bug fix that is keeping me from developing code:

02:36:16 ERROR : Drivers for Jetson AGX : E: Failed to fetch 404 Not Found [IP: 2001:67c:1562::19 80]

This bug repeats itself about 4 or 5 times.

When I put this path in Firefox this is what I get:

[PARENTDIR] Parent Directory -
[DIR] binary-amd64/ 2018-04-26 23:37 -
[DIR] binary-i386/ 2018-04-26 23:37 -
[DIR] debian-installer/ 2017-10-24 22:44 -
[DIR] dep11/ 2018-04-26 22:28 -
[DIR] dist-upgrader-all/ 2018-04-18 15:03 -
[DIR] i18n/ 2018-04-26 23:37 -
[DIR] installer-amd64/ 2018-05-01 23:25 -
[DIR] installer-i386/ 2018-05-01 23:25 -
[DIR] signed/ 2018-04-26 05:33 -
[DIR] source/ 2018-04-26 23:37 -
[DIR] uefi/ 2019-04-18 23:19 -

Clearly the rest of the path doesn’t exist. If SDK Manager source code was available I could fix this myself, but I’m dependent on NVIDIA to fix it. Help! I’m like a Duck in the Water with only one fin spinning in a circle!

How to install opencv 4 in docker container?

We are using this image:


I am trying to install JetPack 4.3 on Agx Xavier Using SDK Manager, Everything goes fine but the only problem is:

–| Computer Vision
-----| VPI

VPI fails with some errors the SDK manager shows below error message:

Error in local apt settings
SDK Manager received errors while using apt commands on your system.

Please check that the Ubuntu local apt repository is working well on your local system including dependencies of packages.

Review SDK Manager terminal for the specific error/s.

At first, I thought there must be some problem with my host linux installation. so i reflashed my host machine and the first thing i did is installed SDK manager.

One more thing that i would like to mention here is, SDK manager automatically installs OpenCV on the host machine that is probably a good thing but i doesn’t installs numpy which means i had to manually install numpy using pip to be able to import opencv in my python console, Hope that will be fixed in the future releases.

even after installing everything (nvidi drivers, cuda, numpy) i double checked to confirm that everything is in PATH.

  1. nvidia-smi
Fri Dec 27 12:11:16 2019       
| NVIDIA-SMI 435.21       Driver Version: 435.21       CUDA Version: 10.1     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  GeForce GTX 106...  Off  | 00000000:01:00.0  On |                  N/A |
|  0%   51C    P0    30W / 150W |    439MiB /  6075MiB |      1%      Default |
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|    0      1132      G   /usr/lib/xorg/Xorg                            18MiB |
|    0      1178      G   /usr/bin/gnome-shell                          48MiB |
|    0      1463      G   /usr/lib/xorg/Xorg                           153MiB |
|    0      1608      G   /usr/bin/gnome-shell                         111MiB |
|    0      2722      G   ...uest-channel-token=15541004593153953379   104MiB |
  1. nvcc -V
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2019 NVIDIA Corporation
Built on Mon_Mar_11_22:07:30_CDT_2019
Cuda compilation tools, release 10.0, V10.0.326

Both of these commands works fine, I re-started the host machine and went with the whole installation process for Xavier.
Still it shows the same error, i am unable to understand what i am missing.

Here is the link to SDK manager log files.

I am having a very similar problem.

I have installed JetPack 4.3.
How to upgrade TensorRT to 7.0 version ??

Hi jhx2002, upgraded TensorRT will be provided with the next JetPack update - please stay tuned.

I would also very much like to know the status of DMA performance. I believe DMA over PCIE has been very slow so far, and completely kills my use case for the product. It’s been about three weeks since this gentleman inquired, so would you kindly post a reply? Thanks.

I need to update TensorRT now, what can I do ?

Hi jhx2002, on Jetson the TensorRT can’t be updated independently of the JetPack version, as TensorRT has dependencies on the version of CUDA and L4T drivers included with JetPack. So it will only be possible to upgrade TensorRT when the next version of JetPack is released, sorry about that.

Tried to update to latest jetpack 4.3 and getting download failures due to wrong checksum. Using latest SDK Manager:

Hi emccullo, can you confirm this is for Jetson AGX Xavier? Also, can you tell from the logs (on the logs tab of SDK Manager), which file is failing to download correctly?

Thanks Dusty_nv for the quick response
Yes, this is for the Jetson AGX Xavier.
I’m getting multiple files that are failing the checksum. Here’s a few examples
2020-01-27 11:52:52.823 - error: file downloaded with wrong checksum.
outputPath: /home/X/Downloads/OpenCV-4.1.1-2-gd5a58aa75-aarch64-samples.deb
Actual checksum: d70c7fb4a7f06d27e2b952cf45bc7397.
Expected checksum: 5969fc1376ac31cbadfd42276e271ffd

2020-01-27 11:55:35.001 - error: file downloaded with wrong checksum.
outputPath: /home/X/Downloads/cuda-repo-ubuntu1804-10-0-local-10.0.326-410.108_1.0-1_amd64.deb
Actual checksum: 78700a84ef1f5b4655f9b3f5d443cedb.
Expected checksum: 0396239108d46ab682fb90468ea937b6

Anyone else having an issue with USB flash drives having issues with dismounting with Jetpack 4.3 installed?

They seem to be getting mounted twice.

I didn’t have this issue with Ubuntu on the Xavier prior to Jetpack 4.3

OK thanks, I am checking with the web team for their suggestions or if they see other cases like this currently. Typically if there is some kind of outage, we will get multiple reports about download issue, however your case is the first I’ve heard at this time (so far). In the meantime, if you clear the downloads and try again, does it still occur? Could you possibly try from a different connection as to eliminate the possibility of an issue there?

Hi emccullo, we have flushed the CDN cache overnight - can you try downloading again and see if you still have issues? Thanks.

Thanks dusty_nv, I tried it this morning with the same setup and it now works. Issue resolved.
Again, just want to thank you for the great support!

Will this make the SDK Manager obsolete for future releases and all updates can be installed by apt-get?

I am asking because I don’t have a genuine Linux machine at hand and have to run Ubuntu on VirtualBox on a MacOS host. Installing JetPack updates is a tedious and error prone scenario with this setup.

Once you have your Jetson setup initially (with JetPack 4.3 or newer), in theory you wouldn’t need SDK Manager for future upgrades. The Nano devkit you could just flash an SD card without using SDK Manager. However, that leaves the other Jetson devkits and production modules which would still need to be flashed an initial time upon receiving them new, so SDK Manager would still be used for those.