mmc_rx_fifo_overflow of ethernet

Dear Sir,

Environment : Jetpack 3.3
U-boot/Kernel : tegra-l4t-r28.2.1
Utility : pktgen 2.75(from kernel tegra-l4t-r28.2.1)

I’ve tried to validate the ethernet of Jetson TX2 with pktgen(bidirection)

LAN Mapping/Architecture

Xeon® CPU E3-1205 v6├─┤I350├────────┤nVIDIA Jetson TX2 │

pktgen’s configuration

dst mac of i350/TX2
packt size 1500
count 10000
delay 17500

smp_affinity keep default

irq 45 : 2490000.ether_qos.tx0, default is 1
irq 44 : 2490000.ether_qos.rx0, default is 1
irq 42 : ether_qos.common_irq,  default is 3f

After pktgen stop(send 10000 packets), I always check the ethernet’s receive status

ifconfig eth0 | grep "RX packets"

For the most part, the “RX packets” of Jetson TX2 is less than the “TX Packets” of Xeon/I350.
There is also add some count in the mmc_rx_fifo_overflow of eth0 of Jetson TX2.

ethtool eth0 | grep fifo

Is there any approach to improve it??

Best Regards,
MOMO Chen

Please try to use rel-28.3 or even rel-32.2.1 release to see if any improvement.

Dear WayneWWWW,

Sorry to reply late, I cost some time for setup the sdk-manager for build tegra-l4t-r32.2.1(rel-32.2.1) with pktgen.ko

Unfortunately, There seems no improvement for mmc_rx_fifo_overflow with rel-28.3/rel-32.2.1.
It is still increase during Jetson TX2 receive packet.

rel-28.3 setup by Jetpack-3.3 with JetPack-L4T-3.3-linux-x64_b39.run
rel-32.2.1 setup by JetPack_4.2.2_Linux_GA_P3310 with sdkmanager_0.9.14-4961_amd64.deb

Best Regards,
MOMO Chen

Got it. Thanks for testing.

Xeon® CPU E3-1205 v6├─┤I350├────────┤nVIDIA Jetson TX2 │

Does this mean you use the TX2 on-board ethernet to a host with Xeon CPU + i350 NIC?
Is there any router?

Dear WayneWWW,

No, there is no any router.
they are connect with each other directly.

Best Regards,
MOMO Chen

Are you using cross over cable?

Dear WayneWWW,

I just confirmed with our HW engineer.
In our product(carrier board) with Jetson TX2, it is connect to I350 directly that without cross.
In other side, we also validate the officer carrier board with Jetson TX2 with cross over cable.

Their result seems are same.

p.s by the way, our officer carrier board’s usb flash port is broken now, so that will be hold with JetPack_4.2.2_Linux_GA_P3310’s default Image

Best Regards,
MOMO Chen

Could you share the error log (dmesg) with us too?

Also, could we try this test with 2 TX2 devices? I mean 2 tx2 devices connected to each other directly and there would be no I350.

Dear WayneWWW,

I’ve tried to collect all information that you might need(in the attachment)
I’m use the ‘dmesg -c’ to collect kernel message(show and clear),
and there is no news after receive packets.

Since my sample will lend to other department till the tail of october.
So, these information is based on tegra-l4t-r28.2.1

About the 2 TX2 devices test. We couldn’t do that so far, because

  1. In our product, the Jetson TX2 is connect to I350 directly that in the same board.
  2. There is only one official board we got
    ※The official board is test with Xeon® CPU E3-1205 v6 and I350, too

Best Regards,
MOMO Chen
Jetson_tx2_20190927_1509.txt (70.7 KB)

Hi momo_chen,

Could you help do more comparison test? Since we don’t have I350 here, all I can do is deliver your log and consult with our internal engineer.

If you could confirm that even 2 TX2 can reproduce this issue, then we can investigate this issue more thoroughly.

Or you could try to connect I350 with x86 host and see if overflow is seen. It is to eliminate that I350 is not the one causing problem.