Modify boot order


I am using Jetson AGX Xavier based board, with L4T35.1 images flashed to emmc. I am trying to make emmc as the device with highest priority in the boot order because board tries to boot from sdcard when connected.

I tried steps mentioned in this link (UEFI Adaptation — Jetson Linux Developer Guide documentation). Added ‘gNVIDIATokenSpaceGuid’ node and mentioned boot order as follows,

gNVIDIATokenSpaceGuid {

                  DefaultBootPriority {
                                      data = "emmc,usb,nvme,sd,ufs";

Updated LinuxforTegra/kernel/dtb/L4TConfiguration.dtbo. Flashed board with above changes.
But i can observe the board still tries to boot from sdcard and not the emmc. Also if i go to the boot options menu, SDcard has higher priority than emmc.

What am i missing?

Ashik P.


then, will it work if you override the default order when flashing?

No @DaveYYY. Still SDCard has the highest priority.
Built the uefi from sources and picked BootOrderEmmc_Jetson_DEBUG.dtbo and copied to LinuxForTegra and LinuxforTegra/kernel/dtb

Used command sudo ADDITIONAL_DTB_OVERLAY="BootOrderEmmc_Jetson_DEBUG.dtbo" ./ jetson-agx-xavier-devkit mmcblk0p


can you first try upgrading to L4T 35.3.1 and see if it helps?
We’ll check it this still happens on the latest version.

Its working on 35.3.1.

But i would like to get it fixed on 35.1.


if you want to stick with 35.1, then you may update only the UEFI binary instead of the entire L4T version.
You can compile the latest version of UEFI source code provided here:

Replace uefi_jetson.bin inside Linux_for_Tegra/bootloader/ with the one you just generate, and flash either with

sudo ./ -k A_cpu-bootloader jetson-agx-xavier-devkit mmcblk0p1
(Only re-flash the bootloader partition)

, or with

sudo ./ jetson-agx-xavier-devkit mmcblk0p1
(Complete re-flash)

Will check this out.

Thanks @DaveYYY

Hi @DaveYYY
Tried the method you mentioned, but this error msg shows up during every boot.
Failed to validate rootfs status: Not Found


are you still able to login to the system?
Please attach the full boot log here.

Also, did you do a whole re-flash, or only updated the bootloader partition?
Is it our official rootfs that is in use?

I am using custom rootfs

Board is booting from emmc and the previous issue with sd card is not seen .
Also if i check the boot order, emmc is on the top.

But the mentioned error was coming. Wanted to make sure that doesnt cause any issues.


Then I think that’s the cause, and if it doesn’t ruin the booting process, and prevent you from logging in, it should be fine.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.