MPICH2 corrupt or old module file error

I’m using MPICH2 1.3r-c2 in my FORTRAN code. I’m running this code in Windows environment currently.

When I was using Intel Visual Fortran, the code worked fine. But when I moved to PGI Visual Fortran to use OpenACC, following 4 MPICH2 modules give errors during compilation.

mpi.mod
mpi_base.mod
mpi_constants.mod
mpi_sizeof.mod

This code must be portable; that is, the code should run in Linux environment also. So using Microsoft MPI is not a good idea.

It seems that there is no way to solve this problem by myself.

It would be really thankful if PGI provide me with MPICH2 packages that are for PGI compilers. It would be the best if the version also matches, but version doesn’t really matter, I guess.[/u]

Hi CNJ,

Fortran compilers each have their own format for module files. Since these were compiled by the Intel compiler, they can not be used by PGI.

You’ll want to rebuild your MPICH2 installation using PGI to obtain correct module files but also then you wont need to link against the Intel Fortran runtime libraries which the current library would have dependencies.

  • Mat

Hi Mat,

Thank you for the reply.

I understand that I have to rebuild MPICH2 with PGI compiler.

The problem is that I don’t know how to do it.

I just installed MPICH2 using an installer.

The installer has been downloaded from the following link:

http://www.mpich.org/static/downloads/1.3rc2/

Hi CNJ,

In looking over MPICH’s web page I see that they no longer support Windows and recommend users use MS-MPI.
https://wiki.mpich.org/mpich/index.php/Frequently_Asked_Questions#Q:_Why_can.27t_I_build_MPICH_on_Windows_anymore.3F

I tried building from source, but it looks like the configure script is fairly Linux centric even when invoked within Cygwin. You might be able to hack the script but I’m not sure.

Sorry,
Mat

That’s sad.

I should try porting to MS-MPI then.

I appreciate your help, Mat.

Have a nice day.