Mt7610u problem

Hi! Is Xavier nx support mt7610u? I have a USB WiFi Adapter(asus ac51) which use mt7610u. And I want to use in Xavier nx, but when I plug in the network seems not recongnize it. The fellowing picture is the detail info

As the picture show,s we can know the usb has recongnize it and the kernel also has the fireware which call mt7610u.bin. So we can conclude that the system doesn’t up the firmware? How can I load the firmware and make my USB WiFi Adapter work.

Do you know what is the driver name of Mt7610u? Need to check if kernel includes it or not.

I don’t know which driver it is, but when I plug in my computer where ubuntu 20.04 installed and after I run dmesg | grep mt I get the fellowing info

And I find some info about mt7610u’s driver in this site: MediaTek 802.11ac USB Wi-Fi Linux Driver Installation - Kuan-Yi Li's Blog it seems the kernel already include it after 4.19

The kernel on jetson is still 4.9. Please check /lib/modules and search mt76* and see if any file with this name.

After I run this command but get nothing

Is there any way to upgrade nx’s version?

The search command is wrong. Please use find instead of grep.

nvidia@nvidia-desktop:/lib/modules$ sudo find -iname “mt*”
[sudo] password for nvidia:

I can see there is mt7601u driver here but not sure if this is compatible with your case. If the driver is missing, please try to contact the vendor and see if they can provide a driver on k4.9.

I type this command in my computer there is nothing shows and the seem as xavier

Then maybe the question is where did your driver package come from? Is it from the pure jetpack? Or you prepared it by yourself?

Yes our system is from jetpack(4.4)

and the main modify about it is opencv version.

What does your /lib/modules look like?

this is my /lib/modules

And do you have a mediatek driver folder in the 4.9.140-tegra?


I find folder mediatek but there is no mt7610u

Ok, probably not exist on jp4.4. Sorry that all the devices I have now are on jp4.5.1, so cannot check that for you.

Anyway, please contact with the vendor for the driver code and see if it can build/run on k4.9.

ok, I will contact them and thank you for your help