Nano CSI camera not released in Jupyter notebook, "Hello Camera" app

I’ve used Jetson Nano in past with OpenCV for a two USB camera project which works using filters, ROIs, etc…
Now I want to go through Nvidia AI and Deep Learning course. I am using RPi v2 camera and it works with Nano. I have Jupyter notebook running over SSH from my camera, and can run the Hello Camera app once, but then if I try to run notebook again (with same parameters) it gives me “Could not initialize camera.” I suspect it is not releasing the camera, even though I run the unobserve command.
I also have a monitor/keyboard hooked up to the Nano, and can run Gstreamer to view the camera using:
gst-launch-1.0 nvarguscamerasrc | noverlaysink

and it will display, then when ^C out it releases and is able to restart.
Am I missing something with the way the notebook operates? Or is there a Jetcam command which releases the camera stream?

Hi @rplpozl, please see this post for the way to restart the nvargus-daemon on the host:

We are currently working to integrate a fix into the container - sorry about that!

Hi @dusty_nv,
Thanks for the quick response. I looked at the other post; I’m pretty sure I had already tried the “sudo systemctl restart nvargus-daemon” from the keyboard connected to the Nano, that does’t seem to work.
However, the other thing mentioned in the post led me to a solution. Under the cell which contains:
camera.unobserve(update_image, names=‘value’)
I inserted a new cell which contains:
camera.running = False

and this solves the problem. The release command releases the camera; the running=False is necessary to prevent an error.
You might want to include that in the notebook.