No CUDA events collected

“No CUDA events collected. Does the process use CUDA?”
is in my diagnostic summary after a trace.No CUDA API calls show up in the timeline.

I used to get CUDA events collected until I made some changes to my application that involved mostly converting a bunch of memCpys to async on dedicated streams.

Driver Version: 471.41
NSight: 2021.2.4.12-a25c8fd

I followed the steps here to geenrate a log but none appeared, at least not that I could find.

Also, is there a place to read up on what the blocked state wait reasons mean? Or get more detail on them from the profiler?

Can you tell me a little more about how you are using the tool? Can I get the options you were using (or the command line)?

I’m using NSight System GUI, with the following options:
*Sample Target Process w/ call stacks
*Collect CPU Context Switch Trace
*Collect CUDA Trace
*Collect GPU Metrics
*Collect WDDM Trace

I’m just starting the application, pointing it at my executable and starting a profile from the GUI.


Hi aven_omega, do you get CUDA traces when you profile any other CUDA app (for example, the CUDA toolkit sample application vectorAdd)? Also, on which OS are you trying to profile? Would it be possible for you to share the report file?

Windows 10.
I tried to profile vectorAdd and simple assert, but now every time the profiler gets to around 95% complete, NSight systems crashes and stops responding. Every time I try to open one of my old reports, the same crash happens.

Here is the report from my own application. I tried turning on logs following this but I don’t see any log files being created.
Report 13.qdrep (29.7 MB)

Report 14.qdrep (29.8 MB)
This should be one of the vectorAdds, as I can’t seem to view reports right now at all. I’ll try reinstalling NSight later.