No devices found


Going quite crazy here. No matter what I do, I always get No devices were found when running the nvidia-smi command.

  • I’m running Ubuntu 20.04 Server.
  • Secure boot is disabled in BIOS (I am using CSM) and BIOS is upgraded fully.
  • I am not using nomodeset.
  • I am using options nvidia-drm modeset=1, otherwise booting hangs with the “blinking cursor”.
  • I’ve been having horrible tearing (screen full of horizontal pink/green lines on the screen… even when simply trying to install Ubuntu (hence I switched to Ubuntu Server).
  • To even be able to install, I have to have nomodeset as a kernel parameter.
  • My hardware is Titan RTX, Asus Prime-X570-Pro motherboard, and AMD Ryzen 9 3950X
  • I initially followed the instructions here: Installation Guide Linux :: CUDA Toolkit Documentation and tried all sorts of combinations (eg. w/ and w/o secure boot, old drivers (455), new drivers (460), using ubuntu-drivers autoinstall)
  • The remotely closest thing that has worked is by following: How do I install NVIDIA and CUDA drivers into Ubuntu? - Ask Ubuntu
  • At this point, the screen displays (at very low resolution) but again I cannot get past the No devices were found when running the nvidia-smi command.
  • I’ve attached the output of nvidia-bug-report.log.gz (165.7 KB)

Any help would be appreciated!! Thanks in advance! I’ve spent 5 full days just trying to get this even set up.

You’re getting

[    2.021552] NVRM: GPU 0000:08:00.0: RmInitAdapter failed! (0x26:0xffff:1290)
[    2.025685] NVRM: GPU 0000:08:00.0: rm_init_adapter failed, device minor number 0

which points to a hardware issue. Please try reseating the card in its slot, reseat power connectors, check if the card works in another machine.

I’ve tried reseating. No luck. Tried Fedora as well. I don’t have another computer to try it in at the moment.

Is there anyway to send in to NVIDIA to have it tested? I’m within 1 year of warranty.

You’ll need to get in touch with nvidia support to get an RMA.