No display with Quadro M2000M/Optimus and Ubuntu 14.04

I have been trying to get my ThinkPad P50 with an M2000M/intel hybrid and 4k display to work with Ubuntu 14.04 but have not had any luck. The M2000M appears to be supported from 352.63 so I have tried the ubuntu 352 package, and also the 355 and 361 packages from ppa:graphics-drivers/ppa.

In all cases running with “prime-select intel” works ok, but when I change to nvidia and reboot I get a black screen. I am sometimes able to get a vt up to be able to change back to intel, and have also used this to run the nvidia bug report script (output attached).

From the Xorg log I don’t actually have any errors, it seems as though perhaps the card can’t find any monitors?

I had previously tried to use bumblebee, I have uninstalled (purged) all the packages, but I thought I would mention that in case it is relevant.

Has this setup actually been tested (hybrid M2000M)? If anyone could guide me to configure it under ubuntu it would be really great!


Is this ever going to stop saying “[SCANNING… PLEASE WAIT]”? How long does it take to virus scan scan a text file in a known format?

Also, I see a lot of unanswered posts on this forum. It feels like no one is going to offer any support here. There doesn’t seem to be any other route for support either.

I have a Thinkpad P70 and have had a similar issue with it’s Quadro M3000M.

I have been able to get it to boot with the proprietary driver by disabling hybrid graphics and CSM support in the bios, setting the boot display device to be “Displayport”, then booting with a display plugged into the displayport on the side of the laptop. Without an external display plugged in the machine kernel panics when X is started.

Once it is booted both the internal and external display can be used, but it had issues re-detecting display if the configuration changes.

It seems that the P50 is certified for RHEL 7.2, so you might sign up for a trial and give it a try if you do not mind switching distributions. They might have some specific fixes to overcome these issues (or their support may be able to help). I am considering doing this myself just to see if it is a smoother experience until the hardware is more supported by Ubuntu and Debian.

Ok, I just managed to get this to work with bumblebee. I currently have two different PPAs for this so I’m not sure exactly where all the packages I’m using came from. My PPAs are:


I installed:
nvidia-352-updates bumblebee bumblebee-nvidia primus linux-headers-generic bbswitch-dkms

Then edited /etc/bumblebee/bumblebee.conf so that:


Make sure /etc/bumblebee/xorg.conf.nvidia has

Option “UseDisplayDevice” “none”

(can’t remember if I edited that).

Then reboot and run “optirun glxgears -info” and confirm it’s using the Nvidia driver. Hopefully all the steps are here! I’m going to test changing “TurnCardOffAtExit=false” to true in the bumblebee conf now, as leaving the card on seems like a bad idea. Thanks fleaplus for your help.

EDIT: Ok it works with “TurnCardOffAtExit=true” (whether it is really turning the card off I’m not sure). Also, I changed to “PMMethod=auto” and it’s still ok.

I followed your steps, and it seemed to work (glxgears used nvidia), but the intel driver was not setup properly. I couldnt change DPI, so everything was very tiny.

I then tried to reinstall the intel driver and somehow messep up xserver.

After reinstalling xserver I’m stuck with a login loop, no matter what drivers are installed (tried nvidia-352-updates with and wihtout bumblebee).

Any suggestions?

Edit: I deleted .Xauthority and now I’m able to login again. Trying to get bumblebee working now and will report

I can get bumblebee to work, but the Intel graphics driver is still not working properly.

The dpi scaling has actually no effent and I have a black bar on the bottom of the screen.

Any ideas how to fix this?

I switched back to discrete nvidia graphics for now.

I haven’t had the issue with the black bar. WRT DPI scaling, I didn’t think this was a feature of the X server? I have switched from XFCE to cinnamon as cinnamon does scale the UI. I wonder if you have some extra (incompatible) packages installed? Are you on a P50?

I have not been able to get discrete graphics to work on its own, which I’d like to do as there is a performance hit with bumblebee (as it renders off screen and then has to copy into whichever window). But I didn’t want to uninstall a working setup, so perhaps that isn’t possible with bumblebee installed. It would be nice to be able to switch between bumblebee and discrete only.

I also cannot get external monitors working, but I have not tried terribly hard yet.

I get occasional crashes of the X server, in I think but there are several threads running so I’m not certain (I didn’t look into it in depth yet).

Interesting that my nvidia bug report from my first post is STILL virus scanning. Don’t think nvdia actually offer any support in this forum…

Yes, I’m on a P50. I’m gonna try again to get the intel graphics to work and will report.
Maybe we should try to use Nvidia prime instead of bumblebee.

Here is what I did to get discrete nvidia to work:

sudo apt-get remove --purge nvidia-* bumblebee bumblebee-nvidia primus bbswitch-dkms

sudo apt-get install nvidia-352-updates

reboot into BIOS and select discrete graphics

So I upgraded to ubuntu 16.04, and now am just using nvidia with prime. I just followed your purge instructions, and installed nvidia-370 and nvidia-prime. All is working as advertised, though I note performance with the built in LCD is not as good as it could be as you’re still copying to the integrated graphics framebuffer somewhere.