problem with Quadro P1000

I have trouble activating the proprietary nvidia driver for a Quadro P1000 on a DELL Precision Notebook running on debian stretch 9.7.

Kernel is from backports: 4.19.0-0.bpo.1-amd64

nvidia-driver is also from backports: nvidia-driver (390.87-6~bpo9+1).

additional installed packages are

bumblebee (3.2.1-14).
primus (0~20150328-4).
bumblebee-nvidia (3.2.1-14).

nvidia-detect runs fine and recommends to install the driver for my graphics card:

▶ nvidia-detect
Detected NVIDIA GPUs:
01:00.0 3D controller [0302]: NVIDIA Corporation Device [10de:1cbb] (rev ff)

Checking card: NVIDIA Corporation Device 1cbb (rev ff)
Your card is only supported by the updated drivers from stretch-backports.
See https://backports.debian.org for instructions how to use backports.
It is recommended to install the
nvidia-driver/stretch-backports
package.

If I run nvidia-xconfig, a basic xorg.conf is created: https://pastebin.com/xQXne2kQ

but it will not boot into graphical interface and stops before gdm opens. ttys are accessible but other than deleting the xorg.conf I don’t know what to do or where to look for the nvidia error messages.

Current dmesg shows a lot of ACPI related warn messages: https://pastebin.com/uhwk8pbq

I have also attached a /var/log/syslog: https://pastebin.com/m57355j5
nvidia-bug-report.log.gz (47.5 KB)

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

I am not sure if the attached bugreport suffices because I am running on my Intel graphics card right now:

sudo lshw -c video
  *-display                 
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:156 memory:eb000000-ebffffff memory:80000000-8fffffff ioport:4000(size=64) memory:c0000-dffff

It’s an Optimus system so you can’t use nvidia-xconfig to create an xorg.conf, leads to a non-working system. You installed Bumblebee which enables on-demand use of the nvidia gpu by running
primusrun
or
optirun
Otherwise, the intel gpu is used for the desktop and the nvidia gpu is turned off.

Thank you for the answer. I know that it is an optimus system. I have run it as stand-alone nvidia and using bumblebee. The Problem is that the nvidia driver can not be activated. Neither in bumblebee nor in standalone. The only usable scenario right now is with intel graphics.

Here is the output of the primus commands:

$ optirun glxgears
[121617.827539] [ERROR]Cannot access secondary GPU - error: Could not enable discrete graphics card

[121617.827606] [ERROR]Aborting because fallback start is disabled.

$ primusrun glxgears
/usr/bin/primusrun: line 41: warning: command substitution: ignored null byte in input
primus: fatal: Bumblebee daemon reported: error: Could not enable discrete graphics card

Please run dmesg >dmesg.txt after you used optirun and attach.

[145029.454810] bbswitch: enabling discrete graphics
[145029.454825] pci 0000:01:00.0: Refused to change power state, currently in D3

Please try kernel parameters
acpi_osi=! acpi_osi=“Windows 2009”

That did not help. I think the corresponding section in dmesg is follwed by a BIOS Error (bug):

[    0.292861] ACPI: Disabled all _OSI OS vendors
[    0.292861] ACPI: Added _OSI(Module Device)
[    0.292861] ACPI: Added _OSI(Processor Device)
[    0.292861] ACPI: Added _OSI(3.0 _SCP Extensions)
[    0.292861] ACPI: Added _OSI(Processor Aggregator Device)
[    0.292861] ACPI: Added _OSI(Linux-Dell-Video)
[    0.292861] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[    0.292861] ACPI: Added _OSI(Windows 2009)
[    0.329271] ACPI BIOS Error (bug): Failure creating [\_SB.PCI0.XHC.RHUB.HS01._UPC], AE_ALREADY_EXISTS (20180810/dswload2-316)

There are also other errors in dmesg. Should I report upstream to DELL? - They advertise linux compatibility of the Precision 5530.
dmesg.log (98.3 KB)

I am having the EXACT SAME issue. I’m running MX Linux with KDE, on a Dell Precision laptop. I was also trying to enable my nvidia driver, used nvidia-xconfig to generate etc/X11/xorg.conf, and now my desktop won’t load. I would love to find a solution for this.

ukso-nvidia, this looks like this acpi/pci bug:
https://bugzilla.kernel.org/show_bug.cgi?id=156341
meaning, once the dgpu is turned off, you can’t turn it on again.
I think you can keep bumblebee from turning the nvidia gpu off by using

KeepUnusedXServer=true

in bumblebee config or blacklisting/uninstalling bbswitch. Of course this leads to higher power consumption.
Nevertheless, suspend/resume won’t work on this machine, at least your dgpu will be dead again.
This should be reported to Dell.

Burlyswan, you have the wrong config, you can’t use nvidia-xconfig on a hybrid (Optimus) system.
You’ll either have to use PRIME (https://devtalk.nvidia.com/default/topic/1022670/linux/official-driver-384-59-with-geforce-1050m-doesn-t-work-on-opensuse-tumbleweed-kde/post/5203910/#5203910) or bumblebee. Please open a new thread for this.

current setup (as recommended) does not change anything:

$ cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-4.19.0-0.bpo.2-amd64 root=/dev/mapper/debian--vg-system ro acpi_osi=! "acpi_osi=Windows 2009" nosplash
$ cat /etc/bumblebee/bumblebee.conf|grep KeepUnusedXServer
KeepUnusedXServer=true

There are a few reported bugs for the DELL laptop series which point to a firmware bug:

  • https://bugzilla.kernel.org/show_bug.cgi?id=109511
  • https://bugzilla.redhat.com/show_bug.cgi?id=1610727

I should probably first get rid of these firmware bug messages before continuing with nvidia setup.

[    0.284207] ACPI: Added _OSI(Windows 2009)
[    0.320235] ACPI BIOS Error (bug): Failure creating [\_SB.PCI0.XHC.RHUB.HS01._UPC], AE_ALREADY_EXISTS (20180810/dswload2-316)
[    0.320240] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20180810/psobject-221)

Maybe just uninstall bumblebee and bbswitch and revert to a PRIME output config:
https://devtalk.nvidia.com/default/topic/1022670/linux/official-driver-384-59-with-geforce-1050m-doesn-t-work-on-opensuse-tumbleweed-kde/post/5203910/#5203910

Last week’s (27 Feb 2019) firmware update (Dell Precision 5530 1.8.1 System BIOS) solves the ACPI BIOS Errors. I will try your solution with prime output config next.

I have recently upgraded to debian buster. The dmesg is now outputting a proper error. I currently have no additional active /proc/cmdline but I will try with the Window 2009 solution.

[   44.995623] nvidia-nvlink: Nvlink Core is being initialized, major device number 239
[   45.047689] NVRM: This is a 64-bit BAR mapped above 4GB by the system
               NVRM: BIOS or the Linux kernel, but the PCI bridge
               NVRM: immediately upstream of this GPU does not define
               NVRM: a matching prefetchable memory window.
[   45.047691] NVRM: This may be due to a known Linux kernel bug.  Please
               NVRM: see the README section on 64-bit BARs for additional
               NVRM: information.
[   45.047697] nvidia: probe of 0000:01:00.0 failed with error -1

I am also posting at DELL:

https://www.dell.com/community/Precision-Mobile-Workstations/Dell-Precision-no-nvidia-graphics/m-p/7305077#M1828

Now you’re running into a whole different issue.
Please attach a dmesg output.

error remains with following kernel load:

▶ cat /proc/cmdline                                        
BOOT_IMAGE=/vmlinuz-4.19.0-5-amd64 root=/dev/mapper/debian--vg-system ro acpi_osi=! "acpi_osi=Windows 2009" quiet splash

I removed the kernel options as nvidia is still not loaded:

▶ lsmod | grep nvidia
 
▶

I will attach bugreport and kernel log to this post.

nvidia-bug-report.log.gz (117 KB)
kern.log (139 KB)

The error message is misleading. What’s happening is:

  1. bbswitch is loading, turning off the nvidia gpu
  2. nvidia driver is loading, trying to init the gpu which is off, so fails and unloads.
    Since you’re trying to use bumblebee, the nvidia driver should be blacklisted and only load when bumblebee starts up, turning on the dGPU. Something is broken with your bumblebe setup.

Good to hear that there is no actual “error” anymore but optirun still is not work

So I tried

▶ sudo tee /proc/acpi/bbswitch <<<ON 
ON

~                                                                                            
▶ sudo dmesg |tail -2               
[  880.868429] bbswitch: enabling discrete graphics
[  880.868460] pci 0000:01:00.0: Refused to change power state, currently in D3

which is the same reason for optirun to fail:

~                                                                                           ⍉
▶ sudo optirun glxgears -info
[ 1033.754918] [ERROR]Cannot access secondary GPU - error: Could not enable discrete graphics card

[ 1033.754966] [ERROR]Aborting because fallback start is disabled.

~                                                                                           ⍉
▶ sudo dmesg |tail -2        
[ 1033.751425] bbswitch: enabling discrete graphics
[ 1033.751453] pci 0000:01:00.0: Refused to change power state, currently in D3

How can I get the card to wake up?