No HDMI output after installing Jetpack 4.4 DP

Good afternoon.

I downloaded Jetpack 4.4 DP today. Installed on ubuntu 18.04 host system, downloaded all installers. Flashed the device, everything goes through ok. Then after flashing i reset the Xavier NX module (on an auvidea JN30 carrier board, mfr assures me this should work up to 15W). But unfortunately after reset, there is no signal on HDMI output. Power lights are on and MCU light is flashing 1 sec on 1 sec off.

I repeated the whole process with SDK Manager again and the same thing happened, no HDMI output.

I tried running the flash.sh script from the command line to monitor for errors and everything seems to go through ok, this is my command:

sudo ./flash.sh jetson-xavier-nx-devkit-emmc mmcblk0p1

on execution completion I get :

*** the target t186ref has been flashed successfully ***
Reset the board to boot from internal eMMC

Everything seems to through ok with the flashing process. Just no HDMI on reset…

Any ideas?

About this:

…did the carrier board manufacturer provide a board support package compatible with this release? I’m wondering if the quoted comment was directed only towards the 15W spec, or if this also applied to any board support package? If the BSP was missing or or not compatible this might account for it.

Thanks for the thought, but the carrier MFR does not provide a BSP for the carrier I’m using as it is supposed to be a direct swap out for the Nvidia Nano Dev Kit.

I’m trying to use the JN30A and I’m looking here - https://auvidea.eu/firmware/

Note: JN30A (Nano dev kit version) works with the default developer kit image provided by Nvidia. Please flash this image onto an SD card and plug this into the compute module.

I tried the BSP that is available for the JN30B just incase that worked, but I got the same result. no HDMI output after flashing. I ordered a JN30B board to try that, maybe that will work!

Correct me if I am wrong, but I assume from you said (without having researched to verify) that the JN30A refers to the equivalent carrier for the a02 revision (SD card version of Nano, with no NX module matching this), and the JN30B (eMMC version, which the NX module would be interchangeable with) corresponds to the equivalent carrier for the b01 revision.

Maybe someone else can verify, but it sounds like your NX module must be used with the JN30B using the B revision software. If there is still no HDMI output, and the flash looked successful, then the system may in fact already be running, but have a video issue. The best way to answer this is if you have a serial console log from boot.

Also, is your monitor purely HDMI without any adapters?

OK Yes, I have reached the same conclusion. I ordered a JN30B board to confirm, should arrive today. So I will confirm if it works soon.

I can confirm that I now have the Xavier NX working nicely with the auvidea JN30B board and Jetpack 4.4. So it seems the problem was the JN30A board is not compatible.

Thanks and best wishes