Jetson TX2 & Auvidea carrier board J140 no HDMI output


I flashed TX2 with jetpack 4.2 SDK, but I stuck at point when SDK prompt me to type IP address, login name and password. At this moment I should type it directly on TX2, but there isn´t any output from HDMI.

I also tried patch Auvidea kernel. Therefore I run jetpack SDK and after it flashed TX2 (still no HDMI output) I close jetpack SDK. As instructed I copy Auvidea files to Linux_for_Tegra and run Then I repeat jetpack SDK installation. Everything flashed OK, but HDMI still not working.

Could someone help me?
Thank you.

If you have HDMI connected during the flash, then as flash completes the Jetson will reboot and you’ll be given an opportunity to set up a login account. Alternatively, you can use serial console for this (see

The Auvidea changes simply go in to the flash software prior to the flash. This will change to adapt to different wiring, but the need to create an initial admin account on first boot remains the same regardless of which carrier board you use.

Typically, once the Jetson has completed boot, this is when you must do the account creation in order to access the IP address (ssh to a working address will still fail if there is no account to talk to). Your booted Jetson, along with the micro-B USB cable, should create a virtual wired ethernet device. Your host PC will see this device and it will be assigned an address. The PC could “ping” to verify the virtual wired ethernet is working. Then you could “ssh some_name_you_created@” to verify ssh works. At this point you will know the name/address (“some_name_you_created” and “”) can be used with JetPack/SDK Manager.

You will find some differences if the monitor is not connected during the flash. You will also find that many adapters for HDMI (for monitors which are not actually HDMI) fail. Is this an actual HDMI monitor? Is the monitor attached during the flash?

Yesterday I borrow original TX2 dev board where HDMI working. I completed installation on that board, but after change board to Auvidea J140, HDMI still not working.

Board has mini HDMI connector, so I use converter mini HDMI to HDMI and HDMI cable to HDMI monitor. Next, I try HDMI to DVI cable, with different monitor, but problem is still not solved. Yes, I have connected HDMI during flashing, also I tried restart board and unplug and plug back HDMI.
Thru SSH I looked to dmesg and I found that problem:

[ 0.895285] tegradc 15210000.nvdisplay: vblank syncpt # 8 for dc 1
[ 0.895304] tegradc 15210000.nvdisplay: vpulse3 syncpt # 9 for dc 1
[ 0.896120] tegradc 15210000.nvdisplay: dc_hdmi_hotplug_init: couldn’t get regulator vdd_hdmi_5v0, -517
[ 0.902477] tegradc 15210000.nvdisplay: hdmi: invalid prod list prod_list_hdmi_board
[ 0.902503] tegradc 15210000.nvdisplay: hdmi: tegra_hdmi_tmds_range_read(bd) failed

Thanks for your help.

The board support package included in the default flash software is for the development kit carrier board (mainly this is the device tree). This includes information for drivers to find the hardware when multiple pin configurations can be used, e.g., to find the HDMI. If your module works on the development carrier board, then it would be expected for some parts/functions of the module no longer work on a different carrier board.

Basically, that flash software needs to have the Auvidea BSP added to the flash software before flashing. I am thinking that whatever Auvidea files you added may have been lost if you were flashing via JetPack/SDK Manager (JetPack/SDKM downloads various files for you…command line does not download for you…running JetPack/SDKM in any mode other than command line again can overwrite your Auvidea BSP changes).

It is still possible that there are other issues with HDMI even if the Auvidea files were in place, but are you certain that the correct Auvidea BSP release was used with the correct L4T/JetPack/SDKM release?

Thanks for your help. Finally, I was find solution. Problem was caused by HDMI convertor. I used different one, and HDMI output is now working.