Jetson TX2 problem with HDMI DISPLAY

Hi,
I know there was a lot of similar topics, but I couldn’t find a solution for my problem.
When I powered up a fresh bought Jetson TX2 with developers kit there was no signal at HDMI. I ignored that and started flashing tegra with JetPack 3.2 from host ubuntu machine. Flashing completed successfuly, but there still was no signal from HDMI cable connected to developers kit. I have checked different cable and different displays but with no effect. Im have connected to Jetson via SSH. That is what I’ve got after using a dmesg command (part of it):

[    4.239974] mmc1: hw tuning done ...
[    4.239980] mmc1: tuning_window[0]: 0xffffffff
[    4.239985] mmc1: tuning_window[1]: 0xfffffe3f
[    4.239989] mmc1: tuning_window[2]: 0xfff8ffff
[    4.239993] mmc1: tuning_window[3]: 0x63ffffff
[    4.239998] mmc1: tuning_window[4]: 0x0
[    4.240002] mmc1: tuning_window[5]: 0x0
[    4.240029] mmc1: tuning_window[6]: 0x0
[    4.240033] mmc1: tuning_window[7]: 0x0
[    4.240035] sdhci: Tap value: 60 | Trim value: 5
[    4.240038] sdhci: SDMMC_VENDOR_INTR_STATUS[0x108]: 0x40000
[    4.243172] ALSA device list:
[    4.243174]   #0: tegra-hda at 0x3518000 irq 400
[    4.243175]   #1: tegra-snd-t186ref-mobile-rt565x
[    4.244525] tegra-vi4 15700000.vi: initialized
[    4.245139] mmc1: queuing unknown CIS tuple 0x91 (3 bytes)
[    4.245180] mmc1: new ultra high speed SDR104 SDIO card at address 0001
[    4.245845] tegra-vi4 15700000.vi: subdev 150c0000.nvcsi-2 bound
[    4.245848] tegra-vi4 15700000.vi: subdev ov5693 2-0036 bound
[    4.330865] tegra-usb-cd usb_cd: notification status (0x0, 0x1)
[    4.330867] tegra-usb-cd usb_cd: set current 0ma
[    4.330874] tegra-xudc-new 3550000.xudc: exiting ELPG
[    4.331873] tegra-xudc-new 3550000.xudc: exiting ELPG done
[    4.331876] tegra-xudc-new 3550000.xudc: device mode on
[    4.615978] mmc2 tuning done saved tap delay=108
[    4.615981] mmc2: hw tuning done ...
[    4.615991] mmc2: tuning_window[0]: 0xffffffff
[    4.615997] mmc2: tuning_window[1]: 0xf80fffff
[    4.616002] mmc2: tuning_window[2]: 0xffffffff
[    4.616006] mmc2: tuning_window[3]: 0xffffffff
[    4.616011] mmc2: tuning_window[4]: 0x7fffffff
[    4.616035] mmc2: tuning_window[5]: 0xffffffc0
[    4.616040] mmc2: tuning_window[6]: 0xffffffff
[    4.616045] mmc2: tuning_window[7]: 0x7fffffff
[    4.616047] sdhci: Tap value: 108 | Trim value: 5
[    4.616050] sdhci: SDMMC_VENDOR_INTR_STATUS[0x108]: 0x40000
[    4.616069] mmc2: new ultra high speed SDR50 SDHC card at address 0007
[    4.616538] mmcblk1: mmc2:0007 SS08G 7.21 GiB 
[    4.618139]  mmcblk1: p1
[    6.924781] tegradc 15210000.nvdisplay: hdmi: plugged
[    6.978842] tegradc 15210000.nvdisplay: sor_poll_register 0x15: timeout
[    6.986037] tegradc 15210000.nvdisplay: dc timeout waiting for OR MODE = SAFE
[    7.042893] tegradc 15210000.nvdisplay: sor_poll_register 0x16: timeout
[    7.050104] tegradc 15210000.nvdisplay: dc timeout waiting for HEAD MODE = SLEEP
[    7.335843] EXT4-fs (mmcblk0p1): 8 orphan inodes deleted
[    7.341778] EXT4-fs (mmcblk0p1): recovery complete
[    7.355464] EXT4-fs (mmcblk0p1): mounted filesystem with ordered data mode. Opts: (null)
[    7.364748] VFS: Mounted root (ext4 filesystem) on device 179:1.
[    7.373259] devtmpfs: mounted
[    7.377161] Freeing unused kernel memory: 1168K (ffffffc001128000 - ffffffc00124c000)
[    7.385703] Freeing alternatives memory: 96K (ffffffc00124c000 - ffffffc001264000)
[    7.432766] systemd[1]: System time before build time, advancing clock.
[    7.452810] systemd[1]: systemd 229 running in system mode. (+PAM +AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ -LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD -IDN)
[    7.473472] systemd[1]: Detected architecture arm64.
[    7.484030] systemd[1]: Set hostname to <tegra-ubuntu>.
[    7.601606] systemd[1]: Started Forward Password Requests to Wall Directory Watch.
[    7.611413] systemd[1]: Listening on LVM2 metadata daemon socket.
[    7.619785] systemd[1]: Created slice System Slice.
[    7.626816] systemd[1]: Listening on LVM2 poll daemon socket.
[    7.634807] systemd[1]: Created slice system-getty.slice.
[    7.642459] systemd[1]: Listening on udev Kernel Socket.
[    7.650110] systemd[1]: Created slice User and Session Slice.
[    7.658729] systemd[1]: Created slice system-serial\x2dgetty.slice.
[    7.666664] systemd[1]: Reached target Encrypted Volumes.
[    7.673638] systemd[1]: Reached target User and Group Name Lookups.
[    7.681642] systemd[1]: Listening on udev Control Socket.
[    7.688587] systemd[1]: Listening on Journal Socket (/dev/log).
[    7.696031] systemd[1]: Listening on Journal Socket.
[    7.703975] systemd[1]: Mounting Debug File System...
[    7.712088] systemd[1]: Started Braille Device Support.
[    7.721938] systemd[1]: Mounting POSIX Message Queue File System...
[    7.730165] systemd[1]: Listening on Device-mapper event daemon FIFOs.
[    7.739716] systemd[1]: Starting Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling...
[    7.753005] systemd[1]: Listening on /dev/initctl Compatibility Named Pipe.
[    7.763077] systemd[1]: Starting Remount Root and Kernel File Systems...
[    7.775388] systemd[1]: Starting Load Kernel Modules...
[    7.782626] systemd[1]: Reached target Slices.
[    7.789024] systemd[1]: Listening on Journal Audit Socket.
[    7.798081] systemd[1]: Starting Create list of required static device nodes for the current kernel...
[    7.811879] systemd[1]: Listening on Syslog Socket.
[    7.820194] systemd[1]: Starting Journal Service...
[    7.826975] systemd[1]: Reached target Remote File Systems (Pre).
[    7.834873] systemd[1]: Reached target Remote File Systems.
[    7.842314] systemd[1]: Reached target Swap.
[    7.851986] systemd[1]: Mounted POSIX Message Queue File System.
[    7.859823] systemd[1]: Mounted Debug File System.
[    7.868308] systemd[1]: Started Remount Root and Kernel File Systems.
[    7.876980] systemd[1]: Started Load Kernel Modules.
[    7.884202] systemd[1]: Started Create list of required static device nodes for the current kernel.
[    7.896239] systemd[1]: Started Journal Service.
[    8.019975] systemd-journald[292]: Received request to flush runtime journal from PID 1
[    8.106837] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[    8.114743] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[    8.170826] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[    8.178710] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[    8.190704] PD DISP2 index4 DOWN
[    8.195169] PD DISP1 index3 DOWN
[    8.199922] PD DISP0 index2 DOWN
[    8.201299] tegra-pcie 10003000.pcie-controller: 4x1, 1x1 configuration
[    8.203105] tegra-pcie 10003000.pcie-controller: PCIE: Enable power rails
[    8.203496] tegra-pcie 10003000.pcie-controller: probing port 0, using 4 lanes
[    8.205693] tegra-pcie 10003000.pcie-controller: probing port 2, using 1 lanes
[    8.238050] tegradc 15210000.nvdisplay: blank - powerdown
[    8.244204] tegradc 15210000.nvdisplay: hdmi: unplugged
[    8.258542] xhci-tegra 3530000.xhci: cannot find firmware....retry after 1 second
[    8.402910] dhd_module_init in
[    8.405996] tegra_net_perf_init: cannot get wifi sclk
[    8.411645] found wifi platform device bcmdhd_wlan
[    8.421622] wifi_platform_get_country_code_map: could not get country_code_map
[    8.428859] wifi_plat_dev_drv_probe:platform country code map is not available
[    8.436322] Unsupported HDMI VIC 15, ignoring
[    8.440694] Unsupported HDMI VIC 140, ignoring
[    8.441767] Power-up adapter 'DHD generic adapter'
[    8.441773] wifi_platform_set_power = 1
[    8.458316] Unsupported HDMI VIC 10, ignoring
[    8.462844] Unsupported HDMI VIC 208, ignoring
[    8.470800] Unsupported HDMI VIC 138, ignoring
[    8.475777] Unsupported HDMI VIC 32, ignoring
[    8.483976] tegradc 15210000.nvdisplay: blank - powerdown
[    8.486921] tegradc 15210000.nvdisplay: unblank
[    8.486934] PD DISP0 index2 UP
[    8.491907] PD DISP1 index3 UP
[    8.492000] PD DISP2 index4 UP
[    8.494346] Parent Clock set for DC plld2
[    8.546822] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[    8.546824] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[    8.598823] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[    8.598825] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[    8.642831] wifi_platform_bus_enumerate device present 1
[    8.644840] tegra-pcie 10003000.pcie-controller: link 0 down, retrying
[    8.650818] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[    8.650820] tegradc 15210000.nvdisplay: timeout waiting for postcomp init state to promote
[    8.651611] tegradc 15210000.nvdisplay: hdmi: pclk:27027K, set prod-setting:prod_c_54M
[    8.661058] wifi_platform_bus_enumerate device present 0
[    8.661406] F1 signature read @0x18000000=0x17214354
[    8.664845] F1 signature OK, socitype:0x1 chip:0x4354 rev:0x1 pkg:0x2
[    8.665321] DHD: dongle ram size is set to 786432(orig 786432) at 0x180000
[    8.665373] wifi_platform_prealloc: failed to alloc static mem section 7
[    8.665380] wifi_platform_get_mac_addr
[    8.666808] CFG80211-ERROR) wl_setup_wiphy : Registering Vendor80211
[    8.702821] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[    8.702824] tegradc 15210000.nvdisplay: timeout waiting for win assignments to promote
[    8.704806] wl_create_event_handler(): thread:wl_event_handler:1bf started
[    8.704810] CFG80211-ERROR) wl_event_handler : tsk Enter, tsk = 0xffffffc1dfcc1a70
[    8.704892] dhd_attach(): thread:dhd_watchdog_thread:1c0 started
[    8.704913] dhd_attach(): thread:dhd_dpc:1c1 started
[    8.704934] dhd_attach(): thread:dhd_rxf:1c2 started
[    8.704938] dhd_deferred_work_init: work queue initialized 
[    8.705317] Dongle Host Driver, version 1.201.82 (r)
               Compiled in drivers/net/wireless/bcmdhd on Dec  1 2017 at 06:06:28
[    8.705602] tegra_sysfs_register
[    8.705627] Register interface [wlan0]  MAC: 00:04:4b:a7:c2:d3

[    8.705629] dhd_prot_ioctl : bus is down. we have nothing to do
[    8.705709] sdhci-tegra 3440000.sdhci: Tuning already done, restoring the best tap value : 60
[    8.706748] wifi_platform_set_power = 0
[    9.051095] tegra-pcie 10003000.pcie-controller: link 0 down, retrying
[    9.264868] xhci-tegra 3530000.xhci: Firmware timestamp: 2017-03-31 06:21:56 UTC, Version: 55.07 release
[    9.266840] xhci-tegra 3530000.xhci: xHCI Host Controller
[    9.266855] xhci-tegra 3530000.xhci: new USB bus registered, assigned bus number 1
[    9.267638] xhci-tegra 3530000.xhci: hcc params 0x0184fd25 hci version 0x100 quirks 0x00010810
[    9.267660] xhci-tegra 3530000.xhci: irq 59, io mem 0x03530000
[    9.267771] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    9.267774] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    9.267776] usb usb1: Product: xHCI Host Controller
[    9.267777] usb usb1: Manufacturer: Linux 4.4.38-tegra xhci-hcd
[    9.267779] usb usb1: SerialNumber: 3530000.xhci
[    9.268041] hub 1-0:1.0: USB hub found
[    9.268063] hub 1-0:1.0: 4 ports detected
[    9.282962] xhci-tegra 3530000.xhci: xHCI Host Controller
[    9.282968] xhci-tegra 3530000.xhci: new USB bus registered, assigned bus number 2
[    9.283082] usb usb2: New USB device found, idVendor=1d6b, idProduct=0003
[    9.283085] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    9.283087] usb usb2: Product: xHCI Host Controller
[    9.283088] usb usb2: Manufacturer: Linux 4.4.38-tegra xhci-hcd
[    9.283090] usb usb2: SerialNumber: 3530000.xhci
[    9.283320] hub 2-0:1.0: USB hub found
[    9.283337] hub 2-0:1.0: 3 ports detected
[    9.283693] tegra-xotg xotg: otg: host 3530000.xhci registered
[    9.382975] xhci-tegra 3530000.xhci: entering ELPG
[    9.385536] xhci-tegra 3530000.xhci: entering ELPG done
[    9.453623] tegra-pcie 10003000.pcie-controller: link 0 down, retrying
[    9.455644] tegra-pcie 10003000.pcie-controller: link 0 down, ignoring
[    9.858024] tegra-pcie 10003000.pcie-controller: link 2 down, retrying
[    9.913986] cfg80211: World regulatory domain updated:
[    9.913992] cfg80211:  DFS Master region: unset
[    9.913992] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[    9.913998] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[    9.914001] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[    9.914003] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[    9.914006] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[    9.914010] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[    9.914013] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[    9.914016] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[    9.914019] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   10.247350] tegradc 15210000.nvdisplay: hdmi: plugged
[   10.262841] tegra-pcie 10003000.pcie-controller: link 2 down, retrying
[   10.455273] using random self ethernet address
[   10.460600] using random host ethernet address
[   10.474417] Mass Storage Function, version: 2009/09/11
[   10.480590] LUN: removable file: (no medium)
[   10.491177] using random self ethernet address
[   10.496465] using random host ethernet address
[   10.507027] usb0: HOST MAC 0e:c0:6b:24:c6:ba
[   10.512310] usb0: MAC be:01:97:78:79:93
[   10.517343] usb1: HOST MAC 9e:21:a6:7b:bb:eb
[   10.522590] usb1: MAC e6:98:2d:48:e6:35
[   10.527338] tegra-xudc-new 3550000.xudc: ep 0 (type: 0, dir: out) enabled
[   10.548598] device usb0 entered promiscuous mode
[   10.558472] IPv6: ADDRCONF(NETDEV_UP): usb0: link is not ready
[   10.569211] device usb1 entered promiscuous mode
[   10.579550] IPv6: ADDRCONF(NETDEV_UP): usb1: link is not ready
[   10.592775] l4tbr0: port 2(usb1) entered forwarding state
[   10.598838] l4tbr0: port 2(usb1) entered forwarding state
[   10.690840] tegra-pcie 10003000.pcie-controller: link 2 down, retrying
[   10.692863] tegra-pcie 10003000.pcie-controller: link 2 down, ignoring
[   10.692869] tegra-pcie 10003000.pcie-controller: PCIE: no end points detected
[   10.693042] tegra-pcie 10003000.pcie-controller: PCIE: Disable power rails
[   10.852137] android_work: did not send uevent (0 0           (null))
[   10.922856] android_work: sent uevent USB_STATE=CONNECTED
[   10.935791] android_work: sent uevent USB_STATE=DISCONNECTED
[   11.003209] IPVS: Creating netns size=1424 id=1
[   11.026982] android_work: sent uevent USB_STATE=CONNECTED
[   11.034709] configfs-gadget gadget: high-speed config #1: c
[   11.041169] tegra-xudc-new 3550000.xudc: ep 5 (type: 3, dir: in) enabled
[   11.041185] tegra-xudc-new 3550000.xudc: ep 3 (type: 2, dir: in) enabled
[   11.041201] tegra-xudc-new 3550000.xudc: ep 2 (type: 2, dir: out) enabled
[   11.041280] tegra-xudc-new 3550000.xudc: ep 9 (type: 3, dir: in) enabled
[   11.041296] tegra-xudc-new 3550000.xudc: ep 7 (type: 2, dir: in) enabled
[   11.041311] tegra-xudc-new 3550000.xudc: ep 4 (type: 2, dir: out) enabled
[   11.041338] tegra-xudc-new 3550000.xudc: ep 15 (type: 3, dir: in) enabled
[   11.041356] tegra-xudc-new 3550000.xudc: ep 11 (type: 2, dir: in) enabled
[   11.041375] tegra-xudc-new 3550000.xudc: ep 6 (type: 2, dir: out) enabled
[   11.041505] IPv6: ADDRCONF(NETDEV_CHANGE): usb0: link becomes ready
[   11.041580] l4tbr0: port 1(usb0) entered forwarding state
[   11.041596] l4tbr0: port 1(usb0) entered forwarding state
[   11.041683] android_work: sent uevent USB_STATE=CONFIGURED
[   11.041761] tegra-xudc-new 3550000.xudc: setup request failed: -95
[   11.044376] tegra-xudc-new 3550000.xudc: ep 13 (type: 2, dir: in) enabled
[   11.044392] tegra-xudc-new 3550000.xudc: ep 8 (type: 2, dir: out) enabled
[   11.044623] IPv6: ADDRCONF(NETDEV_CHANGE): usb1: link becomes ready
[   11.077980] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   11.080500] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   11.088026] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   11.088099] 
               Dongle Host Driver, version 1.201.82 (r)
               Compiled in drivers/net/wireless/bcmdhd on Dec  1 2017 at 06:06:28
[   11.088101] wl_android_wifi_on in
[   11.088103] wifi_platform_set_power = 1
[   11.335351] gk20a 17000000.gp10b: railgate is disabled.
[   11.359397] mmc1: queuing unknown CIS tuple 0x80 (5 bytes)
[   11.433782] sdhci-tegra 3440000.sdhci: Tuning already done, restoring the best tap value : 60
[   11.443172] F1 signature read @0x18000000=0x17214354
[   11.452486] F1 signature OK, socitype:0x1 chip:0x4354 rev:0x1 pkg:0x2
[   11.459707] DHD: dongle ram size is set to 786432(orig 786432) at 0x180000
[   11.488000] tegradc 15210000.nvdisplay: blank - powerdown
[   11.516884] dhdsdio_write_vars: Download, Upload and compare of NVRAM succeeded.
[   11.558638] dhd_bus_init: enable 0x06, ready 0x06 (waited 0us)
[   11.558905] Enabling wake69
[   11.559894] wifi_platform_get_mac_addr
[   11.561483] Firmware up: op_mode=0x0005, MAC=00:04:4b:a7:c2:d3
[   11.567397] dhd_preinit_ioctls pspretend_threshold for HostAPD failed  -23
[   11.572237] Firmware version = wl0: May  4 2017 13:48:00 version 7.35.221.21 (r697384) FWID 01-58d9d0b3
[   11.574772] dhd_interworking_enable: failed to set WNM info, ret=-23
[   11.574989] tegra_sysfs_on
[   11.847126] CFGP2P-ERROR) wl_cfgp2p_add_p2p_disc_if : P2P interface registered
[   11.872609] WLC_E_IF: NO_IF set, event Ignored
[   12.538848] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[   12.538856] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[   12.590875] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[   12.590885] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[   12.598313] PD DISP2 index4 DOWN
[   12.598516] PD DISP1 index3 DOWN
[   12.598660] PD DISP0 index2 DOWN
[   12.705327] tegradc 15210000.nvdisplay: unblank
[   12.705339] PD DISP0 index2 UP
[   12.706447] PD DISP1 index3 UP
[   12.706537] PD DISP2 index4 UP
[   12.710420] Parent Clock set for DC plld2
[   12.762837] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[   12.762841] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[   12.814830] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[   12.814834] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[   12.866838] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[   12.866844] tegradc 15210000.nvdisplay: timeout waiting for postcomp init state to promote
[   12.867692] tegradc 15210000.nvdisplay: hdmi: pclk:154128K, set prod-setting:prod_c_200M
[   12.867703] tegradc 15210000.nvdisplay: hdmi: pclk:154128K, set prod-setting:prod_c_300M
[   12.922850] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[   12.922854] tegradc 15210000.nvdisplay: timeout waiting for win assignments to promote
[   13.927773] eqos 2490000.ether_qos eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[   13.929068] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   14.027649] tegradc 15210000.nvdisplay: unblank
[   14.083541] CPU1: shutdown
[   14.086262] psci: CPU1 killed.
[   14.098868] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[   14.105860] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[   14.116396] CPU2: shutdown
[   14.119380] psci: CPU2 killed.
[   15.162853] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[   15.169435] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[   16.030900] tegradc 15210000.nvdisplay: tegra_nvdisp_wait_for_common_channel_to_promote: DC 1 timed out waiting for COMMON promotion
[   17.644000] fuse init (API version 7.23)
[   19.241767] IPVS: Creating netns size=1424 id=2
[   19.326831] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[   19.333375] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[   20.394879] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[   20.401602] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[   21.414004] tegradc 15210000.nvdisplay: blank - powerdown
[   22.462909] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[   22.462923] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[   22.514859] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[   22.514869] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[   22.527855] PD DISP2 index4 DOWN
[   22.528933] PD DISP1 index3 DOWN
[   22.529470] PD DISP0 index2 DOWN
[   22.578352] tegradc 15210000.nvdisplay: unblank
[   22.578386] PD DISP0 index2 UP
[   22.579819] PD DISP1 index3 UP
[   22.579959] PD DISP2 index4 UP
[   22.585364] Parent Clock set for DC plld2
[   22.638856] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[   22.638863] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[   22.690837] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[   22.690843] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[   22.742843] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[   22.742850] tegradc 15210000.nvdisplay: timeout waiting for postcomp init state to promote
[   22.743727] tegradc 15210000.nvdisplay: hdmi: pclk:154128K, set prod-setting:prod_c_200M
[   22.743741] tegradc 15210000.nvdisplay: hdmi: pclk:154128K, set prod-setting:prod_c_300M
[   22.806850] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[   22.806859] tegradc 15210000.nvdisplay: timeout waiting for win assignments to promote
[   23.897117] tegradc 15210000.nvdisplay: unblank
[   23.958833] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[   23.965378] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[   24.902894] tegradc 15210000.nvdisplay: tegra_nvdisp_wait_for_common_channel_to_promote: DC 1 timed out waiting for COMMON promotion
[   25.022853] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[   25.029511] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[   25.642824] l4tbr0: port 2(usb1) entered forwarding state
[   26.090827] l4tbr0: port 1(usb0) entered forwarding state
[   26.329323] IPVS: Creating netns size=1424 id=3
[   26.786831] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[   26.793928] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[   26.914840] tegradc 15210000.nvdisplay: tegra_nvdisp_wait_for_common_channel_to_promote: DC 1 timed out waiting for COMMON promotion
[   27.859986] EXT4-fs (mmcblk1p1): recovery complete
[   27.864846] EXT4-fs (mmcblk1p1): mounted filesystem with ordered data mode. Opts: (null)
[  957.367648] tegradc 15210000.nvdisplay: blank - powerdown
[  959.426921] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[  959.426936] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[  959.478859] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[  959.478869] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[  959.492753] PD DISP2 index4 DOWN
[  959.493823] PD DISP1 index3 DOWN
[  959.494441] PD DISP0 index2 DOWN
[ 1314.063746] tegradc 15210000.nvdisplay: hdmi: unplugged
[ 1314.093161] tegradc 15210000.nvdisplay: blank - powerdown
[ 1314.098689] tegradc 15210000.nvdisplay: unblank
[ 1314.103316] tegradc 15210000.nvdisplay: unblank
[ 1317.347900] Unsupported HDMI VIC 15, ignoring
[ 1317.352317] Unsupported HDMI VIC 140, ignoring
[ 1317.356846] Unsupported HDMI VIC 10, ignoring
[ 1317.361347] Unsupported HDMI VIC 208, ignoring
[ 1317.365852] Unsupported HDMI VIC 138, ignoring
[ 1317.370371] Unsupported HDMI VIC 32, ignoring
[ 1317.374876] tegradc 15210000.nvdisplay: blank - powerdown
[ 1317.380465] tegradc 15210000.nvdisplay: hdmi: plugged
[ 1317.393104] tegradc 15210000.nvdisplay: Invalid out_w + out_x (1920) > hActive (720)
                OR/AND out_h + out_y (1200) > vActive (480)
                for WIN 0
[ 1317.411712] tegradc 15210000.nvdisplay: blank - powerdown
[ 1317.417188] tegradc 15210000.nvdisplay: unblank
[ 1317.417205] PD DISP0 index2 UP
[ 1317.418259] PD DISP1 index3 UP
[ 1317.418358] PD DISP2 index4 UP
[ 1317.420559] Parent Clock set for DC plld2
[ 1317.474846] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[ 1317.474854] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[ 1317.526834] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[ 1317.526841] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[ 1317.578845] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[ 1317.578855] tegradc 15210000.nvdisplay: timeout waiting for postcomp init state to promote
[ 1317.579766] tegradc 15210000.nvdisplay: hdmi: pclk:154128K, set prod-setting:prod_c_200M
[ 1317.579784] tegradc 15210000.nvdisplay: hdmi: pclk:154128K, set prod-setting:prod_c_300M
[ 1317.634838] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[ 1317.634844] tegradc 15210000.nvdisplay: timeout waiting for win assignments to promote
[ 1318.725145] tegradc 15210000.nvdisplay: unblank
[ 1318.786830] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[ 1318.793418] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[ 1319.730902] tegradc 15210000.nvdisplay: tegra_nvdisp_wait_for_common_channel_to_promote: DC 1 timed out waiting for COMMON promotion
[ 1319.854857] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[ 1319.861510] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[ 1320.883085] tegradc 15210000.nvdisplay: blank - powerdown
[ 1321.742902] tegradc 15210000.nvdisplay: tegra_nvdisp_wait_for_common_channel_to_promote: DC 1 timed out waiting for COMMON promotion
[ 1322.798909] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[ 1322.798924] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[ 1322.850850] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[ 1322.850861] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[ 1322.863498] PD DISP2 index4 DOWN
[ 1322.864652] PD DISP1 index3 DOWN
[ 1322.865137] PD DISP0 index2 DOWN
[ 1322.926245] tegradc 15210000.nvdisplay: unblank
[ 1322.926277] PD DISP0 index2 UP
[ 1322.927665] PD DISP1 index3 UP
[ 1322.927808] PD DISP2 index4 UP
[ 1322.933219] Parent Clock set for DC plld2
[ 1322.986845] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[ 1322.986852] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[ 1323.038835] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[ 1323.038841] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[ 1323.090850] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[ 1323.090861] tegradc 15210000.nvdisplay: timeout waiting for postcomp init state to promote
[ 1323.091783] tegradc 15210000.nvdisplay: hdmi: pclk:154128K, set prod-setting:prod_c_200M
[ 1323.091802] tegradc 15210000.nvdisplay: hdmi: pclk:154128K, set prod-setting:prod_c_300M
[ 1323.154849] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[ 1323.154858] tegradc 15210000.nvdisplay: timeout waiting for win assignments to promote
[ 1324.245206] tegradc 15210000.nvdisplay: unblank
[ 1324.302836] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[ 1324.309380] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[ 1325.246889] tegradc 15210000.nvdisplay: tegra_nvdisp_wait_for_common_channel_to_promote: DC 1 timed out waiting for COMMON promotion
[ 1325.370876] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[ 1325.377534] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[ 1326.462821] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[ 1326.469349] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
[ 1327.258897] tegradc 15210000.nvdisplay: tegra_nvdisp_wait_for_common_channel_to_promote: DC 1 timed out waiting for COMMON promotion
[ 1327.926852] tegradc 15210000.nvdisplay: dc_poll_register 0x41: timeout
[ 1327.933431] tegradc 15210000.nvdisplay: dc timeout waiting for DC to stop
nvidia@tegra-ubuntu:~$ sudo get-edid | edid-decode
-bash: edid-decode: command not found
[sudo] password for nvidia: 
This is read-edid version 3.0.2. Prepare for some fun.
Attempting to use i2c interface
No EDID on bus 0
No EDID on bus 1
No EDID on bus 2
No EDID on bus 3
No EDID on bus 4
No EDID on bus 5
No EDID on bus 6
No EDID on bus 8
1 potential busses found: 7
Bus 7 doesn't really have an EDID...
Couldn't find an accessible EDID on this computer.

Can anyone help me with solving this problem?
Thanks,
Marcin

I see “Unsupported HDMI VIC”. Is this a 4k display? Does this show up if you boot with a non-4k monitor? Have you tried booting without a monitor, and then plugging it in after boot?

What do you get from “sudo cat /sys/kernel/debug/tegradc.0/edid”?

Can you add this to your “/etc/X11/xorg.conf” file Section “Device”:

Option   "ModeDebug"

…then post the content of “/var/log/Xorg.0.log” after booting with the monitor, disconnecting the monitor, and then reconnecting the monitor.

See also:
https://elinux.org/Jetson_TX2/r28_Display_debug

No, its not a 4k display, its only 1920x1280 monitor. Logs form dmesg which I have pasted in first post were generated when I powered up Jetson with a HDMI cable connetecd to monitor and jetson. Between monitor and HMDI cable there were a HDMI to VGA converter (becuse monitor dont have a HDMI port). Then I disconnected and connected cable to jetson multiple times, it can be seen in a log. After that I tried to boot jetson with and without connected HDMI cable and connect it after few minutes after powered up jetson. In all cases result was the same, there were no signal at monitor. Also I connected a HDMI to HDMI cable (without converter) to other samll monitor with low max resolution (1280 x 720 ) and tried all of these combinations with connecting and disconnecting cable but without different result.

Now I gonna try that what You linuxdev suggested and gonna write logs in next post.
Thanks for suggestions and the help.

This log is weird. Could you use jetpack3.1 first to see if it can work?

[ 1317.347900] Unsupported HDMI VIC 15, ignoring
[ 1317.352317] Unsupported HDMI VIC 140, ignoring
[ 1317.356846] Unsupported HDMI VIC 10, ignoring
[ 1317.361347] Unsupported HDMI VIC 208, ignoring
[ 1317.365852] Unsupported HDMI VIC 138, ignoring
[ 1317.370371] Unsupported HDMI VIC 32, ignoring
[ 1317.374876] tegradc 15210000.nvdisplay: blank - powerdown
[ 1317.380465] tegradc 15210000.nvdisplay: hdmi: plugged
[ 1317.393104] tegradc 15210000.nvdisplay: Invalid out_w + out_x (1920) > hActive (720)
                OR/AND out_h + out_y (1200) > vActive (480)
                for WIN 0

720x480 looks like a mode we added in device-tree on rel-28.2, but rel-28.1 does not have it. So it should have chances avoiding it.

The HDMI-to-VGA adapter completely removes any ability to auto configure. The DDC wire provides EDID data when the video card queries the monitor…this wire is cut for VGA and does not exist. The driver requires EDID data to work.

There are some cases where hot plug layers may at times, under various circumstances, happen to select a mode your monitor supports. It is a case of being lucky.

Also I connected a HDMI to HDMI cable (without converter) to other samll monitor with low max resolution (1280 x 720 ) and tried all of these combinations with connecting and disconnecting cable but without different result.

According to MarcinCVdev, seems issue is still there even without converter.

I thing it was a problem with HDMI-to-VGA. With hdmi to hdmi cable on other monitor there were no problems with display, but when I logged into jetson i saw there are no installed libraries like opencv etc. (I have selected full instalation). SoI have started installation again. Its other topic but there were problems with cuda library isntallation: I had this message:
Sorry for image, but I coudn’t copy and paste text.
It looks like there is a problem with internet connection on jetson… any way main problem is SOLVED.

I don’t know about the specific errors, but keep in mind you can run JetPack again at any later date and simply uncheck flash or host package installs when you want to experiment with Jetson extra software. Flash itself never installs extras…extras occur over wired ethernet after the Jetson reboots into a running system. Many times the error involved is because JetPack doesn’t detect the IP address of the Jetson (in which case you can enter this manually).

Sometimes you may need package “ssh-askpass” on the host PC if ssh wants to use a GUI pop-up for passwords. Sometimes the terminal in JetPack needs you to enter a password. In every case your router should have a log of what address was assigned to the Jetson (sometimes the router is a dedicated appliance, sometimes the host PC is acting as a router).

In some cases flashing a Jetson may result in keys previously memorized on the host for the Jetson changing, and thus ssh denying connection for fear of a man-in-the-middle attack (your host would need to “forget” the previously acquired keys for that case).