HDMI Output Not Working

Hi,

I just got JetPack 4.1.1 to flash L4T to the Xavier module, but there is no HDMI output coming from the device it seems.

Can you advise on any known bugs/issues with this?

I am able to SSH in, and I have setup a VNC server, so I know the OS is running etc.

Is there some other test I can run from the command line to test the HDMI interface on the carrier?

Is there any issue known with using an HDMI to DisplayPort adapter?

Hi dan.binnun,

May I know if you are using xavier devkit? We don’t suggest the use of adapter and JP4.1.1 is a developer preview. I would suggest to use JP4.2.

Also, there are 3 heads on xaiver devkit that can run as display head. There is a HDMI port and 2 type C ports which support DP. You just need a DP to typeC cable.

If you insist using the HDMI port and it got nothing, please share the dmesg with us and I can help check.

I am using the development kit for Xavier yes.

I would have loved to have used JetPack 4.2, but since I am in a VM environment I had to just figure something out to get some source on there.

My end goal here is to figure out how to rebuild a custom device tree into the image for a custom carrier board we designed.

I am far from a Linux expert, so I may be missing something in the dmesg output.

When I search it for HDMI, this is what comes up:

[    1.120693] vdd-hdmi-5v0: 5000 mV 

[    1.857362] tegradc 15200000.nvdisplay: hdmi: invalid prod list prod_list_hdmi_board

[    1.857452] tegradc 15200000.nvdisplay: hdmi: tegra_hdmi_tmds_range_read(bd) failed

[    4.722491] input: tegra-hda-galen-t194 HDMI/DP,pcm=3 as /devices/3510000.hda/sound/card0/input0

[    4.723725] input: tegra-hda-galen-t194 HDMI/DP,pcm=7 as /devices/3510000.hda/sound/card0/input1

[    4.726056] input: tegra-hda-galen-t194 HDMI/DP,pcm=8 as /devices/3510000.hda/sound/card0/input2

[    4.726265] input: tegra-hda-galen-t194 HDMI/DP,pcm=9 as /devices/3510000.hda/sound/card0/input3

Trying to attach the putty log file from the dmesg…
putty.txt (66.7 KB)

Update:

When I plug in directly to my LG 4K monitor’s HDMI input from the module I get the following in dmesg:

[ 3364.327213] tegradc 15200000.nvdisplay: hdmi: tmds rate:594000K prod-setting:prod_c_hdmi_300m_600m
[ 3364.366255] tegradc 15200000.nvdisplay: hdmi: plugged
[ 3364.581762] tegradc 15200000.nvdisplay: hdmi: tmds rate:594000K prod-setting:prod_c_hdmi_300m_600m

But still no video output on the monitor

Update:

After changing the desktop manager to LightDM instead of the default the HDMI output started to work, booting to the CLI finally on HDMI.

It does not launch into the GUI desktop, but that may be due to the distro being minimalist.

Running startx does launch the Gnome desktop.

Update:

After unminimizing the distro, and reconfiguring lightdm to be the desktop manager again the device now reboots into the full Gnome desktop with launcher and icons etc.

Glad to hear that is resolved. I am not sure when do we shift the display manager from lightdm to gdm. We are using gdm on rel-32.1 now. Please note that we don’t suggest user to use VM anyway.

I am running into a similar issue. After trying to install the latest jetpack 4.4, my hdmi port stopped working. The monitor says that it is not receiving a hdmi signal. I tried plugging other sources into the monitor, so I know the monitor and the cable are fine.

I tried downgrading by manually flashing jetpack 4.3 as described in this post (Xavier Update Difficulties) and that process seems to complete successfully. But even so, the monitor does not detect hdmi signal on reboot. I have captured the log from the manual flash. I have also captured the log from the debug port during the manual flash and another log from a regular bootup after the manual flash. manualflash.log (43.6 KB)

Could someone take a look at these logs and suggest a solution? I hope I haven’t bricked the board. I’m not sure how the original poster was able to reconfigure the desktop manager. But I would love to try that solution… or any other solution for that matter.
debug.log (49.4 KB) flash0904.log (350.6 KB)

There is problem with HDMI if the Jetson AGX Xavier is Flashed with latest jet-packs (4.4.1).

Solution

The initial boot requires USB-C to HDMI converter. After the first boot remove the converter and connect the HDMI without turning off the machine. The HDMI will work now.

Sudo apt-get update
Sudo apt-get upgrade

will solve the HDMI issue then The HDMI will work fine without converter.

After first boot with USB-C to HDMI converter. proper update is fine need not convert it into lightDM.
but Drawback is sing USB-c to HDMI converter for first boot.