JetPack 4.2.1: Xavier: No output on screen after flash


I flashed my Xavier with JetPack 4.2.1 using NVIDIA’s SDKManager. The Jetson OS has been successfully flashed on to the Xavier. However, I am not getting on the screen in order for me to complete the “System configuration wizard”.

I have tried different HDMI cable and port on the monitor. Everything was working perfectly with JetPack 4.2 (R32.1) running on the same Xavier.

Please let me know how to resolve this.

EDIT: For some reason I am unable to “EXPORT LOGS” on SDKManager (v0.9.13.4763)
xavier_r32-2_JetPack_4-2-1_no-screen.log (93.4 KB) (1.27 MB)

I haven’t actually gotten around to flashing with 4.2.1 yet, but I remember seeing that what gets installed will change depending on whether a monitor is detected during the flash. Was the HDMI monitor attached during the flash? Or was it added after the flash? If not until after flash, then you might try flashing again with monitor attached during the flash. That might help, not sure.

The monitor was attached when I flashed it first and again during re-flash.

You are right that if monitor is not attached during flash, it is not detected later, however rebooting the system works because it then detects the monitor and displays the output.

I am updating original post to also attach the “flash” logs in case that helps.

I am not yet familiar with the 4.2.1 logs, but I saw a number of errors in creation of the rootfs image during the conversion from raw to sparse image. Someone else who knows the 4.2.1 logs better will need to answer, but one thing I’d verify first is that you actually have enough disk space available (“df -H ~/nvidia”).

I have always seen those errors but since everything works as expected I never paid attention to it.

There’s almost 120GB space available on the disk which should be more than enough

Okay, some more info. I flashed another Xavier with JetPack 4.2.1 and everything worked.

So, does this mean that the HDMI port might have gone bad? I also tried flashing the same Xavier with R32.1 (JP 4.2) also had blank screen.

I will try to reflash this Xavier again and see if that works otherwise what next step should I take to resolve this issue?


For now I have been able to move ahead with the flash process by connecting a USB-C-to-HDMI cable. The other packages are not installing on the Xavier.

But, I think the HDMI port on the Xavier has gone bad. I will try to debug that. I will close the post now.