Jetson Xavier does not boot after flash - Jetpack 4.2.1


I am trying to flash a new Jetson Xavier I have received recently. Unfortunately, the device does not finish to boot and I cannot access the Ubuntu wizard.

I have looked for some hints on the forum (reinstalling SDK Manager, changing USB cable, from a terminal using the script but did not find anything that could solve my problem, so any help will be welcome ^^"…

I have attached the log from the boot (retrieve via the serial port) and the log of the flash.

I also found those lines but I am not sure if they are relevant:

[0002.335] E> Error -9 when finding node with path /boot-configuration
[0002.337] E> tegrabl_cbo_parse_info: "boot-configuration" not found in CBO file.

For the detail, I am trying to install the Jetpack 4.2.1 rev 2 with SDK Manager


EDIT: I have also try to flash Jetpack 4.2.2 rev 1 and I got the same result.
jetson-boot.log (61.1 KB)
flash.log (318 KB)


In your log, the system is able to boot into kernel and does not hang during bootloader. It looks not like boot issue. However, bootloader has hdmi log but kernel does not.

Are you able to see nvidia logo and then it becomes blanked?

Hi WayneWWW,


Is this a nvidia devkit? Is this monitor using native HDMI port? or is there any display converter to conver DVI or VGA to HDMI?

Please try this script to bypass the configuration wizard and we can debug the display issue.

Yes, it is an Nvidia Xavier devkit. I use a native HDMI port without any converter. I also tried with a USB C to HDMI with the sample result. I have a few other Xavier which does not reproduce the issue.

I will give it a try and let you know. Thanks.

If only one xavier hits this issue, then it is possible a hardware issue.

Anyway, please go ahead with the script first.

Hi Wayne,

Sorry for the delay, I had to take care of other matters.

I did not have the time to try the script you have suggested so we just decided to return the Jetson to our provider.

But as you said, it is probably a hardware issue. Anyway, thank for the help!