Jetson xavier agx fails to flash and gets stuck at nvidia logo i.e it fails to enter the configuration wizard

Hi, i recently bought jetson agx xavier and when I try to flash it using sdk manager it gets stuck at nvidia logo screen in my HDMI monitor, it looks like it is not able to find the IP address and the default IP address doesn’t work.
I am using ubuntu 18.04
Below are the logs (335.2 KB)

According to your log and your description, the board is flashed successfully.

What you need to share is the boot uart log, the flash log does not matter anymore.

Dear WayneWWW,

We can’t find any ttyUSB* or ttyACM* in my host PC while connected to Jetson Xavier AGX. I have already tried accessing it via serial console ( minicom and

gktterm) However I am not able to access the board. I have also tried, manually creating the ttyUSB0 file but still no luck .


Which port did you connect here? The ttyUSBx is from the micro usb port of the NV devkit. Not the type C ports.

Please be careful if you are not using the NVIDIA devkit, then it has chance not this port.

we are connecting the front type C port of the jetson agx to the host PC using the usb to Type C connector provided with the jetson agx kit. .

we just flashed it, we still can’t see the first boot configuration screen.

Please check the log from micro usb port … as I said in previous comment…

how to check the log from micro usb?

After you connect it to your host, you shall see ttyUSB3 on your host… then it is back to the serial console post I shared in the beginning…

this is my connection, even after connecting to microUSB when I try “ls -l /dev/ttyUSB*” it says “ls: cannot access ‘/dev/ttyUSB*’: No such file or directory”

Are you sure your mirco usb cable isn’t just a charging cable?

Yes i have replaced the cable, i can see ttyUSB3 but still no logs

dmesg --follow shows this

Here is the Serial Console log file uartLog.txt (149.1 KB)

According to the log, your board keeps rebooting. I cannot check the cause because the we need to enable more logs.

Please go to ~/nvidia/ on your host, find out Linux_for_Tegra/rootfs/boot/extlinux/extlinux.conf and remove the “quiet” keyword inside this and then reflash your board again with

Also, do you have other AGX devices to test?

We have extlinux.conf file inside bootloader folder and Linux_for_Tegra/rootfs/boot is empty.

should we put this in the boot folder

i dont have any other agx

that is Linux_for_Tegra//bootloader/extlinux.conf

No, this should not happen. Where did your Linux_for_Tegra come from?

According to your log, the Linux_for_Tegra installed by SDKM should be


Are you sure you are talking about the same path?

i have removed quiet and flashed againflash-logs (120.2 KB)