Jetson AGX Xavier not booting to desktop after Flash


We purchased four NVidia AGX Xavier Development Kits for a project I’m working on. I have three of them flashed and working fine. However, one of them has an issue. It reboots after the flash and I do see the ubuntu configuration screen. Afterwards, it hangs at boot and never enters the Ubuntu desktop. I can continue with STEP 03 since SSH is working fine. However there’s no desktop displayed out the HDMI port. Just boot text on the Xavier’s display. I’ve tried re-flashing it several times. I also re-flashed another one of the AGX’s from the same Ubuntu 18.04 system and it worked perfectly. So I believe my SDK Manager and OS images are good. I’ve spent some time trying to debug it in the SSH terminal but not really sure what to do from here. Could this be a hardware issue?

Any help would greatly be appreciated. Thanks in advance!

2 suggestions:

  1. verify that all 4 of the Xavier Dev Kits are the exact same version, for example 32 GB vd 26 GB or commercial vs industrial version
  2. instead of flashing manually, try flashing with SDKmanager

Thanks for the reply…

They are all 32GB. I’m not sure how to tell if they are industrial. I assume commercial because it doesn’t say industrial on any of the boxes.

I’m using the SDKManager in Ubuntu 18.04.

On the unit which gets to the user setup screen, but doesn’t allow you to continue, see what happens if you either power cycle or hit the reset button. Normally I wouldn’t recommend that (corrupted filesystem with need for journal recovery), and although I haven’t experienced it myself, I believe some people have had the login setup work correctly after the power reset.

I’ve power cycled many times. It doesn’t go back to the configuration screen but shows the boot text above and then screen goes blank.

I SSH’d into it and made it boot to command line. From there I see the errors in the image (which I don’t see on my other AGX’s)


I also attempted to run “sudo systemctl start gdm3.service” with no luck. Screen went blank.

Then I tried “startx” and received the below error text. Note the “no screens found”. I’ve seen this in other boot logs.


I figured it out.

We received this one with an 1TB NVMe SSD already installed. It was unexpected. Someone else on our project ordered these for us.

I replaced it with a Western Digital 1TB NVMe SSD and it booted right up into the Desktop. CUDA samples work and everything.

Thanks for the replies!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.