Trouble getting HDMI output on Jetson after fresh JetPack installation.

I’m having trouble getting HDMI output on my Jetson, so I can only login via UART and SSH.

I followed the instructions for full install of r21.3-6-5 by running from host computer. That seemed to go okay.

I’m able to SSH in, and do SSH X forwarding. But of course the OpenGL examples don’t work on my host machine (VMWare running Ubuntu 14.04 on Windows 7).

The boot messages indicate “this pci device is not a vga device”, and my startx log reports “No screens found” immediately after “Loading extension GLX”. I’ve tried deleting the xorg.conf and letting it reboot, but it seems to auto-generate the same one as before. I tried sudo apt-get install nvidia-current, but that is not found. I tried adding repositories universe and multiverse, then apt-get-update, and retried the nvidia-current, but still no luck.

I’m also not sure how the JetPack installation (which involves complete top-down reflashing of the device) relates to the initial startup instructions which also tell me to reflash. I was able to run that when I pulled the Jetson out of the box, but I didn’t have an HDMI cable at the time, so I’m not sure if that would have run. I’m afraid to run the “getting started” flash instructions again in case in wipes out my entire JetPack installation, since that took quite a while to install.

I tried Xorg -configure, and that lists “nvidia” as one of the drivers available (along with omap, modesetting, vesa, and fbdev), but then tells me “No devices to configure”, and fails.

Finally, my HDMI cable is actually going through a DisplayPort adapter before reaching the monitor, so I don’t think that should be a problem, but I thought I’d mention it in case for some reason it prevents the detection of the monitor.

So to summarize:

  1. What’s the difference between the “getting started” instructions to flash the device, vs. the JetPack?
  2. How do I install and/or verify the nvidia HDMI driver?


When flashing device, JetPack is following the steps 1-4 of the INSTRUCTIONS section on

Possible issues…

Sometimes a VM won’t flash Jetson correctly if file system permissions are not fully supported. Failing to use sudo during unpack causes this; using a VM loaded onto a non-linux file system does this (e.g., if VM just runs directly on NTFS, linux permissions cannot be supported).

HDMI adapters which fail to properly pass through EDID data will always fail…EDID is needed for detection. An adapter going through any kind of VGA always fails, as VGA itself has no DDC/EDID. DisplayPort might work, this has EDID/DDC…the question is whether the adapter and monitor combination do this correctly.

“this pci device is not a vga device” is not an issue. I believe this is just graphics trying to find GPUs to use for display, and the Kepler is detected but it isn’t a video card function.

The original Jetson comes with R19.2, which has the INSTALL directory with the extra steps to complete the nVidia-specific file setup. This is antiquated and does not appear and is not required except on R19.2. Newer L4T flashes complete this via the “” script, which gets put onto the image that flashes to Jetson. To test if nVidia-specific files are in place, run this:

sha1sum -c /etc/nv_tegra_release

If there is some issue with the flash, I’d suggest any re-flash should skip JetPack and just run the base R21.3 flash by itself for testing. Always do everything during install with sudo, or as root (such as root shell via sudo -s). Any failure to preserve permissions (including during unpacking) is cause for failure to some extent.