No such file or directory #include "crt/host_defines.h"

After installing Deepstream in my ubuntu 18.04. I tried running reference application.
I got the following error when I tried to build using " sudo CUDA_VER=11.4 make "

cc -c -o deepstream_test1_app.o -I…/…/…/includes -I /usr/local/cuda-11.4/include -pthread -I/usr/include/gstreamer-1.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include deepstream_test1_app.c
In file included from deepstream_test1_app.c:26:0:
/usr/local/cuda-11.4/include/cuda_runtime_api.h:147:10: fatal error: crt/host_defines.h: No such file or directory
#include “crt/host_defines.h”
compilation terminated.
Makefile:63: recipe for target ‘deepstream_test1_app.o’ failed
make: *** [deepstream_test1_app.o] Error 1

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.