Docker:: DeepStream Triton Inference Server, deepstream-test1 sample app error : cuda_runtime_api.h: No such file or directory

I’m new to Nvidia DeepStream and trying DeepStream Triton Inference Server using Docker to run “apps/sample_apps/deepstream-test1” sample app. During make, its spits error as following:

cc -c -o deepstream_test1_app.o -I…/…/…/includes -I /usr/local/cuda-10.2/include -pthread -I/usr/include/gstreamer-1.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include deepstream_test1_app.c
deepstream_test1_app.c:26:10: fatal error: cuda_runtime_api.h: No such file or directory
#include <cuda_runtime_api.h>
^~~~~~~~~~~~~~~~~~~~
compilation terminated.
Makefile:64: recipe for target ‘deepstream_test1_app.o’ failed
make: *** [deepstream_test1_app.o] Error 1

Please suggest any solution!

Ah, just solved it, turns out in the Makefile needs the same CUDA_VER as mentioned in “nvcc --version”. So, we need to run it as following:

CUDA_VER=your_cuda_version_as_in_“nvcc --version” make

In my case I tried:

nvcc --version
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2020 NVIDIA Corporation
Built on Tue_Sep_15_19:10:02_PDT_2020
Cuda compilation tools, release 11.1, V11.1.74
Build cuda_11.1.TC455_06.29069683_0

so, the command will be:

CUDA_VER=11.1 make

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.