Noob, Fortran, Cuda, Desperate, Last try... I burn my GTX if i dont get any reply...

Hi everybody,

I won’t annoy you repeating myself.
I have reached this point where i am actually desperate. I feel like i am the only entity of this universe which is currently trying to build the Fortran CUBLAS example (Fortran_Cuda_Blas.tgz) under Windows XP (yes I know it’s not the case, everybody knows how to do it, it’s just me <-- stupid noob)… <img src=‘http://hqnveipbwb20/public/style_emoticons/<#EMO_DIR#>/crying.gif’ class=‘bbc_emoticon’ alt=’:’(’ /> <img src=‘http://hqnveipbwb20/public/style_emoticons/<#EMO_DIR#>/crying.gif’ class=‘bbc_emoticon’ alt=’:’(’ /> <img src=‘http://hqnveipbwb20/public/style_emoticons/<#EMO_DIR#>/crying.gif’ class=‘bbc_emoticon’ alt=’:’(’ />

:teehee: But it’s ok…:teehee:

I have a hammer, and i know that at least one CUDA programmer will feel concerned about the likely interaction between this everyday tool and one brand new 8800 GTX…
:spaz:

Someone is gonna reply to my scream in the ocean, one day… :haha: :fear: :haha: :fear:

:wave:

Sorry, I can’t help because I don’t use Fortran, CUBLAS, or XP for my project, but the threat of hardware violence made it worth a reply. Thanks for the laugh!

EDIT: I had one idea - are you sure you have the CUBLAS library in your linker command?

You have the error message in the post you reference but I don’t see the commands you used to compile/link. Could you share those?

First of all, thank you guyz for replying !!! :D

About your first question, i am quit sure i have my CUBLAS library in my linker command :

"Compiler options (yes, I know it’s VS):

/nologo /Zi /O3 /fpp /include:“D:\Projects\CUDA\ICUBLAS” /DCUBLAS /gen-interfaces /warn:interfaces /module:“Debug\” /object:“Debug\” /traceback /check:bounds /libs:static /threads /dbglibs /c"

"Linker options:

/OUT:“Debug\icublas.exe” /INCREMENTAL:NO /NOLOGO /LIBPATH:“D:\Projects\CUDA\ICUBLAS\icublas” /MANIFEST /MANIFESTFILE:“D:\Projects\CUDA\ICUBLAS\icublas\icublas\debug\icublas.exe.intermediate.manifest” /DEBUG /PDB:“D:\Projects\CUDA\ICUBLAS\icublas\icublas\debug\icublas.pdb” /SUBSYSTEM:CONSOLE D:\Projects\CUDA\ICUBLAS\cublas.lib D:\Projects\CUDA\ICUBLAS\icublas\cudart.lib

"

With the Fortran CUBLAS example a small wrapper “fortran.c” is provided, my guess is that all my problems come from my inability to compile and link this wrapper with my “sgemm_speed.f90” code (I have tried under Intel Visual Fortran and Compaq Visual Fortran). Have you ever done such things ? Do i have to change of compiler ? If yes, can I compile CUDA under cygwin with g95?

A lot of questions that may or may not find an answer in our next episode : “Hard Times for Noob”.

To be followed…

:wave:

You cannot use CUDA under cygwin.

I’ve never used fortran in windows and only once used it long ago in linux. There, I could link in C code by compiling the C code to an object file (gcc -c fortran.c) and link it into the fortran executable (fortran-compiler -o exec fortran_code.f fortran.o).

In visual studio, I’m not sure if you can link object files like that directly into the executable. You may have better luck compiling the c wrapper as a static library, then linking that static library to your fortran code.

Why is it impossible to use CUDA from cygwin? Assuming you use the command line versions of the microsoft/intel compilers, I don’t see how it is really any different calling them from a command line than using the GUI. But I also haven’t actually tried, so please enlighten me.

You can use cygwin if you are using the command line version of the Microsoft compilers. You can not use gcc on Windows.

Yeah, I meant you can’t use gcc within cygwin: http://forums.nvidia.com/index.php?showtop…ndpost&p=204016

I didn’t realize anyone would use the command line visual studio compilers from within cygwin.